Debugging error

Hi I have a pc router with OpenWrt 21.02.2 and from time to time the router goes into a loop where I get disconnected from the LAN and WAN, so the only way I regain connection is to power off and on. But I can't find the logs and don't know where to start. The only thing I have is the following picture showing the loop.

If anyone can give me a hint on what to do next, I will be grateful.

v21 is EOL, upgrade.

1 Like

Ok, I re-install and move to version 23.5.3 and I'm having the same problem. I test the same version in a commercial router and I don't have any problem. So I thing it's hardware relate. I test the ram and no problem.

Since you have on a computer, write the log to disk, to be able to see the crashed log, after a reboot.

Let's have a look at your config to make sure there's nothing obviously wrong:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

First, I can't connect using ssh since no LAN connection is possible, but on the other side I don't have a monitor and keyboard.

So here are the files ask, and some logs I can acquire while having the problem, and I'm starting to believe the problem is related to ddns script, although I'm not sure.

ubus
{
	"kernel": "5.15.150",
	"hostname": "router",
	"system": "Intel(R) Celeron(R) CPU  J1800  @ 2.41GHz",
	"model": "ASRock D1800M",
	"board_name": "asrock-d1800m",
	"rootfs_type": "ext4",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.3",
		"revision": "r23809-234f1a2efa",
		"target": "x86/64",
		"description": "OpenWrt 23.05.3 r23809-234f1a2efa"
	}
}
Network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda5:d80e:a2da::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'


firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone 'lan'
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'
	list device 'tun+'

config zone 'wan'
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'
	list network 'wwan'
	option masq '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config redirect
	option target 'DNAT'
	option name '80'
	option src 'wan'
	option src_dport '80'
	option dest_ip '192.168.3.10'
	option dest 'lan'
	option family 'ipv4'
	list proto 'tcp'
	option dest_port '80'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name '443'
	option src 'wan'
	option src_dport '443'
	option dest_ip '192.168.3.10'
	option dest_port '443'
	list proto 'tcp'
	option family 'ipv4'

config rule
	option name 'allow wan'
	list proto 'tcp'
	option src 'wan'
	option dest_port '80 443'
	option target 'ACCEPT'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name 'transmission'
	option src 'wan'
	option src_dport '51413'
	option dest_ip '192.168.3.10'
	option dest_port '51413'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name 'transmission 2'
	list proto 'tcp'
	option src 'wan'
	option src_dport '9091'
	option dest_ip '192.168.3.10'
	option dest_port '9091'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name 'amule 1'
	list proto 'tcp'
	option src 'wan'
	option src_dport '4712'
	option dest_ip '192.168.3.10'
	option dest_port '4712'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name 'amule 2'
	list proto 'tcp'
	option src 'wan'
	option src_dport '4662'
	option dest_ip '192.168.3.10'
	option dest_port '4662'
	option family 'ipv4'

config redirect
	option dest 'lan'
	option target 'DNAT'
	option name 'amule 3'
	option src 'wan'
	option src_dport '4672'
	option dest_ip '192.168.3.10'
	option dest_port '4672'

config rule 'ovpn'
	option name 'Allow-OpenVPN'
	option src 'wan'
	option dest_port '1194'
	option proto 'udp'
	option target 'ACCEPT'
	option enabled '0'


dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '230'
	option limit '20'
	option leasetime '10m'
	option dhcpv4 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

after this pont I have a long list of static host

And here I have the logs

Sun Jul 14 16:16:02 2024 kern.info kernel: [331792.726732] tg3 0000:03:00.0 eth0: Link is down
Sun Jul 14 16:16:02 2024 daemon.notice netifd: Network device 'eth0' link is down
Sun Jul 14 16:16:02 2024 kern.info kernel: [331792.765814] br-lan: port 1(eth0) entered disabled state
Sun Jul 14 16:16:03 2024 daemon.notice netifd: bridge 'br-lan' link is down
Sun Jul 14 16:16:03 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Sun Jul 14 16:16:05 2024 kern.info kernel: [331795.466519] tg3 0000:03:00.0 eth0: Link is up at 1000 Mbps, full duplex
Sun Jul 14 16:16:05 2024 kern.info kernel: [331795.475197] tg3 0000:03:00.0 eth0: Flow control is on for TX and on for RX
Sun Jul 14 16:16:05 2024 kern.info kernel: [331795.484179] br-lan: port 1(eth0) entered blocking state
Sun Jul 14 16:16:05 2024 kern.info kernel: [331795.491498] br-lan: port 1(eth0) entered forwarding state
Sun Jul 14 16:16:05 2024 daemon.notice netifd: Network device 'eth0' link is up
Sun Jul 14 16:16:05 2024 daemon.notice netifd: bridge 'br-lan' link is up
Sun Jul 14 16:16:05 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Sun Jul 14 16:16:11 2024 user.warn ddns-scripts[3219]: duckdns: Updating IP at DDNS provider failed - starting retry 551/0
Sun Jul 14 16:16:11 2024 user.err ddns-scripts[3219]: duckdns: No or private or invalid IP '192.168.0.6' given! Please check your configuration
Sun Jul 14 16:16:11 2024 user.err ddns-scripts[3219]: duckdns: No update send to DDNS Provider
Sun Jul 14 16:16:44 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:16:44 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:16:51 2024 kern.info kernel: [331841.667678] usb 1-4: new full-speed USB device number 3 using xhci_hcd
Sun Jul 14 16:16:51 2024 kern.info kernel: [331841.856422] input: 2.4G Composite Devic as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/0003:1815:2808.0001/input/input4
Sun Jul 14 16:16:51 2024 kern.info kernel: [331841.937944] hid-generic 0003:1815:2808.0001: input,hidraw0: USB HID v1.10 Keyboard [2.4G Composite Devic] on usb-0000:00:14.0-4/input0
Sun Jul 14 16:16:51 2024 kern.info kernel: [331841.956297] input: 2.4G Composite Devic Mouse as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.1/0003:1815:2808.0002/input/input5
Sun Jul 14 16:16:51 2024 kern.info kernel: [331841.970939] input: 2.4G Composite Devic Consumer Control as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.1/0003:1815:2808.0002/input/input6
Sun Jul 14 16:16:51 2024 kern.info kernel: [331842.047999] input: 2.4G Composite Devic System Control as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.1/0003:1815:2808.0002/input/input7
Sun Jul 14 16:16:51 2024 kern.info kernel: [331842.063499] hid-generic 0003:1815:2808.0002: input,hidraw1: USB HID v1.10 Mouse [2.4G Composite Devic] on usb-0000:00:14.0-4/input1
Sun Jul 14 16:19:14 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:19:14 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:21:44 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:21:44 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:24:14 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:24:14 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:25:07 2024 kern.err kernel: [332337.589080] tg3 0000:03:00.0 eth0: transmit timed out, resetting
Sun Jul 14 16:25:09 2024 kern.err kernel: [332339.392872] tg3 0000:03:00.0 eth0: 0x00000000: 0x167b14e4, 0x00100406, 0x02000000, 0x00000010
...
Sun Jul 14 16:25:11 2024 kern.err kernel: [332341.621211] tg3 0000:03:00.0 eth0: 0x00007810: 0x00000000, 0x00000060, 0x000000fb, 0x00000000
Sun Jul 14 16:25:11 2024 kern.err kernel: [332341.631451] tg3 0000:03:00.0 eth0: 0: Host status block [00000005:00000002:(0000:0000:0000):(0000:0000)]
Sun Jul 14 16:25:11 2024 kern.err kernel: [332341.642679] tg3 0000:03:00.0 eth0: 0: NAPI info [00000002:00000002:(01ed:0000:01ff):0000:(00c8:0000:0000:0000)]
Sun Jul 14 16:25:11 2024 kern.err kernel: [332341.756972] tg3 0000:03:00.0: tg3_stop_block timed out, ofs=4800 enable_bit=2
Sun Jul 14 16:25:11 2024 kern.info kernel: [332341.785791] tg3 0000:03:00.0 eth0: Link is down
Sun Jul 14 16:25:11 2024 daemon.notice netifd: Network device 'eth0' link is down
Sun Jul 14 16:25:11 2024 kern.info kernel: [332341.824910] br-lan: port 1(eth0) entered disabled state
Sun Jul 14 16:25:12 2024 daemon.notice netifd: bridge 'br-lan' link is down
Sun Jul 14 16:25:12 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Sun Jul 14 16:25:14 2024 kern.info kernel: [332344.527599] tg3 0000:03:00.0 eth0: Link is up at 1000 Mbps, full duplex
Sun Jul 14 16:25:14 2024 kern.info kernel: [332344.536217] tg3 0000:03:00.0 eth0: Flow control is on for TX and on for RX
Sun Jul 14 16:25:14 2024 kern.info kernel: [332344.545146] br-lan: port 1(eth0) entered blocking state
Sun Jul 14 16:25:14 2024 kern.info kernel: [332344.552418] br-lan: port 1(eth0) entered forwarding state
Sun Jul 14 16:25:14 2024 daemon.notice netifd: Network device 'eth0' link is up
Sun Jul 14 16:25:14 2024 daemon.notice netifd: bridge 'br-lan' link is up
Sun Jul 14 16:25:14 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Sun Jul 14 16:26:11 2024 user.warn ddns-scripts[3219]: duckdns: Updating IP at DDNS provider failed - starting retry 552/0
Sun Jul 14 16:26:11 2024 user.err ddns-scripts[3219]: duckdns: No or private or invalid IP '192.168.0.6' given! Please check your configuration
Sun Jul 14 16:26:11 2024 user.err ddns-scripts[3219]: duckdns: No update send to DDNS Provider
Sun Jul 14 16:26:44 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:26:44 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:29:15 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:29:15 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:31:45 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:31:45 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:32:24 2024 daemon.notice netifd: Network device 'eth0' link is down
Sun Jul 14 16:32:24 2024 daemon.notice netifd: bridge 'br-lan' link is down
Sun Jul 14 16:32:24 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Sun Jul 14 16:32:24 2024 kern.info kernel: [332775.221622] br-lan: port 1(eth0) entered disabled state
Sun Jul 14 16:32:33 2024 kern.info kernel: [332783.785301] tg3 0000:03:00.0 eth0: Link is up at 1000 Mbps, full duplex
Sun Jul 14 16:32:33 2024 kern.info kernel: [332783.795653] tg3 0000:03:00.0 eth0: Flow control is on for TX and on for RX
Sun Jul 14 16:32:33 2024 kern.info kernel: [332783.806385] br-lan: port 1(eth0) entered blocking state
Sun Jul 14 16:32:33 2024 kern.info kernel: [332783.815475] br-lan: port 1(eth0) entered forwarding state
Sun Jul 14 16:32:33 2024 daemon.notice netifd: Network device 'eth0' link is up
Sun Jul 14 16:32:33 2024 daemon.notice netifd: bridge 'br-lan' link is up
Sun Jul 14 16:32:33 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Sun Jul 14 16:33:12 2024 daemon.notice netifd: bridge 'br-lan' link is down
Sun Jul 14 16:33:12 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Sun Jul 14 16:33:12 2024 kern.info kernel: [332822.815626] br-lan: port 1(eth0) entered disabled state
Sun Jul 14 16:33:17 2024 kern.info kernel: [332828.079836] br-lan: port 1(eth0) entered blocking state
Sun Jul 14 16:33:17 2024 kern.info kernel: [332828.088235] br-lan: port 1(eth0) entered forwarding state
Sun Jul 14 16:33:17 2024 kern.info kernel: [332828.096859] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Sun Jul 14 16:33:17 2024 daemon.notice netifd: bridge 'br-lan' link is up
Sun Jul 14 16:33:17 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Sun Jul 14 16:34:15 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:34:15 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:36:12 2024 user.warn ddns-scripts[3219]: duckdns: Updating IP at DDNS provider failed - starting retry 553/0
Sun Jul 14 16:36:12 2024 user.err ddns-scripts[3219]: duckdns: No or private or invalid IP '192.168.0.6' given! Please check your configuration
Sun Jul 14 16:36:12 2024 user.err ddns-scripts[3219]: duckdns: No update send to DDNS Provider
Sun Jul 14 16:36:45 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:36:45 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:39:02 2024 kern.info kernel: [333172.866334] tg3 0000:03:00.0 eth0: Link is down
Sun Jul 14 16:39:02 2024 kern.info kernel: [333172.871393] br-lan: port 1(eth0) entered disabled state
Sun Jul 14 16:39:02 2024 daemon.notice netifd: Network device 'eth0' link is down
Sun Jul 14 16:39:03 2024 daemon.notice netifd: bridge 'br-lan' link is down
Sun Jul 14 16:39:03 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Sun Jul 14 16:39:15 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:39:15 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:39:16 2024 kern.info kernel: [333186.380564] tg3 0000:03:00.0 eth0: Link is up at 1000 Mbps, full duplex
Sun Jul 14 16:39:16 2024 kern.info kernel: [333186.387451] tg3 0000:03:00.0 eth0: Flow control is on for TX and on for RX
Sun Jul 14 16:39:16 2024 kern.info kernel: [333186.394604] br-lan: port 1(eth0) entered blocking state
Sun Jul 14 16:39:16 2024 kern.info kernel: [333186.400048] br-lan: port 1(eth0) entered forwarding state
Sun Jul 14 16:39:16 2024 daemon.notice netifd: Network device 'eth0' link is up
Sun Jul 14 16:39:16 2024 daemon.notice netifd: bridge 'br-lan' link is up
Sun Jul 14 16:39:16 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Sun Jul 14 16:41:45 2024 daemon.notice netifd: wan (3127): udhcpc: sending renew to server 192.168.0.1
Sun Jul 14 16:41:45 2024 daemon.notice netifd: wan (3127): udhcpc: lease of 192.168.0.6 obtained from 192.168.0.1, lease time 300
Sun Jul 14 16:42:02 2024 kern.err kernel: [333352.611068] tg3 0000:03:00.0 eth0: transmit timed out, resetting
Sun Jul 14 16:42:04 2024 kern.err kernel: [333354.410791] tg3 0000:03:00.0 eth0: 0x00000000: 0x167b14e4, 0x00100406, 0x02000000, 0x00000010
...
Sun Jul 14 16:42:06 2024 kern.err kernel: [333356.533333] tg3 0000:03:00.0 eth0: 0x00007810: 0x00000000, 0x00000060, 0x000000fb, 0x00000000
Sun Jul 14 16:42:06 2024 kern.err kernel: [333356.543569] tg3 0000:03:00.0 eth0: 0: Host status block [00000005:00000006:(0000:0000:0000):(0000:0000)]
Sun Jul 14 16:42:06 2024 kern.err kernel: [333356.554797] tg3 0000:03:00.0 eth0: 0: NAPI info [00000006:00000006:(01ed:0000:01ff):0000:(00c8:0000:0000:0000)]
Sun Jul 14 16:42:06 2024 kern.err kernel: [333356.669075] tg3 0000:03:00.0: tg3_stop_block timed out, ofs=4800 enable_bit=2
Sun Jul 14 16:42:06 2024 kern.info kernel: [333356.697920] tg3 0000:03:00.0 eth0: Link is down
Sun Jul 14 16:42:06 2024 daemon.notice netifd: Network device 'eth0' link is down
Sun Jul 14 16:42:06 2024 kern.info kernel: [333356.736798] br-lan: port 1(eth0) entered disabled state
Sun Jul 14 16:42:07 2024 daemon.notice netifd: bridge 'br-lan' link is down
Sun Jul 14 16:42:07 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Sun Jul 14 16:42:09 2024 kern.info kernel: [333359.769625] tg3 0000:03:00.0 eth0: Link is up at 1000 Mbps, full duplex
Sun Jul 14 16:42:09 2024 kern.info kernel: [333359.778375] tg3 0000:03:00.0 eth0: Flow control is on for TX and on for RX
Sun Jul 14 16:42:09 2024 kern.info kernel: [333359.787519] br-lan: port 1(eth0) entered blocking state
Sun Jul 14 16:42:09 2024 kern.info kernel: [333359.795000] br-lan: port 1(eth0) entered forwarding state
Sun Jul 14 16:42:09 2024 daemon.notice netifd: Network device 'eth0' link is up
Sun Jul 14 16:42:09 2024 daemon.notice netifd: bridge 'br-lan' link is up
Sun Jul 14 16:42:09 2024 daemon.notice netifd: Interface 'lan' has link connectivity


Remove these, then restart and try again.

Can I ask why? I use the first 2 to access my servers, the last one was for a test.

  1. The two rules conflict with each other
  2. You should never expose the LuCI interface to the internet.

Ok, LuCI is not expose to the web the router y behind another modem/router provide by the isp.

Ok... that's fine, then, but the rules conflict with each other, so you'll want to address that.

Yes, I already disable the last one. thanks

After disabling the ddns service, the problem persists. My new theory: it has something to do with my download volume? I haven't got any problem for the last two weeks, today I downloaded two torrents and the problem came back.