Debug connection failed on glinet as repeater

On my gl inet I have set up WISD to act as a repeater. Frequently it does not manage to connect to the network and I don't know why. I reset the router (firstboot) and it starts working again.
How can I debug these failed attempts? I click connect on the web interface, but nothing happens.

/etc/config/dhcp:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/qca953x_wmac'
	option hwmode '11ng'
	option htmode 'HT40+'
	option noscan '1'
	option txpower '20'
	option channel '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk-mixed'
	option wds '1'
	option ifname 'wlan0'
	option isolate '1'
	option ssid 'gl inet ssid'
	option key 'gl inet pw'

config wifi-iface 'sta'
	option device 'radio0'
	option ifname 'wlan-sta'
	option network 'wwan'
	option mode 'sta'
	option key 'key'
	option bssid 'bssid'
	option ssid 'ssid to connect to'
	option encryption 'psk-mixed'

/etc/config/firewall and /etc/config/network if needed are here: Icmp port unreachable

Are you running GL.iNet firmware or stock OpenWrt?

Are there any clues in the logs? They should be available in LuCI, as well as through logread on the command line

I'm running the GL iNet firmware. I've raised the log level to 1, but unfortunately logread does not contain anything useful / related

GL.iNet has a sophisticated set of packages that run on top of OpenWrt for managing connections. There is a very active support forum there that have both knowledgeable users and members of their technical staff participating. I would suggest checking there first.

1 Like

I have flashed the openwrt firmware and it seems so much more stable. I don't have experienced this issue so far.