Debrick TP Link Archer C2

Hey guys, what's up.

Okay, so after a possible bad flash via tftpd, the router doesn't go into "recovery" mode anymore, so that option's closed.
able. Thing is, router doesn't respond. I don't really know what I'm doing wrong or how I can check if everything is alright. Putty doesn't show any signs of life.

Imgur
Imgur

Maybe I am using the wrong pins. I tested with a multimeter and from left to right it gave this:
3.3V 0V 0V 3.3V

I assumed the left one was VCC so I didn't solder a pin onto it.

Do you get any LED activity when you try to boot the device?

https://openwrt.org/toh/tp-link/archer_c2_ac750#serial

ethernet ← VCC GND TxD RxD → Leds

On some versions you need to solder 2 bridges to get serial port working. You need good soldering experiences for that!

Does that mean I pinned it correctly? :sweat_smile:

Power led stays on. Internet led powers on then dies.

I don't know which bridges to solder, really. Wish I knew.

That potentially means that the boot loader is running.

I don't have a C2, but looking at the back side of the board from the images on the ToH

image

and knowing TP-Link's penchant for not populating things, I would guess, and purely guess that certain units may not have one or more of R54, R137, R500, R601 unpopulated. That you've got 3.3 V on the RX pin suggests that it, at least, is connected and has a pull up to +3.3 V (assuming that you checked without the adapter connected).

I'm sorry, I'm a total noob when it comes to electronics. I wouldn't know what this means. I'd love to understand, though.

Okay, so I did a loopback test on the USB TTL cable I've got here (one of these https://images-na.ssl-images-amazon.com/images/I/41V6wBUKLXL._SX466_.jpg) and everything went well. So it's not that.

I still can't access the router through the serial port. I tried everything. Maybe it's toast? Maybe flash is not working properly (I don't have the tools to check it).

If that used 5 V logic, it is possible that the serial port of the SoC or more has been damaged.

Does your board have the four resistors in the places shown in the image above?

It does have those four resistors. Here, a pic of my bad soldering skills and the four resistors:

Imgur

1 Like

For all that matters, I'm using this guy:


index

I don't know if it's the right tool. It worked with my WRT1200AC.

No ideas? :sweat_smile:

I refuse to think that it died because of my soldering or because of a bad flash.

Hi, I have the same problem as the Untrue: after unsuccessful firmware flash vi FTPD the router is not able to go into recovery mode anymore. It only lights the Power led with a short blink of the internet led. After the connection tpo serial port with Putty & UART CP2102, I got only weird symbols. The voltage on pins is 3,3V - 0 - 0 - 3.3V. Any idea of how to proceed? Thanks.

if you messed up on tftp flash of archer c2, it will overwrite the bootloader, make it unable to boot
no serial cable will fix it, you will have to a clip cable to directly read memory to write a right image dump on it: but I think buying a new router may be cheaper than eeprom writer that needed.

1 Like

Thanks, for your reply. I tried my luck with EEPROM programmer: unsoldered the chip, flashed it by an image found on another forum and soldered back. Everything went well and the router works again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.