Debrick EnGenius ENS620Ext using USB to TTL

I am trying to debrick Engenius Ens 620Ext Router, I can copy new firmware to router using tftpd and putty. After that I can’t replace the previous firmware with the new one. As there is no option to erase (I tried in help) or flash option.If anyone can suggest which command should is use for replacing the older into new firmware to router

You did right not to post any output coming from the device, because we know all of them all by heart...

1 Like

Try bootm using the initramfs, then run a sysupgrade from within Openwrt.

not sure if the 2nd bootm param is right, but try tftpboot instead, hopefully it'll take care of the parametrization for you.

In a default install you can make a normal boot then log in on the serial port without a password then run passwd (not passwd root since you'll already be root).

Please cut and paste the terminal text into a code block instead of taking pictures.

It appears that you tried to mount_root before the jffs was ready.

Also there's a big difference between
sbin/ firstboot
and
/sbin/firstboot
which is what you want, though simply firstboot should also work. I'm not sure about that though since this is a very old version.

Is this stock fw, considering it runs AA, which is 11 or so years old, by now ?

It's a script if I remember correctly, execute the command(s) within, manually?

(probably /sbin/jffs2reset -y)

So what you have is factory firmware which is loosely based on a version of OpenWrt which was old in 2018 (I think AA was about 2010).

And it isn't storing settings the way OpenWrt does. It appears it may be using some sort of nvram or userconfig partition which is outside the filesystem. Try cat /proc/mtd to see the partition table. If you find one named userconfig or nvram try hexdumping it. ('dd if=/dev/mtdX | hexdump -C' with X being the partition number) The webui password may be there in plain text, in which case you could use it to log in.

EnGenius is known to do some strange stuff in regards to partitioning and flashing and this is getting out of range of this forum.

Boot an Openwrt initramfs and use that to move to openwrt.

If you want to stay on vendor firmware then contact their support service

That was our 1st suggestion, two days ago.

And is still the best option a few days later!

indeed, but OP couldn't get it to boot ...

Looking at the screenshots the image sent is only the vendor image, not an openwrt image

Unless the op renamed the openwrt image the same as a vendor image would be named

there's a default name for the image u-boot tries to pull, I'd assume he didn't change it, but renamed the file.

That looks like an empty jffs2 filesystem. Does the stock firmware mount it? There's also rootfs_data which is usually the jffs2 overlay filesystem.

Have you tried the web interface to confirm there is still a password set on it? It is likely that they wrote their own webui and it does not use the Linux system root password (which may not even exist) as the web user password.

by default there is

image

Unfortunately that is the factory image, not the initramfs image

You won’t be able to tftpboot the factory image

1 Like

Download the initramfs version and boot that via tftp

Once it boots login to the webui and install the sysupgrade image.

https://downloads.openwrt.org/releases/22.03.5/targets/ipq40xx/generic/openwrt-22.03.5-ipq40xx-generic-engenius_ens620ext-initramfs-fit-uImage.itb

1 Like

I don’t have your device so can’t say for sure, but I can expect you can recover the vendor image by tftp.

I’d expect you will be back to where you were though - the vendor firmware will load the existing configuration and lock you out.