DDNS update script - afraid.org both v4 and v6

I am trying to update both "A" and "AAAA" records on a .undo.it (it's a free freedns forwarder) using luci-app-ddns . I'm not sure this is the right place for this, but I'm using the "afraid.org-v2-token" script. It's not overly well documented but I figured out how to use it.

Now for the fun part. I have both IPv6 and IPv4 scripts going to the same domain. I thought they would update their relevant records (AAAA/A). However, I get this hilarious line in the script log:

Updated <snip>.undo.it from <x>:<y>:<z>:a:a42c:<x>:<y>7085:df22 to <x>.<y>.<z>.145 .

In other words, the IPv4 script is reading the IPv6 IP, thinks it needs to be changed, and updates it to the IPv4 address. I checked the website, and it seems to be going to the correct address to the correct record (AAAA/A) depending on the script run last, but it also removes the "other" record, and then the other script starts failing with:

 200909  WARN : NO valid IP found
 200909  WARN : Get registered/public IP for '<snip>.undo.it' failed - retry 1/0 in 60 seconds

How do I accomplish this, and can you please improve the IPv6 script to check the AAAA record, and not overwrite the A record and vice-versa?

undo[.]it doesn't seem to be supported, so rather than using the afraid service, you'll have to make a custom one.

Custom Service
If you want to use a DDNS provider currently not listed or you want to update multiple hosts within one configuration/section then you should do the following:

  • Choose '–custom– ' as service. Additional field 'Custom update-URL ' is shown.
  • Fill in the URL you like to use. :!: Please read URL syntax description below. Also have a look at Provider specifics.
  • Click [Save & Apply] button to save changes.
    :!: If you found a DDNS provider not listed or with additional IPv6 support or with changed update URL please open an issue at Github-OpenWrt-Packages so it can be included with the next release.

Sorry, I should've mentioned it's one of the hunderds of domains offered by afraid.org more clearly. The update process works fine, it's been running since yesterday. I'm running the v4 script only at this point though, because the v6 script doesn't just add an "AAAA" record as expected, it removes the "A" record as well.

I guess the improvement I'm asking for which would solve the problem fully is to update the relevant record only ("A" or "AAAA") and do not erase any other records. Ideally after running both IPv4 and IPv6 scripts, there is one subdomain with the same name with both A and AAAA.

Can you post the ddns configuration?
Should be uci export ddns

root@AP:~# uci export ddns
package ddns

config ddns 'global'
        option ddns_dateformat '%F %R'
        option ddns_loglines '250'
        option upd_privateip '0'

config service 'myddns_ipv4'
        option interface 'wan'
        option ip_source 'network'
        option ip_network 'wan'
        option enabled '1'
        option lookup_host 'example.undo.it'
        option service_name 'afraid.org-v2-token'
        option password 'BLAhVxA3rUpPjqtLjwhRN8yq'

config service 'myddns_ipv6'
        option use_ipv6 '1'
        option interface 'wan6'
        option ip_source 'network'
        option ip_network 'wan6'
        option service_name 'afraid.org-v2-token'
        option lookup_host 'example.undo.it'
        option password 'BLAhVxA3rUpPjqtLjwhRN8yq'
        option enabled '0'

I've changed the host and password, but that should be irrelevant.

As you can see, I've turned off the ipv6 option for now.

Hopefully what I'm asking for makes sense. I hope it's also supported at afraid.org, I think it is. I hope it's a minor modification to the script.

P.S. Also, my needs are only for IPv4 at this point, so it's not breaking anything. I have noticed it as a potential future issue though, so that's why the thread.

You need to create 2 records (with 2 different tokens) on the portal and enable dynamic updates for both.
Use the same subdomain, make one with dummy A, another with dummy AAAA record.

1 Like

Works perfectly, thanks a bunch for your help. Unintuitive setup, probably more at afraid.org than OpenWRT, but it works great now :slight_smile: .

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.