DDNS Update for freedns.afraid.org not working


i just set up a ddns-client through lacie.

I input my data etc.

Then I got the following error:

Failed to execute cbi dispatcher target for entry '/admin/services/ddns'.
The called action terminated with an exception:
/usr/lib/lua/luci/controller/ddns.lua:107: attempt to index field '?' (a nil value)
stack traceback:
	/usr/lib/lua/luci/controller/ddns.lua:107: in function 'service_version'
	/usr/lib/lua/luci/controller/ddns.lua:117: in function 'service_ok'
	/usr/lib/lua/luci/model/cbi/ddns/overview.lua:20: in function 'func'
	/usr/lib/lua/luci/cbi.lua:66: in function 'load'
	/usr/lib/lua/luci/dispatcher.lua:838: in function </usr/lib/lua/luci/dispatcher.lua:832>

This opens up every time now, when I click on Services -> Dynamic DNS..

How do I solve this error and set up my DDNS?

Had it running under 17.04.5, Netgearr7800. What are you using?

I use a TP-Link 1043ND with latest 18.06

1 Like

At least I can say it works (on my router ;- ) I use afraid.org-v2-token.

I would like to use https but had problems with certificates although I copied them to /etc/ssl/certs

ADD: It is working with https but with path to CA-Certificate to "IGNORE"

If you install ca-bundle then https should work if you set Path to CA-Certificate = /etc/ssl/certs/ca-certificates.crt

Apparently this can happen if the package opkg is removed: https://github.com/openwrt/luci/issues/2057

It may work if you use the "custom" provider in ddns and create your own update URL.

1 Like

I have the same error on: TP-Link TL-WR1043N/ND v1 after upgarding from to OpenWrt 18.06.1 r7258-5eb055306f today.

Any luck in the past 9 months? I have the same issue with 1043ND. When I refresh or restart it seems like it works, but it never updates the changeip dndns

Could you also post your configurations?
It is difficult to evaluate where the problem lies otherwise.

Sorry, I don't really remember what I did.
But the UI still doesn't seem to work, when I open the DDNS-Panle I now get

Bad Gateway

The process did not produce any response

Updates of the DDNS-IP work though.
If you tell me what info you need, I can look it up on my Router.

After messing around for some hours, using https://openwrt.org/docs/guide-user/services/ddns/client and google and of course this place, and attempting all variations, I finally got it working.

This is my recipe:
Add new service: FreeDNS (or your favourite name)

lookup hostname: your.hostname.com
DDNS Service provider: -custom-
Custom update url: https://sync.afraid.org/u/your-update-key
Domain your.hostname.com
Username: guest or your account name, not important
Password: if field is empty, use 'guest', if already filled in, leave it, not important
path to CA-cert: IGNORE

Timer settings tab:
update interval 10 minutes, force 72 hours, retry 3, 60 sec.

SAVE ...
... and Save&Apply on the ddns main page!

Then never save this config again, if you re-open you see provider: 3322.org so the interface is broken.

In Edit - Log file viewer tab you can see the magic happening (Read/Reread log file) and again, don't save but click dismiss.

There's also an issue with Last Update / Next Update because those times are wrong, unfortunately.

Get on https://freedns.afraid.org/dynamic/ by clicking 'Direct url example' next to your host name. You get the key (and in fact the full update url) in the page that opens.

I think you have to hit the Restart DDns button too to start the service with the correct settings. This is for sure if you had old, not working settings in your FreeDNS service configured.

The service got broken. I see /u/ has changed in /dynamic/update.php?

So now the Custom update url is: