DDNS successfully configured, but not able to "ping" the host

Hi folks,
I'm successfully convert from AVM Fritz to OpenWRT. While I tried to configure a DDNS service, I got an IP-adress and successfully update the domain. Nevertheless, I'm not able to resolve/ping the host...
Does anyone has an idea?
best
Andreas

From where are you trying to resolve it? From a lan host or from the internet?
Can you try to force the query from a public internet resolver?
nslookup your.ddns.de 8.8.8.8

ah okay, nslookup via internet resolver is/was successfull! Might be a small thing I forget to configure...
thanks and best

... after reading the documentation again, it looks like, that I MUST add a curl and bind-host on the local router?

As far as I know it can work with wget as well. There are some exceptions where you need to use curl. The requirement for bind-host applies only when

  • Force the usage of either IPv4 or IPv6 communication only.
  • DNS requests via TCP

thanks so far for you support.. due to fact, that I use a "compatible DDNS service provider", why the ddns scipt doesn't handle that topic?
Nevertheless, I found out, that by default the ddns-scripts uses BusyBox build in 'wget ' for DDNS updates over http, which I use so far...
I'm a little bit confused...

Which topic exactly?
Just to clarify, has your initial problem been resolved already?

Hi,
nslookup works pretty fine, also from the local side.. nevertheless, I assumed, that the "link" to the (ddns) hostname would be initate by the script itself, so I would be able to ping the host .. but may be I'm on the wrong way...

I am not sure that I follow you here. Are you trying to ping from a lan host the wan IP?

exactly! Or do I make errors in thinking?

Nope, no mistakes, it was just not clear to me.

UPDATE: Now I'm able to ping the host, but when try to get access to a device via port forwarding (port 8080 from WAN to port 80 in the LAN), no connection available.
Do I have to configure NAT additionly?
best

Port forward is enough, masquerade is for the opposite direction.

ok, may be, I made a mistake... Ping (and nslookup from inside the LAN) is still possable, but no html connect..
any ideas?

Setup a packet capture on the server and verify that it receives the packets and sends back the responses.

okay, to summarize it up;
DDNS works fine, FQDN is reachable (ping/nslookup)
Port forwarding is avaiable (see attached pic)
But, how is the "binding" between the FQDN (WAN side) to the host I want to reach inside the LAN? Is port forwarding really enough to resolve?
best
Andy

Resolving will get you to the wan address of the router. Then as soon as a packet reached the port 8080 it will be NATed to the internal IP and port.

**...and that's exactly what does not happen.. anyway
just tried again; nslookup ok, ping ok, but not able to open the link via browser on dedicated ports...

iptables-save -c -t nat

... assume, to run it directly on the router, the output is:

# Generated by iptables-save v1.8.7 on Tue Aug 23 15:33:51 2022

*nat

:PREROUTING ACCEPT [0:0]

:INPUT ACCEPT [0:0]

:OUTPUT ACCEPT [0:0]

:POSTROUTING ACCEPT [0:0]

COMMIT

# Completed on Tue Aug 23 15:33:51 2022

# Warning: iptables-legacy tables present, use iptables-legacy-save to see them