DDNS reports no update_url found with custom config

I try to get ddns working with my host provider.
Normally it should be quiet easy.
I have an update url from them with no variant parameters (they took the ip from the request).
If i run this url directly from the router with curl it works as it should: The response is 200 and the ip is updated.

But I fail to config this with ddns. This is my /etc/config/ddns:

config ddns 'global'
        option ddns_dateformat '%F %R'
        option ddns_loglines '250'
        option ddns_rundir '/var/run/ddns'
        option ddns_logdir '/var/log/ddns'
        option use_curl '1'

config service 'xxxnetipv4'
        option service_name 'xxxnetipv4'
        option use_ipv6 '0'
        option enabled '1'
        option lookup_host 'xxx.net'
        option domain 'xxx.net'
        option use_https '1'
        option use_syslog '2'
        option check_unit 'minutes'
        option force_unit 'minutes'
        option retry_unit 'seconds'
        option force_ipversion '1'
        option cacert 'IGNORE'
        option ip_source 'network'
        option ip_network 'wan'
        option interface 'wan'
        option username ' user'
        option password 'pass'
        option update_url 'https://ipv4.api.hosting.ionos.com/dns/v1/dyndns?q=xxx'

I tried many variants (Among other things, I also created the config with Luci) but all of them are ending with the following error message:

WARN : No update_url found/defined or no update_script found/defined! - TERMINATE

Since the content of the message is obviously not accurate, I am asking here if anyone can help.

DDNS-version: 2.8.2-11; OpenWRT-version: 21.02.0-rc4

my DDNS, for exemple if you help :


config ddns 'global'
	option ddns_dateformat '%F %R'
	option ddns_loglines '250'
	option ddns_rundir '/var/run/ddns'
	option ddns_logdir '/var/log/ddns'

config service 'ACCESS_OVH'
	option service_name 'ovh.com'
	option use_ipv6 '0'
	option enabled '1'
	option lookup_host 'openwrt.xxxxxx.fr'
	option domain 'openwrt.xxxxx.fr'
	option username 'xxxxx.fr-openwrt'
	option password 'xxxxx'
	option interface 'wan'
	option use_syslog '2'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'
	option ip_source 'web'
	option ip_url 'http://checkip.dyndns.com'


1 Like

Hey that helped.
I don't know which of the followings things was the fault:

  • service_name was set but i used custom - so i deleted it.
  • i deleted lookup_host
  • my dummy user name begans with a space char - so i deleted this

Now it works - thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.