DDNS problem How can I solve it?

DDNS updater client isn't working at all the error is the following:

092249  info : Starting main loop at 2020-03-27 09:22
 092249       : Detect local IP on 'interface'
 092249       : #> ip -o addr show dev pppoe-wan scope global >/var/run/ddns/RemoteDns.dat 2>/var/run/ddns/RemoteDns.err
 092249       : Local IP '..' detected on interface 'pppoe-wan'
 092250       : Update needed - L: '....' <> R: '..'
 092250       : #> /bin/uclient-fetch -q -O /var/run/ddns/RemoteDns.dat -Y off 'https://freedns.afraid.org/dynamic/update.php?***PW***&address=.....' 2>/var/run/ddns/RemoteDns.err
 092254 ERROR : uclient-fetch Error: '5'

.... it means that I masked the address
I have installed the ssl support to the app but it doesn't work..
I have probed a lot of things what I could be..

Thanks for the help!

The line Local IP 'X.X.X.X' detected on interface 'pppoe-wan' makes me think you may be behind what's called a CGNAT https://en.wikipedia.org/wiki/Carrier-grade_NAT meaning that your ISP is not giving you a public IP on your WAN interface.
This has a lot of implications, because you are sharing a public IP with other people you won't be able to forward certain ports or any ports at all for example.

EDIT: Maybe you are not behind a CGNAT and that's just the way PPPoE works (having a local IP given to your pppoe-wan interface) so you will have to do a little bit of research on that.

In relation to your problem you need to change the DDNS WAN IP detection, in the "Advanced settings" tab of your DDNS settings, select URL as an IP address source instead of Network or Interface. The DDNS script will then just call http://checkip.dyndns.com to determine your public IP.


No! It can determine my current IP I have just written it to ....!
I have already written this sentence.. Sorry
I have set to this value so the wan interface IP will be the my IP and it is exactly what it should be.

Install libustream-mbedtls or libustream-openssl


It can determine your current IP address, it does determine your current IP address, and it determines it is a private IP address.

Do you really have a public IP address on your WAN interface? Could you share at least the first octect of that IP address?

1 Like

Same as what @eduperez said, the line specifically say Local IP detected on WAN. Does your WAN IP is something like 192.168.X.X, 172.16-32.X.X or 10.X.X.X?

If it's the case then your ISP is running a CGNAT.

Otherwise, if it's a SSL/TLS problem have you installed the package ca-certificates?

DDNS says that whether you have a private or public IP afaik. It certainly says it on all my instances and I definitely have a public IP on the WAN interface.

Given the error seems to be an issue with uclient-fetch I imagine it's much more likely the issue here is to do with SSL.

Yes it starts with 212 this is a normal ip address I have got because I checked the WAN4 IP address is the same as this.

Yes, sorry, I missread the log messages...

Now it works! I tried to install the two ssl module the frist was installed okay but the second one has got an error that another file that it contains already has got my system.. I chose that overwrite files from other package option ( I do not like this option) and the error has gone.

Thank you for all.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.