DDNS Not Starting & XHR Request Time Out

On the last few Snapshot Revs my DDNS setup will not start on boot and when I Reload the Service in the GUI I get a "XHR Request Timed Out" error appearing on the top of the DDNS GUI screen.

I use a DuckDNS.org setup and it worked fine before.

My work-around is to first disable the DDNS Service and put the startup command "/usr/lib/ddns/dynamic_dns_updater.sh -- start" in the local startup file "rc.local". This works fine and the DuckDNS Service starts up fine on boot and works correctly.

Is there a way to get DDNS working as it should and avoid the work-around I am using?

My DDNS setup is:

config ddns 'global'
	option ddns_dateformat '%F %R'
	option ddns_loglines '250'
	option ddns_rundir '/var/run/ddns'
	option ddns_logdir '/var/log/ddns'

config service 'DuckDNS'
	option service_name 'duckdns.org'
	option use_ipv6 '0'
	option enabled '1'
	option lookup_host 'XXXXXXXXX.duckdns.org'
	option domain 'XXXXXXXXX'
	option username 'XXXXXXXXX'
	option use_syslog '2'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'
	option ip_source 'web'
	option ip_url 'http://checkip.dyndns.com'
	option interface '@lan'
	option use_https '1'
	option cacert '/etc/ssl/certs/ca-bundle.pem'
1 Like

Hello, my DDNSS is working great, for what I see, you may have a error in your line
option cacert '/etc/ssl/certs/ca-bundle.pem'

mine is set to ->

option cacert '/etc/ssl/certs/ca-certificates.crt'

and works perfect

1 Like

Thanks for the tip. I upgraded to a new firmware and it is working good now.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.