DDNS fails to update

i am trying to setup a ddns service but it fails to update the WAN IP with the ddns name. I have tried many different providers and i am facing the same issue. Currently i have duckdns.org and it only gets the IP at the time of account creation.

here are my settings:

and here are the logs from the router:

Fri Apr 29 06:38:43 2022 user.notice ddns-scripts[4906]: DuckDNS_Atxyz: PID '4906' started at 2022-04-29 06:38
Fri Apr 29 06:38:44 2022 user.err ddns-scripts[4906]: DuckDNS_Atxyz: Can not detect local IP using network_get_ipaddr 'wan' - Error: '1' - TERMINATE
Fri Apr 29 06:38:44 2022 user.warn ddns-scripts[4906]: DuckDNS_Atxyz: PID '4906' exit WITH ERROR '1' at 2022-04-29 06:38

and the error when restarting the ddns services

while my router has access to the internet and the LAN can access the internet without any issues.

Did you set it to use the wan_pppoe interface for checking the IP? The log says it's attempting to use wan interface...

i have it like this

and i am getting this error after the reboot:

Fri Apr 29 07:20:24 2022 user.notice ddns-scripts[3294]: DuckDNS_Atxyz: PID '3294' terminated by 'SIGTERM' at 2022-04-29 07:20
Fri Apr 29 07:20:26 2022 user.notice ddns-scripts[3987]: DuckDNS_Atxyz: PID '3987' started at 2022-04-29 07:20
Fri Apr 29 07:20:27 2022 user.err ddns-scripts[3987]: DuckDNS_Atxyz: IP update not accepted by DDNS Provider

I don't use this Duck DNS thing, but that sounds to me like your username/password is wrong or you don't have permission to update your IP-address. Check the documentation that your settings are correct.

Increase the verbosity, and post the logs.

how do i increase the verbosity?

Test the following:

advanced settings
Source of IP address: URL
URL to detect: http://checkip.dyndns.com
Network event: wan

Timer settings
Check Interval: 30
Check unit: minutes
Interval for forcing: 0

i had to wait for a few hours and some reboots, in order for it to work. fixed.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.