DDNS and HTTPS with duckdns.org?

Has anybody managed to make DDNS work for duckdns.org with HTTPS?

It works with HTTP, and it worked with HTTPS in previous versions; but for some reason I cannot manage to make it work with 17.02.2. Neither "curl" or "wget" seem to accept the certificate files I download following their instructions.

Works for me using instructions on the duckdns site. What error do you see?

I run this to set it up.

# Used for duck dns
opkg install ddns-scripts
opkg install ca-bundle
opkg install curl
mkdir -p /etc/ssl/certs
curl -k https://www.startssl.com/certs/ca-bundle.pem >  /etc/ssl/certs/ca-bundle.pem

I found the problem, and it is working now:

The "curl -k ..." command to retrieve the certs file was receiving a "302 Found" message from the server, and not following the redirection. Thus, the "ca-bundle.pem" file contained an HTML page, not a list of certificates, and both "curl" and "wget" where complaining about an incompatible file format.

I downloaded the file with "wget" (which does follow the redirection) and everything works as expected now.

Thanks everybody!

Some update info. Duck DNS has changed his cert, so yo will need to download the new one:

curl -k https://certs.secureserver.net/repository/sf_bundle-g2.crt > /etc/ssl/certs/ca-bundle.crt