David's Build basic script installation and package configuration

Hey all,

First time here (as a topic starter). Very little experience with linux and none with OpenWRT.
To keep it short...

I bought the WRT1200AC from linksys and installed the David's latest build.
Problem is that I cannot figure out how to install scripts and configure them from Luci.

ex1: I would like to install DNSCrypt-proxy v2 which David has an easy to install script.
I cannot find how to install a script via Luci environment.

PS: i would like also to enable fast path is this doable from luci?

So sorry if those questions already been answered, I was searching for over 4 hours before I took the decision to post but couldn't find any solution to my problems.
Thank you all in advance.

Ok basically I ssh to router and installed the dnscrypt-proxy2

Now the only thing I would like to know is if fastpath (hardware acceleration nat) is supported with WRT1200AC and if yes, should I do something or is working out of the box?

Thank you.


Thank you @anomeome will check this as soon as I'm back.

It seems that if I add the option flow_offloading '1' then I'm loosing connection.
I can access the router but I cannot browse.

I don't know if it has to do with the SQM been enabled.

Have not seen any issues with flowoffload since the initial shakeout some time back, so working well for me. The two are not mutually exclusive(I am currently not using SQM), can be used simultaneously, but not recommended as basically nil effect.

I ftped to router and edited the /etc/init.d/firewall conf then just added the option flow_offloading '1' under configure defaults and rebooted.

Wasn't that the correct way?
Probably I won't enable it cause I need the SQM but just for learning purposes...

That should do it. You should be able to just do a:

/etc/init.d/firewall reload

also checkbox under Network->Firewall if you use luci.

Thanks, will try it tomorrow.
Also I'm pretty sure via luci there is no the option under network > firewall ( or I'm blind :stuck_out_tongue: )

Still the same but anyway I won't bother with that as I will leave SQM enabled.

Another issue I'm facing is that I cannot understand how am I suppose to use a USB as internal storage.
Basically two things.

  1. I formatted the usb as 1 partition ext4 then I went to Luci and did the following.


After that I had the following.

Now I don't understand how am I suppose to use this as internal in order to install there other packages...

  1. I would like to install YAMon to monitor my network and the first line of instructions say
    The steps below presume that you have already copied install.sh to the USB drive that is mounted to opt and that have given install.sh execute permissions.

How can I mount the usb to /opt? (it must be the same as to implement the internal thing that I want I suppose.)
Then in order to change its permissions I must do chmod +x install.sh?

Thanks for your time.

These are the steps I used to first configure USB support on my LEDE router:

To configure the drive for YAMon, I went to System-->Mount Points (http:///cgi-bin/luci/admin/system/fstab)
Scrolled down to Mount Points
Clicked Add
Entered the path /dev/sda1 in the Device drop down
Selected /mnt as the Mount Point
(Don't forget to select Enable this mount at the top)
Then click Save & Apply

If you follow these steps, you will install YAMon in /mnt rather than /opt...

Does that help at all?

Sorry just looked more closely at your screenshots... your USB drive is configured to mount at /overlay... so in the YAMon instructions, replace /opt with /overlay


Hi, thank you for your reply.
I will check it out today.

As of my understanding, in order to install yamon or anything else I will have to point out the installation path manually every time correct?

What I'm trying to do is to make lede think that my usb is internal storage so next time I will install anything from system > software > packages then it will use my usb's storage and not the internal from router.

Is this possible?

Maybe this is what you want: https://openwrt.org/docs/guide-user/additional-software/extroot_configuration

@Per Thank you, will check it out.

@al_c It work thanks.

Now I came with another problem. ( I'll posted here but if you don't know, I'll go to the Yamon thread.)

Formatted USB as ext4 then created the mount /opt and added the install.sh
changed the permissions to 775 then installed it and for 2 days worked like a charm.

Now after a restart everything works like it should be for like 10 secs and then when the Yamon is loaded, no internet. sometimes I don't have access to the router either...
Its not like I run out of memory cause I have like 75% free plus the usb uses only 4.05 mb out of 16gb...
If then I remove the USB and do a restart then all is ok.

Thanks all of you for your time.