Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1639

Your latest release (02-08) @davidc502 does seem to have improved the WiFi (5Ghz) issues I was having with prior one, thank you for that, but still not completely resolved for me. On the release before last, which I updated to the other week I noticed considerably reduced transmit power/speed on my 1900ACS of around 800, which meant I was receiving around 585. With the latest release this is now 900-1000 and receiving is steady at 702. This compared to the release I have on the other partition, which is from about a year ago and shows 1300/900 (approx) speed, which is more what I would expect. The only other issue I have noticed with WiFi on the last two releases is that similar to @RobbieL811 the 5Ghz station is becoming 'not associated' and requires a reboot to get it back. This seems to be related to channel switching as I always find it on 36 when this happens. Anyone experiencing anything similar?


#1640

Also had a thought, is it possible/advisable to try replacing the mwlwifi driver on the current release with one from an older snapshot? Or would that cause issues do we think?


#1641

I had a lot of error about WIFI lost the connection and so on.
I have changed the mwlwifi driver to version ec0adbf this completely fixes the issues. In the Github Forum they also talk about a driver problem LINK FORUM.


#1642

Aaah thank you, this seems a good plan as I was not aware of the other post. Is it a case of removing the firmware then installing the older version? Or better to use the --force downgrade option through SSH I have read about?


#1643

I've had major issues with 2.4GHz and 5GHz in recent months and had no idea when this was introduced or how. It had been driving me crazy. But thanks to your comment and following the comments on Github as well, this commit version has fixed my issues entirely. Thank you so much!

@eduperez Would you be willing and able to recompile this for the latest kernel in the 18.x series?


#1644

@WildByDesign That particular commit is a bit outdated, and newer commits (including the version compiled into 18.06.2) are supposed to be "better"... But I am willing to provide any particular build that can be helpful. Just give me a few hours and I will make it.


#1645

I think it'd be better and more useful to yunhaurlin (David Lin) and ingamedeo by instead of building from commit ec0adbf, you create a different branch where you git revert e5e0700 (commit 2f160bb for those who have mirrored kaloz's repo). I am still in the process of testing it, but I do believe it has stopped the errors in the logs with this format:

phyX: cmd 0x####=ABCXYZ timed out

Here is the relevant code that takes the value from MAX_WAIT_FW_COMPLETE_ITERATIONS and is related to the error above, leading to ingamedeo's hypothesis:

I've already built it myself, but I've done way too many changes to my build system that will make it incompatible to the average 18.06.2 user (GCC 7.4.0, Kernel 4.14.101, Binutils 2.32, musl 1.1.21, Graphite/Neon optimizations to name a few).


#1646

hi how can i set vlan priority 4 on port 4?


#1647

Remember WRT3200ACM / WRT32X / WRT32XB series have 2x 88W8964 and a third radio using 88W8887 in receive only mode for DFS. https://github.com/kaloz/mwlwifi/blob/master/README.md


#1648

Packages with commit ec0adbf for 18.06.2 available at: ec0adbf.


#1649

Thank you for this @eduperez, do you know if it would work with @davidc502 latest snapshot/build, which runs Kernel 4.14.98? I tried your previous build last night, which was for 4.14.63 so it didn't like that.


#1650

I doubt it... packages for kernel modules must be built for the exact same kernel and be configured with the exact same parameters, any change in the config made by @davidc502 will make my packages incompatible with his builds.


#1651

Ah, I understand, thank you for letting me know though. I will hope @davidc502 is aware of this and can perhaps use a different mwlwifi driver/version for the next build. No complaint at your snapshots though @davidc502 just those developing the wifi drivers it seems.


#1652

Anyone else having an issue getting to the davidc502 website.. Appears dns isn't resolving the domain for some reason.


#1653

No problem here, though perhaps I am the only one...:thinking:


#1654

Working fine from my browser, but OS has obviously cached it. nslookup returns NXDOMAIN :frowning:

Definitely b0rked


#1655

https://davidc502sis.dynamic-dns.net/ is not resolving for me.


#1656

@eduperez Thank you, I appreciate that.

@davidc502 NXDOMAIN here as well.


#1657

@davidc502
works fine for me...

Server:		127.0.0.1
Address:	127.0.0.1#53

Name:      davidc502sis.dynamic-dns.net
Address 1: 45.79.194.151

#1658

Yup, back again now:

Non-authoritative answer:

Name: davidc502sis.dynamic-dns.net

Address: 45.79.194.151