Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1478

Hello davidc,

I must say I find your work useful for the openwrt community.

Though, do you think all your work on drivers (especially on wifi) will be included in the 19.01 official release ?

Would you consider make a build with less packages installed ?

  • without dnscrypt proxy, as dns traffic then is rerouted to unknown servers, that I do not trust, or at best trust less than my ISP DNS.
    It may be just a coincidence, but I noticed more connections tentative from all around the world since I reinstalled your latest build.
  • without multimedia stuff (ffmpeg, codecs, ...)

#1479

@wired : you certainly could disable all LED with a button trigger.
But I read somewhere, for another older device (1043ND), that the LED of the switch are hard wired, thus not possible to disable these by software.


#1480

Hi Davidc,
First thank for your new build (r9133), everything work perfectly on my wrt1900acs except Adblock DNS Query Report. It did worked in r9028 but not in r9133. I've reboot my alternative r9028 partition to see if you had installed tcpdump-mini for it to work but it doesn't seem so. Again thank for your work.


#1481

Hi David - hope your well. Just a quick question, is Minidlna working OK on the latest build?


#1482

Please keep in mind, I am not a developer. You can keep track of all the wifi developments here > https://github.com/kaloz/mwlwifi

No, not likely. The current build has some of the most popular packages people have voted for over nearly the past 3 years.

Unless you have specifically configured dnscrypt proxy, the configured dns setting on your router is what is used.

Please be specific. Find the processes on the router and tie them to the traffic being observed. If you find an anomaly you will need to contact the maintainer of the package to try and find a solution if it isn't expected. Everything that is built or baked into the router is from OpenWrt with the exception of LuCi Rosy and LuCi Darkmatter which isn't installed by default.

Above I'm being asked to make a build with less packages, and then below I'm being asked why it doesn't include multimedia stuff. This is a tightrope I have to walk. What's too many packages, and what isn't enough. My recommendation is if you have packages you want to remove and others you want, then create a shell script, and save it in a directory that will be backed up every time you sysupgrade. As soon as the router has flashed, ssh to the router and run the script. This is what I do for dnscrypt-proxy version 2 and it works great.


#1483

Yeah, not installed by default, but shouldn't be needed. Is there an error in the log that would indicate what the issue might be?


#1484

It isn't a package that I use anymore, so I haven't tested it. What build are you on currently?

Looking below, they did compile and are available.

minidlna - 1.2.1-3 - MiniDLNA (aka ReadyDLNA) is server software with the aim of being fully compliant with DLNA/UPnP-AV clients.
luci-app-minidlna - git-19.025.11637-a0a78ba-1 - LuCI Support for miniDLNA

#1485

Just find this error in log: Please enable the extra option 'adb_report' to use the adblock reporting feature
Will investigate tomorrow.


#1486

image

Lede SNAPSHOT r9133-e906a75e67 / LuCI Master (git-19.025.11637-a0a78ba)

no visible cake, only Fq_codel


#1487

You can add the daily snapshot repository to LuCi and get the package you want that way. However, be sure to do it soon before the daily snapshots change with a kernel bump.


#1488

can you go in detail on how i do this?


#1489

Yes, i use it, works ok. The only issue i have is forced to re-create database (but maybe it's just my issue).


#1490

Hi guys, I'm fairly new to openwrt. I've had some wifi issues with my linksys 1900acs, I've made a thread Linksys wrt1900acs - wifi not associated but not much feedback there.
It's been running smoothly for 1 day and 22 hours, but before that my radio0 and radio1 lost association or something. A reboot of the router fixed it.
Since I don't like lose ends and not knowing why it fails and if it will fail again I ask you guys :slight_smile:
I'm running this firmware version: Lede SNAPSHOT r8810-09004e6e13 / LuCI Master (git-18.350.50885-91a73be)


#1491

If anyone has a problem with IOT products (smart plugs, smart lights, smart something...) like any ESP8266 device tuya,meross etc... just follow this steps

1)disable WMM on wifi 2.4ghz settings
2)connect and set static ip to the device
3)enable WMM again

@davidc502 could you also test it? I have a wrt3200acs don't know if it's working for wrt1900acs
if it's working, could you please add it to the FAQ? It will be really helpful for others.

EDIT: NOT WORKING


#1492

Manual installation of tcpdump-mini and enabling DNS Query Report in Extra Options of Adblock did it. Strange that it was working by default in the previous build 9028 and whitout tcpdump-mini.


#1493

Please let me know on the next build or the one you go to next. If it still doesn't work without tcpdump-mini then that means something likely changed. I might need to add it to the build which would fix the issue. However, I don't know if the two (tcpdump and mini) play well together on the same build.

Since you've installed mini is it working okay with the regular tcpdump?


#1494

David - Just keep doing what you are doing. Most of us here are very thankful for that! Your builds work best on our WRT series devices and that's how most of us like it. Those that wish for a minimal build should download and install the "trunk" package which you can find from: https://openwrt.org/. For those new to this and who have taken the plunge and installed David's snapshot builds, time to learn how to dig-in. It's a lot easier that it looks. Trust me...

For those with requests to remove packages, this can be done from Systems > Software and then click the Remove button for the software package(s) you no longer want. *** Make sure you did your research, know what you are doing, and exactly what you are removing - you may render your router inoperable by removing the wrong package. ***

As for those with requests to add packages, you need to do this fairly soon after a fresh snapshot release so the build kernel is in synch with the package kernels, (otherwise you need to download the packages directly from the corresponding release directory). This can be done from Systems > Software, then click Update lists... (NOTE: if using Rosy as your interface, it needs to be the latest build or make sure you have already done an "opkg update" after logging in via SSH in the terminal/CLI, because the Rosy GUI to update package lists works after an initial update from the CLI). Then click the Available tab, search for your package of choice, and click the Install button. My recommendation to new folks is to do your research before installing anything so you are sure it is what you need and you know how to configure it properly. This is where forums like this and the OpenWRT wiki site are your friends...

To add packages directly from a terminal using SSH:

  • Logon using SSH (EG: ssh root@192.168.1.1 or whatever your router IP address is)
  • Run opkg update once on the command line. This pulls a fresh list of available packages from the OpenWrt online software repositories.
  • Run opkg list to display a list of available packages (The list also has a very short comment on each package).
  • Run opkg list | grep 'searchterm' to filter the list, only showing packages that contain the word 'searchterm' in either the package name or comment.
  • Run opkg install packagename to install any package from that list.
  • Run opkg remove packagename to uninstall an installed package.

Lastly, have fun with it all.


#1495

For SQM users, we have to wait for the next build, since /usr/sbin/tc doesn't run without this patch. :cry:


#1496

Hey David, hope all is well. Just a side note, yes, tcpdump-mini is required now for the newer adblock, in order to use logging. I have seen it also in my last few builds. A message pops up in the log saying you need it for advanced logging. But what I also found is that just trying to pull any logs (to be able to add to white/black list) needs this. The logging tab seems to be useless without, even if you hit the refresh button.


#1497

Great information! Thanks for taking the time to share.

Actually, this has been fixed on the latest build :slight_smile: