Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1438

Isp router to your main router wan. From the main router lan to the extended router lan. On extended router set the wan ip to something in the range of the main router ie: main is 192.168.1.1 then set the extended router to 192.168.1.2 or .3. On extended set the wifi channel to a different channel than the main or isp router. That should work


#1439

i did that @T-Troll , i disabled the DHCP , firewall, and dnsmasq for the second router , so mainly i'm using it now as Dumb Access Point, and connecting through its LAN port but still no luck


#1440

Hi @waynea yes the wall socket in the second room lead to my ISP router


#1441

Hi @WiteWulf Thanks for the detailed reply , yes i followed that link , and tried to make "Dumb Access point" but still didn't work , i also revert the IP back to be withing the same Main router range "192.168.0.1" but no internet still

Hi @Bigdave240 i tried this , and yet no luck in there


#1442

I'm still getting "invalid firmware" when I try to flash the .img file to my wrt32x through the stock linksys web ui. Is there a way I can try to flash it over SSH, or somehow override the checks?


#1443

Have you tried to flash 18.06?

https://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa9/


#1444

Ok. I hope you also check settings (gateway, routing especially) on connected device.
Also please check routing table at WRT, and disable WAN interface.
Dumb mode is so dumb, it's not so many things can destroy it....


#1445

Cabling should be main isp router lan to your router wan then your router lan to lan of next router. Wall socket in second room needs to connect to lan of your router, not to isp router.


#1446

Any change we can possibly keep this thread on topic to Davidc502's build? I come back here regularly to check for updates regarding issues with the build only to see posts about general ethernet and/or openwrt troubleshooting. Thanks!


#1447

I'm running Davidc builds on my WRT 3200 ACM, but since sometime before Christmas I started having issues with 5Ghz Wifi, which drops about after a week.

The last good version is Lede SNAPSHOT r8289-f4b7dfcc4b / LuCI Master (git-18.283.62711-67fd6b6) Kernel 4.14.75 which just works for multiple weeks. Anything newer I flashed always has this issue that the 5Ghz Wifi completely shuts down, even the indicator LED is dead, after a week.

I just wanted to know if that is a known issue, if there is anything I can do to help to fix it?

I tried the build from "2019-01-13 01:25" which I just rolled back this morning again.


#1448

I don't think this is a known issue, and since I have a ACM, and others have not posted a similar issues, I would say this is isolated.

If you get a chance, please roll back to the latest build you have on the other partition, and let 5ghz fail. From there, copy the wifi errors in the system and or kernel logs. I'm not sure if there will be anything in the logs I can directly address. However, we can take those logs over to Github mwlwifi, and someone will probably have an answer.

EDIT
Just had a thought... What channel and width is 5Ghz set to?


#1449

Thank you @butterymales , @T-Troll, i will check the WAN and cabling issues


#1450

Ok, I booted back to Lede SNAPSHOT r9028-75fdf3ba01 / LuCI Master (git-19.011.54860-47d9205) Kernel 4.14.91, let's see.

Configuration on 5GHz is Mode AC, Channel 60 (5300 Mhz) and Width 80 MHz.

I have a constant connection on that from an Archer C9 that does bridging into another room, I have monitoring on that so it should be easy to correlate time wise. All the other clients are more or less volatile, like Phones and Laptops.


#1451

..., Channel 60 (5300MHz) ...

It's a good thing David asked you this because you're running on a DFS channel. Any radar emissions detected by the four external antennas (plus one internal one on the 3200ACM) boots you off of 5GHz. This is because long before 5GHz wifi was a thing, the spectrum was used by: federal radio, amateur radio, weather dopplers, military communications, and aeroports/aeroplanes communications/weather radar. So when they let the 802.11 consortium use 5GHz for WLAN, regulatory bodies (such as FCC & ETSI) said that on certain channels if radar pulses are detected, WLAN devices must cease operations on that channel and switch to another one.

I don't know about other users besides you, but whenever DFS detects radar, 5GHz on my 1900ACSv2-GB will switch channels but then it just won't re-initialise 5GHz (the logs say hostapd error/failure/failed or something along those lines). This is just something that still isn't fixed in the mwlwifi driver (along with MU-MIMO & 160 MHz width operation). I can see that in LEDE the driver version was 2017-06-06 whilst it is 2018-12-10 in the master branch. I'm pretty sure that over the course of that year the mwlwifi driver developer (David Lin a.k.a Yunhaurlin) changed something about DFS which made the device more sensitive to spurious radar emissions. Unfortunately it also drastically increased the chance of a false positive radar detection.

TL;DR/Solution: If your router was bought from the US or Oceania, use channels 36-48 and 149-165 on 5GHz for non-DFS WiFi. Anywhere else, you're probably (varies with country/region) stuck with 36-48 for stable non-DFS operation.

I have a constant connection on that from an Archer C9 that does bridging into another room ...

One more thing, can you clarify by what you mean by a constant connection? In any case, how are they connected? Ethernet? WDS?


#1452

Running the wrt3200acm myself. All working good on latest build. Great job as always David. Thank you.


#1453

Hey, thanks a lot for this very elaborate response, that is amazing. I'll let it run for a while and see what the actual log output is and then switch channels. I think I choose that one because it had the least contention. I'm in Germany, so I guess I'll have to use one of the lower channels. Is there a GitHub issue for that topic somewhere?

Constant connection is just the Archer C9 in bridge mode, so that is a "normal" Wifi connection. I was just pointing that out, in case it is related to something overflowing etc.


#1454

I check 160 at 8xxx firmware before - it works. Did they broke it again?


#1455

Hi guys, I recently set up dnscrypt-proxy v2 and I couldn't access IPv6 sites. What are the necessary settings to change to allow access to IPv6 websites?


#1456

I think it's broken only on certain regions...


#1457

I know another bug, more annoying. If you set 160, 80-40 clients can't connect the network. So, for that time, you can only switch if all you clients are 160.