Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1418

@davidc502 , something weird is going on ... I selected 80 Mhz in Luci, and in the wireless config I can see

option htmode 'VHT80'

But LUCI will only allow me to select 20Mhz channels in the dropdown list ... i tried forcing an 80 mhz channel like 42, 58, 106, 122, 138, 155 , but the interface fails to come online (

[ 6742.820433] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6742.827923] br-lan: port 3(wlan0) entered blocking state
[ 6742.833299] br-lan: port 3(wlan0) entered disabled state
[ 6742.838850] device wlan0 entered promiscuous mode
[ 6742.843630] ieee80211 phy1: change: 0x40
[ 6742.881118] device wlan0 left promiscuous mode
[ 6742.885663] br-lan: port 3(wlan0) entered disabled state

#1419

Have you tried VHT80 on channel 36 / 40 / 44 / 48 as these are no DFS channels.
Just a though like.


#1420

Man, you're a genius! It worked .... Now I'm at 173/55 mbits (from 110/16 before) on channel 48 ... still not 500 tough :slight_smile: , I suppose because channel 48 is a 20 mhz channel? Why can't I use the 40 , or 80, or even 160 mhz channels?

EDIT: Switching to Channel 36 took me to 205/50 mbps !

The software that you recommended is just awesome! For those of you that have never seen it, it just looks gorgeous ... and IS useful :slight_smile:

wifi


#1421

After soft bricking (lost ssh/luci access) the primary partition on a wrt1900ac device I flashed using the latest sysupgrade (4.14.91 kernel). This succeeded, access with luci/ssh is working again and all settings are default. However, the kernel is not 4.14.91, it is 4.14.54.

I am not sure how to troubleshoot this. I've tried flashing again with no change. (I don't think I checked syslog though). Any ideas?

Thanks.


#1422

glad to of helped, if your using channel 36 and set it to VHT80 then your using VHT80 and channel 36. However that looks like a Wifi nightmare in the 2.4Ghz range ouch.


#1423

Can you explain to me that of the channels a little more? I select channel 36 ,and set it to VHT80 ... from reading the specification from the IEEE, looks like my router would use 4 x 20 mhz channels, right? Like in the picture below:

Untitled

That's why LUCI wouldn't let me choose the CHANNEL 42, which is the official number for the 80mhz channel that includes channels 36,40,44 and 48?

Untitled


#1424

@solidus1983

For apps that have been deleted, the configuration files remain behind, so for example in /etc/config, the configuration for dnscrypt will still be there which is fine. You can manually delete them, and then create a backup, and they shouldn't come back on the restore or during sysupgrade.

For stuff that isn't being restored; you may have to create a restore path. You can read how to do so from a post I made yesterday - That will ensure what ever it is you want restored will be there.

As for flashing the current partition... There have been some really savvy folks who have done it, but is not recommended. I recommend blowing away the factory firmware, and you can always flash back when you want. I completely understand the reasoning for having a safety net.

Best Regards,


#1425

Thanks for the reply, Was keeping the Stock firmware as i found issues with it and contacted support about them as the QoS they have doesn't do well in the bufferbloat department whilst your build with sqm does wonders.

I take it if i do a normal sysupgrade via GUI and it flashes the other partition it keeps everything like the original partition the upgrade was done from ?

If it does will just do sysupgrade with the fancy crap.


#1426

"I take it if i do a normal sysupgrade via GUI and it flashes the other partition it keeps everything like the original partition the upgrade was done from ?"

It is supposed to do that. However, there can be exceptions.


#1427

Hi, Wen I try to flash the new sysupgrade image the sha256 that the router shows is different than the one on the page https://davidc502sis.dynamic-dns.net/releases/, then it just refreshes. I have LEDE Rango wrt3200ACM


#1428

Hi Guys & David,
Thank you for the great work , appreciate it !
i'm running your latest build on my wrt1900v2, i have a naive issue ,
i'm trying to connect the router through Wall Ethernet socket
and then i plugged that into the router wan port
and i made sure the Wan interface is DHCP
i also changed the Lan interface to use a different IP than the Wan
But i still couldn't have internet connection over the WIFI

However, when i connect my laptop directly to the wall Ethernet port , i can connect normally to the internet :slight_smile:
direct

i tried to search google about similar configurations but none of them worked for me ,

could you please help me out ? what configurations i should change to have it work ?

Thank you in advance.


#1429

The sha256sum's are correct.

davidc502@pc2:~/Downloads$ sha256sum lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-factory.img 
398ff1ea5f07929211243f8f2d9945767eade2b0986a1e9c249def09d1380fec  lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-factory.img
davidc502@pc2:~/Downloads$ sha256sum lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin 
108df1fa592a7377d4a53735a8555bff9845fc4d142e5e0f3abb8b1e22fed3bd  lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin

#1430

Not sure whether I understand yr architecture correctly but you need a standalone modem with the WRT1900.
It has to be
Wall socket > csble > modem > cable > WRT1900 wan port
Plugging yr laptop directly to the wall socket probably works because it has a built in modem


#1431

Hi Waynea,
Thank you for your reply, i grouped one image for the whole setup that i did so far , and added some comments in it.
Setup_Config

i have two routers : one from the ISP PPPoE (D-Link) which provide internet (wireless) as well.
i connected one ethernet cable from one of its LAN ports to the Wall Ethernet socket , so that i can receive it in the second room.
in the second room , i plugged another Ethernet cable in another WALL socket.
now , whenever i'm connecting my laptop it works fine (Obtain IP and got internet access)
but when i tried to connect that cable in the second room to my WRT1900V2 router through its WAN port, the router can't obtain any IP nor connect to the internet.
i set WAN in my second router to be DHCP , and i also changed the LAN IP range to a different one than the main IP range , "10.0.0.1".

i tried to connect through LAN port for the second router but still no internet.
i also tried to configure the V-Lan by mapping certain LAN port to the WAN processor , but still nu luck.

i would appreciate any guidance , how to make it work, as i don't have any wireless coverage for this second room.

Thank you


#1432

I'm using a 1900ac as a wifi network extender. 5Ghz as client, 2.4Ghz as AP.
I have a weird issue where intermittently can't ping main router. wl show connection at full strength and the issue resolves itself usually in a few minutes or with a /etc/init.d/network restart. The issue has increased in frequency since the previous update. I had hoped this update would have fixed it but no luck
Any ideas how do I go about debugging this issue?
Thanks


#1433

Maybe it's not a good idea to have doubleNAT for WRT clients.
You can connect router to LAN port instead (or just add WAN port into LAN group), and work in the same LAN segment.


#1434

Weird little problem with dnscrypt-proxy v2 last night: been running it for months based off davidc502's howto with no problems at all. Lost DNS late last night and spent a while debugging (restarting dnsmasq, restarting the router, etc.) before realising that /usr/sbin/dnscrypt-proxy was missing. The config files were still there, so I just downloaded the tarball again and replaced. Like I say, weird, no idea how that happened ¯\(ツ)


#1435

On the topic of bearDropper, are there any other users here still using it? It was one of the first things I installed when I started using david's builds last year, and it seemed to be working well then. But I've noticed just recently when idly watching syslogs scroll past that it's not blocking IPs with repeated failed logins any more. I was sat watching the same IP fail to login over and over again, every few seconds, for about half an hour the other day and bearDropper did nothing. I restarted the service a few times and nothing changed.

Sadly it looks like bearDropper has been abandoned (looking at it's github page) as there've been no updates to any of the authors repos for 2-3 years :frowning:


#1436

Forgive me but I'm confused.
The wall socket in the second room - where does it lead to?

  1. your ISP router?
  2. direct to your ISP?

#1437

Hi @Waleed, I wouldn't recommend running in this configuration as you'll be "double NAT'ing", with all your internet traffic passing through two routers. If your ISP uses an ethernet presentation I'd advise taking the D-Link out altogether and replacing it with the WRT1900. If you want to use the WRT1900 as an additional access point (with no routing or firewall) you'll need to reconfigure it as such. This guide is a good starting point for that:
https://openwrt.org/docs/guide-user/network/wifi/dumbap

Also, your WRT1900 is probably not running properly as you've changed its LAN address from its default 192.168.1.1 to 10.0.0.1. I had similar issues (as have others) when I tried to do the same. The scripts to change these details don't seem to update everything that's necessary.