Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1256

The work around is to just un-comment out the first line in the /etc/config/uhttpd configuration.

config uhttpd 'main'
#	list listen_http '0.0.0.0:80'    <<<<<<< remove the comment # from this line. 
#	list listen_http '[::]:80'
	list listen_https '0.0.0.0:443'
	list listen_https '[::]:443'
	option redirect_https '1'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '3'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'
	option ubus_prefix '/ubus'

#1257

Yes, just a frontend problem, not backend. I've already resolved like that, thanks.


#1258

Did you happen to try more than one LuCi? I tried it on Rosy.


#1259

All same problem


#1260

I use these builds for half a year now, though the Rosy theme is not displayed well, left sidebar is hiding the countdown before a change. And inside Network>Interfaces>LAN>Physical settings the "interface" drop down is not showing choices.

rosy1

rosy2


#1261

Thanks for the information... Well, it looked like Rosy was actively being supported, and was the main reason why I switched. However, the last 4, formatting issues have been sitting in the queue for a week sigh......

Feel free to report this. Read above posts for the Rosy Github.


#1262

Hi all, got a query with dnscrypt 2.
Ive installed this as per your instructons david. The install seems Ok when I check it. But when I try the test to resolve I get

Domain exists: yes, 4 name servers found
Canonical name: google.com.
IP addresses: 216.58.204.14
TXT records: docusign=05958488-4752-4ef2-95eb-aa7ba8a3bd0e facebook-domain-verification=22rm551cu4k0ab0bxsw536tlds4h95 v=spf1 include:_spf.google.com ~all
Resolver IP: 141.101.70.44

This looks fine, as that IP is one of Cloudfare's servers here. But I run a dnsleak test from the web it tells me that my DNS queries are going to my ISP. Rival dns test services give the same result. So is Dnsproxy working correctly? or is being somehow bypassed?
PS - ive switched the value for IPv6 to True in the dnscrypt-proxy.toml
file - still the same result


#1263

I have installed Davidc502 LEDE package for a new Linksys WRT3200ACM router. Firmware flash takes fine and the router works as it should for about 30min - and hour. Then I start seeing high latency and really slow speeds. Speed tests at Speakeasy.net show 2-4Mbps down and 0.8Mbps up. That is on a comcast highspeed cable service that normally sees 150+ Mbps down and 10+ Mbps up. Unplugging my computer from the router and directly into the cable modem I will see the normal highspeed results. Booting to the Linksys firmware recovery partition or reflashing with DDWRT I will also see the speeds revert and stabilize. Flashing back to the LEDE build the router works for a little while, then begins to slow down again. Thoughts??


#1264

A couple things you want to check are ---

  1. Make sure "Use DNS servers advertised by peer" is unchecked. Look in Interfaces - WAN - Advanced settings..

  2. Be sure your clients are receiving the proper dhcp DNS assignment. Check to see that your clients DNS settings are set to go to your GateWay, and not some other DNS server on the internet.


#1265

Hi David
thanks as always. I deleted the files and then reinstalled the whole thing form scratch. And unchcecking the box in the WAN section seems to have fixed the issue; all DNS leak test sites now show Cloudfare!


#1266

I just uploaded new builds to the server and are ready for download.

Kernel version = 4.14.88
WiFi driver = 10.3.8.0-20181210
Build = r8810

Several kernel bumps since the last build.
There have been some wifi driver changes and firmware changes.
softethervpn was removed from the build as it was causing compiling issues.


#1267

lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin
maybe broken?
Sha256 checksum 9990b576258f87a7f761a7bd80afca03881a32aae5a303262ebb86acfdfcf47f
Which not equal to sha256 in Downloads.
Redownloaded 5 times.


#1268

checking checksums.


#1269

getting a similar issue with WRT1200AC

Errors in log
Tue Dec 18 18:16:20 2018 authpriv.info dropbear[8733]: Early exit: Terminated by signal
Tue Dec 18 18:16:25 2018 authpriv.warn dropbear[8849]: Failed loading /etc/dropbear/dropbear_ecdsa_host_key
Tue Dec 18 18:16:25 2018 authpriv.info dropbear[8849]: Not backgrounding


#1270

The checksums.... check out fine. EDIT I did check each image and they all match the checksums.

From the server ---
sha256sum ./lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin
f40c031b3dd6019d7adbb0892b2fd0f6af9990b6fdcc32965bb68b19b4268024 ./lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin

Downloaded to my linux machine

davidc502@pc2:~/Downloads$ sha256sum ./lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin
f40c031b3dd6019d7adbb0892b2fd0f6af9990b6fdcc32965bb68b19b4268024 ./lede-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin


#1271

Not in my logs today, but I did have the same errors yesterday. Have you tried build r8810 yet?

root@lede:~# logread | grep dropbear
Mon Dec 17 22:17:12 2018 daemon.notice procd: /etc/rc.d/S50dropbear: interface wan has no physdev or physdev has no suitable ip
Mon Dec 17 22:17:12 2018 authpriv.warn dropbear[2971]: Failed loading /etc/dropbear/dropbear_ecdsa_host_key
Mon Dec 17 22:17:12 2018 authpriv.warn dropbear[2971]: Failed listening on '22': Error listening: Address not available
Mon Dec 17 22:17:12 2018 authpriv.info dropbear[2971]: Not backgrounding
Mon Dec 17 22:17:18 2018 authpriv.warn dropbear[5729]: Failed loading /etc/dropbear/dropbear_ecdsa_host_key

#1272

The errors i listed are from your 8810 release. WRT1200ACv1 failed.
I am going to try it on my WRT1900ACSv2 & WRT1200ACv2


#1273

Thank you. Problem was with update through Luci - wrong checksum.
Download and upgrade through ssh - no problem. Sorry for disturbing.


#1274

Same "issue" here on my 3200ACM. Downloading it from your site gives me the same checksum in my OS but luci shows the sha256 as
9990b576258f87a7f761a7bd80afca03881a32aae5a303262ebb86acfdfcf47f

This is the first time the checksums haven't matched for me on luci and I believe it's the first time I'm updating since the new theme went in if that helps track down what's causing it.

followed the wiki instructions on updating over ssh though and it worked fine.


#1275

Build r8810 works well on my Linksys WRT1900ACS V2 for the few hours that I've been running it. I augment the build with DNS-over-TLS (getdns and stubby), vpn-policy-routing, and wireguard and it all is operating smoothly. I'm glad the rosy theme is now displaying memory use correctly on the status overview page.