Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1214

Oh thanks for the quick reply! I saw in other threads that they were already testing WPA3, so I thought I wanted to try it out. Thanks a lot @davidc502 @slh @FCS001FCS


#1215

Doing a speed test I noticed Inbound / Outbound are reversed for Eth1 in the Real Time Graphs.

Anyone else seeing the same issue?


#1216

@davidc502 -
as soon as i change my lan IP address to 192.168.1.254, the lan cant get WAN access. the ip routes seem fine. i think it must have to do with dnsmasq. even if i diable dnscrpyt, the problem persists.
see attached code

on openwrt 18.06.1, with router at .254:
 ip route show
default via XX.YY.240.1 dev eth1.2  src XX.YY.244.67
XX.YY..240.0/20 dev eth1.2 scope link  src 65.29.244.67
192.168.1.0/24 dev br-lan scope link  src 192.168.1.254

#1217

Hi,

I've got a problem with my Notebooks wifi on my AC-Wifi router. If i run a test on speedtest.net, the download test works fine but the moment it tries to do the upload test the AC-Wifi gets disconnected and sometimes wount reconnect if i don't reboot the router, I'll post the systemlog. My guess would be the notebooks wifi driver, because i updated it recently and the same test works fine on my mobile using the speedtest.net app. But a confirmation and explanation of you pros would be appreciated.

@David Thanks for your great work, i love your cfws, they are the best!

Notebook, Asus Zenbook Pro ux501vw-fy144t, Intel Dual Band AC 7265 driver version 19.51.15.3
Router Linksys WRT1900ACS, Lede SNAPSHOT r8614-78ca6a5578 30.11.2018

Wed Dec  5 19:03:34 2018 kern.info kernel: [  670.648449] ieee80211 phy0: radar detected by firmware
Wed Dec  5 19:03:34 2018 daemon.notice hostapd: Wood-AC: DFS-RADAR-DETECTED freq=5260 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5290 cf2=0
Wed Dec  5 19:03:34 2018 daemon.notice hostapd: Wood-AC: DFS-NEW-CHANNEL freq=5180 chan=36 sec_chan=1
Wed Dec  5 19:03:35 2018 kern.info kernel: [  671.252899] ieee80211 phy0: channel switch is done
Wed Dec  5 19:03:35 2018 kern.debug kernel: [  671.258482] ieee80211 phy0: change: 0x40
Wed Dec  5 19:03:35 2018 daemon.info hostapd: Wood-AC: IEEE 802.11 driver had channel switch: freq=5180, ht=1, vht_ch=0x0, offset=1, width=3 (80 MHz), cf1=5210, cf2=0
Wed Dec  5 19:03:35 2018 daemon.notice hostapd: Wood-AC: AP-CSA-FINISHED freq=5180 dfs=0
Wed Dec  5 19:03:40 2018 kern.debug kernel: [  676.739468] ieee80211 phy0: Mac80211 start BA 48:45:20:51:4b:45
Wed Dec  5 19:06:49 2018 kern.debug kernel: [  865.518426] ieee80211 phy0: Mac80211 start BA 5c:51:88:90:58:b1
Wed Dec  5 19:06:50 2018 kern.debug kernel: [  866.191444] ieee80211 phy0: Mac80211 start BA 5c:51:88:90:58:b1
Wed Dec  5 19:08:45 2018 daemon.notice hostapd: Wood-AC: AP-STA-DISCONNECTED 48:45:20:51:4b:45
Wed Dec  5 19:08:45 2018 daemon.info hostapd: Wood-AC: STA 48:45:20:51:4b:45 IEEE 802.11: disassociated due to inactivity
Wed Dec  5 19:08:46 2018 daemon.info hostapd: Wood-AC: STA 48:45:20:51:4b:45 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

#1218

I just wanted to follow up with you that I haven't found out any other information on this issue. Last night I tried to change my LAN IP address to 192.168.1.254, and the router bounced back and fourth between 1 and .254 for a few minutes until it decided to go back to .1 and stay there. I was able to log into .1 and LuCi gui said LAN was configured for .254 << Go figure.

I don't know how important it is for you to use this IP address, but if it is a strategy to stay a bit more secure through obscurity, I might recommend another subnet using .1.

Thoughts?


#1219

I was going to get smart and tell ya to not run a speed test ! :slight_smile: Then everything would be fine, and I wish things were that simple at times.

Anyhow, there is nothing in the logs to indicate an issue. I see DFS is being used, so at some point Radar was detected and switched channels. If it switches to another DFS channel it can take a few minutes to come back up. If you happened to be running a speed test at that time, then it would have failed.
As for the other logs, it just shows normal association/disassociations to the AP. Keep in mind, some devices do not like DFS channels. I have a wifi extender that at times refuses to connect and when it does, will drop connections at times. Does this Notebook have wifi issues if you select a non DFS channel?


#1220

I want correct to someone telling
Rosy theme showing memory and active connections when only we point to it by mouse cursor

Thanks


#1221

regarding my choice of router LAN address of 192.168.1.254:
most devices default to 192.168.1.x, and will get an address from the main router if all is good. if a device fails to get assigned an address, or, even worse, decides (by misconfiguration or failure) to be a dhcp server, then my home network is toast if my main router is also at 192.168.1.1. so by placing it at a different address, i significantly reduce the addressing conflicts when plugging in and testing new devices.
since i like to screw around with new devices, and also like to avoid taking down the whole home, i have found this approach works pretty well, with the .254 address a known, low-conflict place for my router to 'always' be at.

thus i would very much like to get your build workable with a different lan address, but still in the 192.168.1.x subnet.


#1222

Confirmed -- It is the graphs/bars that are not working.


#1223

I have a screen format issue in the Network Shares settings, fields name and path are too small to input data. Anyone experiencing the same issue, this is using luci-theme-rosy_git-18.333.34665-4f2b80e-1 on davidc r8373.
image


#1225

No. It does not show up even after I removed rosy and uninstalled cpu frequency and reinstalled it. It must be totally broken.


#1226

Try adding a line or two below and that should give enough room.


#1227

This is my sambashare config file, what do you mean by adding a line.
Also, the Shared Directories delete icon is partially cut off screen when view in google chrome.

option name 'Partages'
option path '/mnt/sda1'
option guest_ok 'yes'
option read_only 'no'

#1228

on the samba front, I just installed r8614... I was running r7xxxx something (about 6 months old). I found some of my samba/netbios stuff was not working properly. Specifically, I wasnt seeing netbios working.

This may have been a samba4 change in the build, but while debugging I found the following entry in my smb.conf:

######### Dynamic written config options #########

	disable netbios = yes

I had no idea where that came from. I went digging into init.d and found this in the samba4 script:

echo -e "\n######### Dynamic written config options #########\n" >> /var/etc/smb.conf
	if [ "$DISABLE_NETBIOS" -eq 1 ] || [ ! -x /usr/sbin/nmbd ]; then
		echo -e "\tdisable netbios = yes" >> /var/etc/smb.conf

I scratched my head on that for a while as I have no such disable_netbios option set... and then I realized it was triggering on the

[ ! -x /usr/sbin/nmbd ]

Sure enough, nmbd is missing from /usr/sbin. Was this a change to samba4 (did they remove nmbd?), or am I missing another package now?


#1229

You had mentioned a screen format issue in the Network shares section. I have found in 2 other areas with this type of problem, and adding lines below will alleviate the issue.

If it is where the name and path are input, then that trick will not work.


#1230

Issue open


#1231

@davidc502, quick one : I'm on your latest build now, and installed snmpd from the LEDE official repository (not yours). It is not starting ... in the log i get this 2 entries:

Any ideas can this be related to?

kern.info kernel: [ 1475.537657] xt_CT: No such helper "ftp"
kern.info kernel: [ 1475.756795] xt_CT: No such helper "ftp"

Same thing in DMESG:

[ 2158.382182] xt_CT: No such helper "ftp"


#1232

Another issue with formatting open for Sofware -- Update Lists. Text hidden behind menu.


#1233

I wouldn't think those are related to snmpd, but may be related to iptables.

It shouldn't be an issue to install snmpd from the lede repository, but I did install from the default repository for the build and it did start.

root@lede:/etc/opkg# ps -ef |grep snmpd
root     11768     1  0 17:35 ?        00:00:00 /usr/sbin/snmpd -Lf /dev/null -f
root     11885 10690  0 17:35 pts/0    00:00:00 grep snmpd

Is listening
root@lede:/etc/opkg# netstat -an |grep 161
udp        0      0 0.0.0.0:161             0.0.0.0:*     

Is anything generated in the logs with the following command?

/etc/init.d/snmpd restart

Also, do you already have a snmpd configuration in - cat /etc/config/snmpd

You may consider renaming it to snmpd.old and re-installing snmpd and see if it starts.


#1234

Screen format issue -- Configure opkg