Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1194

Even with this new theme, collectd-mod-cpufreq is still not working.


#1195

The problem is the wrong display
Status-Firewall
/cgi-bin/luci/admin/status/iptables


It does not depend on the theme
these rules are added and work, but not displayed

iptables -A zone_vpn_server_2_forward -s 10.20.0.0/16 -d 195.82.146.214 -j zone_wan_dest_ACCEPT -m comment --comment "rutracker"
iptables -A zone_vpn_server_2_forward -s 10.20.0.0/16 -d 195.82.146.114 -j zone_wan_dest_ACCEPT -m comment --comment "rutracker"
iptables -A zone_vpn_server_2_forward -s 10.20.0.0/16 -d 104.28.17.16 -j zone_wan_dest_ACCEPT -m comment --comment "rutracker"
iptables -A zone_vpn_server_2_forward -s 10.20.0.0/16 -d 104.28.16.16 -j zone_wan_dest_ACCEPT -m comment --comment "rutracker"
iptables -A zone_vpn_server_2_forward -s 10.20.0.0/16 -d 195.82.146.121 -j zone_wan_dest_ACCEPT -m comment --comment "bt2"
iptables -A zone_vpn_server_2_forward -s 10.20.0.0/16 -d 195.82.146.122 -j zone_wan_dest_ACCEPT -m comment --comment "bt3"
iptables -A zone_vpn_server_2_forward -s 10.20.0.0/16 -d 195.82.146.123 -j zone_wan_dest_ACCEPT -m comment --comment "bt4"


#1196

Delete the luci-statistics configuration, uninstall and then reinstall luci-app-statistics. That should fix the problem

EDIT

I forgot that was a separate module. Please uninstall Rosy which will fall back to bootstrap. Does the CPU Frequency mod show up?


#1197

I undated to latest R8614 but had some issues with the configuration files not being fully saved on a couple (at least last) versions of Davidc502 image. I think it was my setup and not a general problem.

BTW I went to Bootstrap Theme to avoid any issues with Rosy theme.

Recovered my setup by a lot of cut/paste from prior files saves (tar.gz) but I am having problems with Dropbear SSH login. I had it working before for many revisions but just cannot seem to get it going now,

The error on Putty is " Server refused our key" when I try to login via SSH.

I went through the renewal of the keys config but still no luck.

Anyone having a similar problem?

Is there a complete guide on how to setup SSH via GUI available? I did a search for a guide but none I found helped.


#1198

Have you tried another ssh program like MobaXterm?


#1199

Yes, Just tried installed MobaXterm and same error as Putty. BTW Putty worked for yeas on this WRT3200 and before on my old WRT1900.

I am convinced it is the WRT3200 setup and maybe I am missing some basic setup. Or there is an issue with the SSH on the latest build.


#1200

Seems there's a bad pub/priv keypair. Can you generate a new key pair?


#1201

I update my gear to latest release, and configure our what happened to collectd.
No, it's not exactly the config file problem - just 2 plugins previously installed in firmware missed, as a result collectd didn't start with old configuration.
You can continue using you old config after install collectd-mod-sensors and collectd-mod-ping (this one doesn't work, in fact, with "access denied" in log) via opkg or remove corresponding plugin section from config.
So, please, check you build config about it.

PS: use "collectd -f" to check about this problem in console.


#1202

@davidc502
how do I enable WPA3 to try them out in your builds?

thanks so much for your builds and your hard work!!


#1203

I haven't kept up with the project, but imagine this is still be worked on.


#1204

Early WPA3 support is available, with two caveats:

  • wpad-openssl or wpad-wolfssl need to be installed (wpa3 requires building against an external crypto library for SAE support)
  • luci doesn't know about it yet, so you do need to configure it by hand

#1205

Even if the configuration was done on the router side, you still need a client that understands how to connect wpa3.


#1206

Already tried that but no luck. I will try a fresh install and see if that helps.

Thanks.


#1207

Update: Uninstalled via Luci and reinstalled. Then paired the keys per normal and all is OK now.

Not sure what it was.

Thanks to Davidc502 for the assistance.


#1208

So far - l'm liking r8614 :slight_smile: - Liking rosy as the interface (yes I sorta agree the bootstrap should be default - but there has to be a good point of difference here. Wired speedtesting so far is maxing out the Gigabit Fibre connection, and wireless speeds have also been good.... so far so good.. WRT3200ACM


#1209

Just popped all r8614 on my WRT32X, all looking good except for some stats missing in the Rosy theme on Status->overview (memory and active connections). These work fine in Bootstrap on the same build.


#1210

Known issue, but thanks for reporting.


#1211

@davidc502 -
i have put r8614 on my wrt32x, but can't get it to work if i move the lan address off 192.168.1.1. i can access the router at 192.168.1.254, but internet access is blocked. i have rebooted router and re-acquired IP address from clients, which correctly show gateway as 192.168.1.254.

others have reported this; in my experiences a few builds back, i could get this to work if i moved the lan address as the last configuration step. now, no go.

thoughts?
thank you!


#1212

Seems I do recall others attempting the same thing and having issues... Have you tried 192.168.2.1 for the Gateway? Don't forget to configure DHCP to dole out addresses in that range if you decide to try it. Also, any specific firewall rules for clients would need to be changes as well.

EDIT

If you get a chance, run the following command whilst in the 192.168.1.254 configuration -- ip route show

root@lede:~# ip route show


#1213

I moved from r8466 to r8614, because I was having a problem, but the problem persists.

I have a PPPoE internet connection, through my optical fiber modem.

It is not detecting when this connection drops. Even if I disconnect the cable from WAN port, it do not detect it.

I added a script to /etc/hotplug.d/iface, to try to debug it, but it do not rise any hotplug event on disconnection (even removing the cable from WAN port), just on first ifup event. Since it does not rise any ifdown, when i replug the cable, if does not rise any ifup event. I need to manually restart the interface to reconnect my internet.

When I go to luci->network->Switch, it shows the right WAN port connection status ('1000baseT full-duplex' when connected and 'no link' when disconnected).

Anyone with this problem?