Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1112

No dnscrypt v2, stock davidc firmware plus kmod-usb-printer / p910nd


#1113

Here's my overlay on davidc r8373 with dnscrypt v2

overlayfs:/overlay 13.3M 4.3M 8.3M 34% /


#1114

Can you look inside of /overlay/upper/usr/sbin and see if there's a 6mb dnscrypt executable in there?


#1115

Looking in the device page ... it looks like it should have more than 13.4MB of overlay... look

Untitled


#1116

Was thinking the same thing earlier... Seems there was some discussion about it on the old forum.

The 3200acm has twice the flash size, but ends up with 3 times the usable flash size than the 1900acs? I don't know why that is. This may be something that needs to be reported as an issue because when
mariano.silva reports he's running out of space on his 1900acs, I'm thinking the guy must be running a hell of a lot of add-ons :slight_smile: In reality that just isn't the case. The truth is we have 1900acs owners with limited space to begin with.


#1117

You calling me "a guy" just makes me proud :wink:

I'm running your build, plus this stuff ( some of them are pre-loaded now in your image )

    • rsync
    • collectd-mod-conntrack
    • collectd-mod-df
    • collectd-mod-disk
    • collectd-mod-iptables
    • collectd-mod-netlink
    • collectd-mod-ping
    • collectd-mod-processes
    • collectd-mod-protocols
    • collectd-mod-entropy
    • collectd-mod-sensors
    • collectd-mod-syslog
    • collectd-mod-tcpconns
    • collectd-mod-uptime
    • collectd-mod-wireless
    • collectd-mod-logfile
    • kmod-fs-f2fs
    • e2fsprogs
    • cfdisk
    • tar
    • f2fs-tools
    • vsftpd-tls
    • bmon
    • mailsend
    • mpack
    • ssmtp
    • kmod-fs-cifs
    • cifsmount
    • transmission-daemon-openssl
    • transmission-web
    • luci-app-transmission
    • kmod-ipt-ipset
    • luci-theme-darkmatter
    • luci-app-dnscrypt-proxy
    • mtr
    • collectd-mod-snmp
    • snmp-mibs
    • snmp-utils
    • snmptrapd

The ones that really takes space are snmp-mibs, transmission, and dnscrypt2 (that's the killer, 6MB!)


#1118

ls -l /overlay/upper/usr/sbin
6709352 dnscrypt-proxy


#1119

See link below as it explains how to compress the dnscrypt-proxy executable down to 2MB.

I copied these instructions -- Link below.

"The dnscrypt-proxy file is quite large, but can be compressed for a massive reduction of its size, from ~12 Mb down to ~2 Mb."

In order to do so, use UPX on any platform (Windows, Linux, macOS...) with the following command:

upx --lzma dnscrypt-proxy


#1120

WOW! That was just AWESOME!! Thanks, @davidc502!

upx --lzma dnscrypt-proxy
                       Ultimate Packer for eXecutables
                          Copyright (C) 1996 - 2018
UPX 3.95        Markus Oberhumer, Laszlo Molnar & John Reiser   Aug 26th 2018

        File size         Ratio      Format      Name
   --------------------   ------   -----------   -----------
   6709336 ->   1760820   26.24%    linux/arm    dnscrypt-proxy

I don't see how can't we make this a default for all software in the system... the speed loss of decompression in realtime when the executable loads is meaningless given the huge processing power of this routers!

/dev/ubi0_1              13.3M      7.1M      5.5M  56% /overlay
overlayfs:/overlay       13.3M      7.1M      5.5M  56% /

#1121

@mariano.silva how to run the compressed programm ?


#1122

David,

This upx executable compression is an awfully neat trick to save space. I changed some time ago from using dnscrypt-proxy v2 to doing DNS over TLS with stubby and dnsmasq-full, however I still like to have dnscrypt-proxy on my WRT1900ACS, and it's great to save the 4 M.


#1123

UPX compresses the file and leaves it executable ... it's like a ZIP file that has an exe header. The resulting compressed file is actually executable, don't worry. It works fine. I've been doing this for over 30 years, from the D.O.S. times, when we struggled with disk space when the largest hard drives for PC's were of 40 megabytes :slight_smile:


#1124

r8466 has just been uploaded to the server.

Kernel version = 4.14.81
WiFi driver = 10.3.8.0-20181114
Build = 8466

I did notice that LuCi gui has been worked on since the last build. It appears the software section has been updated, but it isn't working properly for me. Just to rule my machine out, is anyone else having issues with the Software section?

minidlna is back. On this build I did install ffmpeg-mini to satisfy a minidlna dependency. However, on the next build I will remove ffmpeg, because the developers fixed the dependency issue.


#1125

Same for me, i'm running another variant of OpenWrt compiled by Daniel Petre, but it seems some issues displaying some display problems, some options in the software submenus ...
rosy

@davidc502 congratulations for everything you do, i watch with interest this section...


#1126

David,
Update r8466 did not work well for me at all on my Linksys WRT1900ACS V2. I went through the upgrade process as usual, and after the router rebooted I could neither access the router through the LuCi web interface nor through SSHing from my wired desktop and I had no access to the internet, despite the router front panel LEDs lit as I normally expect them to be. Both the SSH and the GUI access would just hang. I had to resort to a "hard reset," turning off/on three times to get to the other partition.

I tried this twice to ensure there wasn't something in my normal procedure that I had erred, and I had the same behavior twice.

Any thoughts?


#1127

Frankly with SuperWrt version, i had no trouble accessing the router, just some small problems with the submenus....




#1128

Just installed r8466 and software section doesn't work properly also for me. I have installed luci-app-statistics and it doesn't work correctly either.


#1129

Thanks for the information. I had the same issue the first time it came up, and it became unresponsive, but after a reboot it acted fine. For a test, I rebooted a couple more times to make sure there wasn't a lingering issue. Whatever it was, it happened initially when the router came up, but after that reboot it was fine.

If you get a chance, use the advanced reboot to go back to the other partition, and see if there is still an issue.

Thanks,


#1130

Thanks for the information. You can try the luci-app-statistics off of the daily snapshots, and it should work fine.


#1131

David,
The rebooting back into the partition with r8466 worked in that I can now access the router through LuCI, however I still can not ssh into the router, and I still have no internet access. This is surprising because according to the LuCI Status Overview page, the router does have my usual external IP address and DNS servers.

I used Advanced Reboot twice to go into the r8466 partition thinking it might clear up, but in both attempts I had the same result: access to the router through LuCI, no access to the router through SSH, and no internet despite the router having a valid external IP address and DNS servers.