Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

I found my problem, the routers were not on the same channel, and it has to be and didn't know it until I read it

voilà

You have to use DSA in order to use IGMP snooping.

Not sure about that.. I have IPTV and have been using IGMP snooping for years. Unless something has changed that requires it?

Hi, guys.

I have a strange wifi issue with latest build, and need you help (i'm out of ideas).

Being short, i have one IoT device in my network, connected to wifi (it has Broadcom adapter).
It works well, until... i try to connect it from my notebook using SSH. And it acts extremely slow.

Investigation reveals very strange behavior - i have slow ping with packet loss then ping it from notebook. And only this way - ping from device to notebook are ok, as well as from device to router and from notebook to router. Ping from router to device slow as well.

As i see in summary, it's always stuck to 54Mbps (g?) to router uplink, and don't going higher.

I check it with other router i have - it doesn't have this issue.

Any ideas where to look?

IGMP snooping with swconfig worked on software bridge level, such as eth0.1 to wlan0. LAN to LAN didn't work.

DSA leverages the full potential of the switch, retaining 802.1q tagged traffic between switch ports within the switch fabric instead of routing/processing such traffic through the CPU plus providing native vlan filtering.

Thanks, but excuse my ignorance but how would I enable DSA? My OpenWRT network config is probably a few years old (though I am have the latest image for wrt32x ), but I don't see an option for DSA and I am struggling to find information about how to correctly enable it?

It is being enabled through kconfig flags at compilation time and there is nothing particular in /etc/config/network that deals with DSA management since there is currently no UCI support for the underlying bridge command implemented https://github.com/openwrt/luci/issues/2798.

Ah, ok, so is there no OpenWRT image that I can use with it enabled already? Do I really have to build my own image to enable this on my WRT32x ? Seem a bit strange to even have to IGMP_SNOOPING option if the image doesn't support it without DSA

Not in the stable branch but the Master branch probably has it enabled.

ok, so is there is a 'beta' image based on master then or do I have to build my own image?? I have in the past built it for some other routers but I usually want a 'stable' image on my main router !!!

Either way, try snapshot from the Master branch or self-compile with sources from the stable branch.

Reading your earlier post you seem to have snapshot from Master already deployed though


As far as I understand igmp_snooping is not managed through DSA but the kernel.

Is the Wlan port slaved into br-lan?

So DSA offers better performance compared to swconfig? The thing is that vlans via DSA can't be configured in Luci at the moment and imho that's a big downgrade compared to swconfig.

@davidc502
If it's not too complicated please consider a revert back to swconfig, I think a lot of users of your builds would welcome this as well.

1 Like

It does, it offloads native switch tasks to the switch chip instead of bothering the CPU with it. Plus it adds native vlan filtering.


I understand that it is inconvenient for the user and the writing been on the wall for the past year, notwithstanding the confusion it apparently creates amongst users.


There is likely no point in reverting to something legacy which not been accepted into mainline kernel but its discussion led to DSA in the end. Probably better to get used to DSA and learn how to utilise the bridge command until UCI support is implemented.

2 Likes

Not to mention DSA is built-in to the Linux kernel and still uses Switchdev for some things. It's well discussed here including why they are moving to DSA along with a link to Linus' write up on it:

https://openwrt.org/docs/techref/hardware/switch

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/networking/dsa/configuration.rst

I'm not sure what the debate is. Perhaps we should just accept DSA as overdue for being enabled in OpenWrt and move forward.

2 Likes

The problem I have is as soon as a new build with DSA is pushed out to the server, and people start downloading and flashing, the posts will start flooding in because we just essentially soft bricked everyone's router.

The solution to solving this soft brick isn't going to be the same for everyone, from what I can tell.

For me, I edited the needed files from a configuration backup, and then flashed without saving configurations, and then restored.. This method failed over and over.

What worked was just to flash saving existing configurations, then going into the router via wifi, and editing those same files, and then rebooting.

I've been holding off of the newer upgrade. There is lots of discussion that sounds like things should be much "better" with the 5.x kernel and this new DSA. I'm waiting until there's a bit more help available - in terms of an upgrade guide as I don't want to break the router again - in the past I have seemingly locked myself out completely, but managed to get in via my phone and a vpn to reset things.
I'm a potential "soft bricker" (ugh!) so need to wait for a bit more stability. I hope a decent upgrade route can be found.
I am very grateful for the efforts you put in to this. Thank you.

2 Likes

If you are looking for a proper migration/conversion script from swconfig to DSA the chances seem slim https://github.com/openwrt/openwrt/pull/3074

A migration script is an unobtanium.If it wasn't, it would have materialised already; there certainly has been enough successfully attempted failures.

sorry but it's years that devs wait for someone to make a script that can port switch configuration to DSA, it is not going to happen.
We will have to put strong warnings in next OpenWrt release so people know they will need to deal with this, but there is really no point in stopping this in master.

1 Like

Wow, so there should be a clean flash requirement by the sound of it. Soft bricking is going to be a nightmare across all of OpenWrt if that's the case.

1 Like

Not sure why this would be an issue if people pay attention to the big red box that appears in the GUI if they are moving from an image prior to commit, to an image post that commit. Seems it should be self evident that user attention is required,.