Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

I'm running a clean 19.07.2, but am having all the problems I described above. Like my wireless turning itself off due to inactivity but no longer turning on once the clients come back looking for it (unless I reset the radio), and dnsmasq acting all nutty, refusing to give out IP addresses to my wireless clients.

Which is why I asked here to see if maybe I missed packages or settings. I figured maybe David does some tweaks or stuff to it that make these particular devices work better.

Can I downgrade via the upgrade option in Luci?


Not just because there isn't anything to downgrade to, but also because that would need a whole different set up command line options to opkg than the ones luci supplies.

You can downgrade, especially using sysupgrade command in force mode.
But DON'T keep settings in this case!

Ok, let's do it logical way.
I hope you already try to reset settings to default? Do it, if not.

Next, 5G wifi can go down by radar detection. Try channels 36 or 40.

And the last, but not least, it can happened if you have country code mismatch.
Issue a command:
cat /dev/mtdblock3 | grep cert_region
And check what country codes are supported by you router, then set one of them.

DNSmask issue is really strange, but... You can disable it completely, using odhcpd as dhcp server, and smartdns as a dns resolver. Or try to disable and stop odhcpd, it can interfere in some cases.

I started from default. I put the entire configuration in a uci script as a personal challenge. See if I could do it without luci.

I did see radar detected in the logs, but it auto-jumped to a nearby channel in response, and it stayed online as long as there were clients using the band. It wasn't until after the log reported it was turned off due to inactivity that it refused to come back online. But since I did change to a channel that had less interference on it, I will try to change it to someplace "busier".

As for the region/country, it reports EU. That means I can set it to any country within the EU, right? My previous experience is that OpenWRT won't even bring it online (even once) if the setting is incorrect. On an older router that was locked at US I had to hack the software package to set it to my country.

Hi all
im stil struggling with getting dnscrypt to work on r12833.....everytime i remove the checkbox from 'Use DNS servers advertised by peer' then internet connectivity fails. restore the checkbox and it is ok, but with resolution through my ISP which I obviously dont want.....
That has to mean that somewhere there is an issue in my config of dnscrypt.. could someone for whom this works kindly copy and paste the relevant lines from their /etc/config/dhcp, the toml file and any others?
There has to be something really silly my end that I cant see and it is doing my head in!

I tried a wifi toggle and got this:

Tue Apr 21 17:30:37 2020 daemon.notice hostapd: wlan0: INTERFACE-ENABLED
Tue Apr 21 17:30:37 2020 kern.info kernel: [135419.130109] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Tue Apr 21 17:30:37 2020 daemon.err hostapd: nl80211: Could not configure driver mode
Tue Apr 21 17:30:37 2020 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Tue Apr 21 17:30:37 2020 daemon.err hostapd: nl80211 driver initialization failed.
Tue Apr 21 17:30:37 2020 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Tue Apr 21 17:30:37 2020 daemon.notice hostapd: wlan0: AP-DISABLED
Tue Apr 21 17:30:37 2020 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Tue Apr 21 17:30:37 2020 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Tue Apr 21 17:30:37 2020 daemon.notice hostapd: wlan0: INTERFACE-DISABLED
Tue Apr 21 17:30:37 2020 daemon.notice netifd: radio0 (8808): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 4133 path ()
Tue Apr 21 17:30:37 2020 daemon.notice netifd: radio0 (8808): Device setup failed: HOSTAPD_START_FAILED

If I reboot the entire device it'll start...

I do think David changed some logging settings, I am seeing all kind of logging settings I didn't see before, like dnsmasq complaining about 150 concurrent DNS requests and openvpn throwing me a AEAD Decrypt error: bad packet which has something to do with MTU size according to the Internet.

i'm having the same issues
when i unchecked same option i have no internet connection everything is factory no setting saved

If you remove the option for Use DNS servers advertised by peer, and then none of the clients have DNS, then that means 1 of 2 things I can think of.

  1. DNS requests are not being proxied
  2. dnscrypts is not listening on the configured port.

For #1. You need to have requests sent to on the right port.
Screenshot from 2020-04-21 13-22-44

For #2. The dnscrypt-proxy.toml needs to be listening on the right port.
listen_addresses = ['']

I'm thinking you may have put in the router gateway IP address?

Hi DAvid

These two look correct, here are the forwarding in Network > DHCP and DNS

while the .toml file shows

## listen_addresses = ['', '[::1]:53']
listen_addressess ['']

I dont even see any stupid typos.....

Lets see if it is listening. Please run this command

netstat -an |grep 5300

if I run this i get no response, just back to the root prompt

my results beblow but unable to add dns forwardings address when i add it give me an error about expecting valid hostname

root@OpenWrt:~# netstat -an |grep 5300
tcp 0 0* LISTEN
udp 0 0*

Deleting post.

still nothing...

The work around is to add the line to the WAN section of the /etc/config/network file.

option dns ''


config interface 'wan'
	option ifname 'eth0'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'dhcp'
	option peerdns '0'
	option dns ''
	option ipv6 0
1 Like

Run this command please.

opkg list-installed dnscrypt-proxy2

looks good

dnscrypt-proxy2 - 2.0.39-1

This one too.

ps -ef |grep dnscrypt-proxy

I have the feeling the configuration file is in the wrong spot. Not by your doing :slight_smile: