Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

thanks man ill give it a try

Confirm, i meet it some releases ago.

Another possible fix is add Transmission start into startup script:

transmission-daemon -g <you_transmission_config_dir_path>

It works as well.

PS: Iperf shows about 3 time less throughput in 5G with latest firmware(s), so i rollback now.
PPS: Also it's a missed package - you have SmartDNS (nice thing, i use it), but don't have luci-app-smartdns (see Github of the autor, it have it).

1 Like

fyi ... on the issue with 5.4 and WRT3200acm ... it is now running I was able to install it and running on the alternate partition ... no issues ieee80211 nor mwlwifi (ootb openwrt)

Hi David - hope you're well and bearing up under lockdown. Ive just got round to trying again with dnscrypt - but no luck. Ive re-read some other posts on this and my config is as follows

in the .toml file

## listen_addresses = ['', '[::1]:53']
listen_addressess ['']

# server_names = ['scaleway-fr', 'google', 'yandex', 'cloudflare']
server_names ['cloudflare']

# Use servers implementing the DNS-over-HTTPS protocol
doh_servers = true

in /etc/config.network

config interface 'wan'
option dns ''

plus, in etc/config/dhcp

config dhcp 'lan'
list dhcp option '6,'


config dnsmasq
list server ''

when i uncheck the 'Use DNS servers advertised by peer, box, internet connectivity instantly fails. Restoring the check restores the service with DNS provided by by ISP........can you see what I'm doing wrong?

all the best

Hi :slight_smile:
Does anyone use drivers on Linksys WRT1200AC? Is it better with wifi stability? do you have any opinions?

Hope this is the right place to post this issue.

I'm using

OpenWrt SNAPSHOT r12833-02640f0147 / LuCI Master git-20.095.36093-af6fd6d on my WRT 1900ACS V2 and can not get the 5GHz network to come on

i've tried to go to older version and nothing works. if i go back to stock firmware no issues

What can i post to give you more info?

This is what i see

Take the Auto option for channel off and place it to either 36,40,44 or 48 it will work then.

Just tried all 4 of the channels, and still not working. none of my devices see that SSID


Can you post the output of

cat /etc/config/network
cat /etc/config/wireless

Please make sure you remove your SSID's and PSK keys etc or any sensitive data such as Username and passwords.

If you don't know ssh well simply make a config backup and then use something like 7zip and head to the /etc/config folder and edit the files network and wireless and paste here just make sure you remove the Sensitive data first.

I went and installed

openwrt-19.07 branch (git-20.057.55219-13dd17f)] OpenWrt 19.07.2 r10947-65030d81f3

that seemed to fix the issue. maybe just an issue with the version i had installed?

thanks for the help

Dear Dave ( and other here in the know ),
Hello and I hope that all here in the community are well and safe. I just have one simple question. I see much discussion here about the ongoing development of 5.4 Kernel Build for our devices. My query -
is there a working 5.4 Build available at this time or are the bugs still being worked out ?
Forgive my inability to discern the answer on my own; however - I have not seen a clear declaration of such a build or any download links. I am spurred on to ask about 5.4 because Dave and others I know have been collaborating and compiling test builds for the last few days. I am asking for the current progress and status of the 5.4 Build at the end of day. Thanks and I appreciate all relevant and pertinent information relating to my central question.
Peace Stay Safe and God Bless

Yes, since the beginning of March on wrtpac devices.

1 Like

Support for kernel 5.4 has been pushed to master a couple of days ago.


It says: mvebu: set kernel testing version to 5.4 ...

How do I change to kernel 5.4 or do i have to build the firmware myself

That is going to be a negative.

1 Like

Until it is defaulted to 5.4 in master you will have to build an image by making the change to Testing Kernel in menuconfig.

When you flashed did you use .bin or .img? and what did you flash from? From the readout above it looks like you have 1 radio, and part of another configuration. Did not all of the read out end up on 1 page?

I get an error on the Overview page in Luci: wrt1900ACv1. I think copied all the files to the right location... do i need to reboot maybe?

HTTP error 404 while loading class file "/luci-static/resources/baseclass.js?v=git-19.292.31773-cc35206"
at compileClass (
at async Promise.all (index 0)
at async Promise.all (index 1)

Yeb Luci doesn't allow creating instances, I was able to make a tun0 after David directed me to a guide. SSH worked fine.

Hi David, thanks for your guidance. I was able to fix it all by SSH because I was at a dead end when it came to creating an instance with Luci.

I have another question, is it possible to have my regular internet not the VPN running at the same time but through WiFi 2.4 only?