Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Not had any disconnect issues or lag spikes on my WRT32X on latest build as well. This is on both 5GHz and 2.4GHz wireless. Have you checked to make sure channel is not set to auto? If it is set the channel manually might help.

Had issues with not finding my network on Auto, but haven’t tried on this firmware. Does it work with 160mhz?

I haven't tested 160mhz as it requires channels that are in DFS which I can't touch due to my location.

I’m in Sweden, I read somewhere I’m not supposed to change the country code. I left mine as DE - Germany

There were only two major feature additions in the driver versions between 18.06.1 and 18.06.2. One, was the addition of beamforming, and the second, was uAPSD (power saving). Since beamforming only applies to 5GHz AC, uAPSD is the more likely candidate for these issues arising. However, there were also changes with how AMSDU/AMPDU (Block Ack) frames are established and destroyed - these may also cause some of the issues.

However, I only experience this same problem on my 1900ACSv2 when the signal-to-noise ratio gets really bad (i.e. neighbour's AP runs on channel Auto and ended up on the channel as my router during peak hours) or when I am on a different floor and on the opposite end of the house with respect to the router. Wireless operation is highly dependent on your environment. Try moving to a less congested channel on 2.4GHz or in the worst case, just add more APs in your household.

Driver roll-backs do not have a solid chance of fixing the issues. If mac80211 or hostapd gets updated, strange issues MAY arise as was stated in the issue thread you linked: https://github.com/kaloz/mwlwifi/issues/347#issuecomment-461872671 (he is a volunteer code reviewer for the Linux wireless stack). At least if you stick to 18.06.x it will still use mac802.11 from 4.14-rc1 and hostapd 2.6 and will make bugfixing the driver easier, if it is an issue caused by the driver.

For future reference to anyone interested, the networking stack for our devices look like this:

    Userspace (hostapd/other apps)
      mwlwifi (open source code)
  mwlwifi (proprietary firmware binary)
       hardware (88w8864/8964)

For my purposes at least, the driver works good enough. But it can be improved and should be improved. But the issue is that most of the processing happens in the firmware binary when it really should be done in the open source code or by mac80211/cfg80211 functions. Entire commands generated by mac80211/hostapd are parsed out by the open source part so that the black box binary works properly, adding overhead.

1 Like

Try setting it to France. Read the description in the link below.

1 Like

Hi Everyone.

I'm working on a Plex issue.. My Plex server sits behind my 1900AC router running the latest build from David.

Plex support said I need to "allow private domain 'plex.direct'" in the DNS rebind. I want to make sure I'm doing that right. Suggestions where to add that?


New images have just been uploaded to the server. No changes in the wifi driver, but we have had a few kernel bumps.

Kernel version = 4.14.120
WiFi driver =
Build = r10077

In this build we make atmeterial the primary LuCi.


Can't get 5Ghz too work with location set to FR, DE or SWE. Using 80MHZ.

Tried diffrent channels. Auto 36, 40, 44 and 48. WTF

"Wireless is not associated". This is on the latest firmware.

What is the output of the following command?

cat /etc/config/wireless

This probably isn't the thread for that but you can add this:

list rebind_domain 'plex.direct'

to the

config dnsmasq

section of your dhcp config file.

If you want to do it with a gui go to the DHCP page and add it here:

Domain whitelist

My issue is actually with 5Ghz not 2.4Ghz. I suppose I could try to change the channel. Everything worked well until I upgraded to those post 18.0.2 builds...

Is there a better way to try and diagnose what the issue might be?

Uff. Wave hello to FCC. You can change location now, but NOTHING changes actually.
Check dmesg/syslog about DFS, it's about this.

He shouldn't be having issue on channels 36, 40, 44, and 48. OpenWrt's Auto setting doesn't even work since it's not built in hostapd. Auto in OpenWrt does this: https://github.com/openwrt/luci/pull/2687#issuecomment-490864482

Maybe. But there isn't really a standard procedure for this. It'd be best to just do it via process of elimination. For now you can try and disable u-APSD powersaving. If it helps, then good. If it doesn't, then you can always change it back.

  1. SSH into your router and edit /lib/netifd/hostapd.sh
  2. Edit the line set_default uapsd 1 into set_default uapsd 0
  3. Reboot.

Just installed the latest build on a wrt1900ac v1. I'm getting something weird with the way fonts display in LUCI. They are all defaulting to a serif font for some reason. This messes up the interface pretty badly in a lot of places.

I've loaded the interface in Firefox, Safari, and Chrome and all do the same thing.

Any ideas on how to fix this?

My guess is the theme you are using is set to use your browser's default font settings. This was the case for me. Changing your browser default to a non-serif font such as Arial should do the trick. It did for me.

1 Like

Is the latest working ok for you on the wrt1900ac v1? Has the spontaneous rebooting problem been (once again) resolved?

We have been through at least 1 iteration of that problem, and was eventually solved. However, since that time, the problem has creeped back up for some users. Of course you are welcome to try the build and see if it works, and if it doesn't revert back.

My 2nd recommendation would be to move away from the V1.

It seems to be stable so far. No cyclical reboots. I'm using just using router functionality right now, no wx radios.

1 Like