Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Thanks but not my case, wifi instability happens on my build...

not sure based on your posts, are you running some custom firmware?
have you tried to run the standard firmware from openwrt, as that is what i always use.

just a guess, given that you have the same basic wifi problem with both ddwrt and openwrt, that there is something wrong with the router itself, perhaps that is why is was sold by the first owner?

as a test, to know for sure, i would install the linksys firmware and test.

Hi @asdffdsa! my WiFi issues are with apple devices (an iphone and a dell with apple wifi card [hackintosh]) The WiFi is usable, but sometimes it drops out and then I have to put the device in airplane mode in order to reconect, thats all...

There is really some weird issue with my WRT1200 with the WAN port, I just restarted my other cable router again and afterwards had only just around 25MB/s from my WRT1200 to the cable router. I restarted the WRT1200, again just 25MB/s. I shut it off waited 10 minutes then powered it on again and then had the normal 86Mb/s again. Anyone have an idea what might cause this?

Did this work?

Check the port speed/duplex - seems like it downgrade mode after reboot.
Use swconfig dev switch0 show command for it.
Negotiation issues are not to easy to solve, but you can try simple change the cable between modem and WRT - it can be 90% source of this issue.

On any given day I have at least 21 devices connected to my WIRELESS network... Another 4+ hard wired.... Who says the WRT1900acv1 isn't reliable..... Thanks DavidC!

2 Likes

Totally agree Brewder. My wrt320m is rock solid with David's build....

1 Like

Although constrained to stay on linux 5.4 due to limited space on kernel partition, both my 1900AC v1's are still doing their job. One of them has a 3G modem hooked up and is being used in an area where land internet connections are poor speed-wise and the other is being used as a all-in-one router, file server and torrent client. My other 2 3200ACM's are totally different beasts, running linux 5.9.10. As for wifi, reading all issues in different forums, I can say for my usage it's rock solid too across all devices.

nitroshift

Is it possible that you share with us how you compiled the 5.9.10 kernel?
(WRT32x owner)
Thanks

I will upload the patches on github the following days. Be aware, it's still work in progress. Also, it uses the mainstream DSA, not the old swconfig architecture.

nitroshift

2 Likes

Hi all,
I need some suggestions, if you will have any
I have a wrt1900acs with an old Davidc's build running on it, can't remember which one, and I'm not physically close to the router in these days.
From some time, i lost ssh access from my remote location. I used fwknop and PKI ssh login, both ain't working anymore.
Now i have someone who granted me access to the local network and i tried to connect to the router but unsuccessfully because lucy and ssh access are broken.
I don't think the alternate partition has a working firmware on it, but i would like to give it a try and i will instruct my friend on how to make the router switch partition using the Power Switch method.

If changing partition will not work, is there a way to force a factory reset?
The reset button on the router will reset it to default?

Thanks in advance and sorry for the long post

sorry guys, but I think it's time to blow some smoke up david's ass..

his build has been great since I've been using it, I wouldn't want to use another build.

David, thanks for all your work here.

3 Likes

See the device page wiki and recovery pages.

Hi Rural,
thanks for your reply.
Yes, i saw the wiki pages and there i found confirmation about the partition switch with the Power Switch method.
I wasn't sure if also on Davidc's releases the reset button was set to that function.

Thank you for the clarifications

hi,
i know this is basic stuff but did you reboot the router?

Hello asdffdsa :slight_smile:
Yes, was the 1th thing we tried
I think authorized_key file and some more are corrupted, it's not the 1th time it happens :frowning:
This is the Lucy error:

/usr/lib/lua/luci/ccache.lua:70: error loading module 'luci.controller.fwknopd' from file '/usr/lib/lua/luci/controller/fwknopd.lua':
	/usr/lib/lua/luci/controller/fwknopd.lua:2: unexpected symbol near '-'
stack traceback:
	[C]: in function 'loader'
	/usr/lib/lua/luci/ccache.lua:70: in function </usr/lib/lua/luci/ccache.lua:61>
	[C]: in function 'require'
	/usr/lib/lua/luci/dispatcher.lua:568: in function 'createindex'
	/usr/lib/lua/luci/dispatcher.lua:595: in function 'createtree'
	/usr/lib/lua/luci/dispatcher.lua:262: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>

I think my last chance is to reset to defaults with hardware button, then instruct my friend on how to login and setup the WAN interface with the DHCP parameters required by my ISP.
Once everything will be again up&running in a clean state, i'll tailor it remotely

The hardware reset needs to be done on a valid linksys firmware partition to work. Are you able to boot to both Linksys and OpenWrt partitions with the 3 power cycle procedure?

Regarding the “authorized_key” file corrupt error. Is that when trying to access OpenWrt via SSH?

Oooh, that's really a bad news. I don't remember if the alt partition holds a valid firmware.
Will try the power cycle procedure at first, so we'll check for the alt partition state. :cry:

Yes, the “authorized_key” file corrupt error is related to the OpenWrt access via SSH.
It no more accepts any of my keys, and only key access was allowed on sshd_config :frowning:

Not being physically there, adds lot of complications to the party...

Thanks for your suggestions guys, really appreciated.

EDIT: the router is configured with extroot. what if i simply make him unplug the extroot usb device?

See if your friend can ssh in locally using a wired connection.