Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

I did a quick search on the autotuning side of things for my own benefit, as I'd not heard about it before.
An app was noted in one of the searches "SG TCP Optimizer". Whilst I wouldn't normally want an app making changes, I saw this at least shows the PowerShell etc commands before it commits.
I'm only throwing this in as, to me at least, it shows a lot of options for configuring the stack which may be worth you looking at?

Obviously I already tried the TCP Optimizer, with no effect, sometimes even seems as it making it worse. Here is another gif showing the issue, this time a periodic up and down on Windows 10 client, where on Linux it is 100% stable 64MB/s:

Windows 10:


I wonder if this is a bug in Windows 10, which maybe wasnt there long ago, and no one noticed so far, or a bug in the OpenWRT image, maybe of the new kernel.

Hi all,
I'm just about to setup an OBI302 ATA with freephoneline on my OpenWRT router. According to this guide http://forum.fongo.com/viewtopic.php?f=15&t=18805#p73839, I have to check the UDP unreplied timeout and UDP assured timeout for values lower than 20 and 120 repectively. Does anyones know if I have to change any of theses settings and if so, where to set theses. What are the defaults values in Davidc OpenWRT, I see somes files in /proc/sys/net/netfilter but there all 0 byte
Thank you

I've found file 11-nf-conntrack.conf in /etc/sysctl.d with theses values that can be modified in /etc/sysctl.conf:

Any advice

Just a quick question. I am getting ready to upgrade from kernel 4.14.103 r9506 to 5.4.41 r13342 of David's builds. Any gotcha's I need to know about (1900ACS)?

(I was advised download a backup of my config, remove /etc/config/ubootenv and /etc/fw_env, repack. Upgrade w/o keeping config, then restore the modified backup.)

Anyone have anything? Thanks in advance.

Its normal this speed

im using sqm with this configs:

config queue 'eth1'
	option interface 'eth1.100'
	option debug_logging '0'
	option verbosity '5'
	option qdisc 'cake'
	option script 'piece_of_cake.qos'
	option linklayer 'none'
	option qdisc_advanced '1'
	option squash_dscp '1'
	option squash_ingress '1'
	option ingress_ecn 'ECN'
	option egress_ecn 'NOECN'
	option qdisc_really_really_advanced '1'
	option iqdisc_opts 'nat dual-dsthost mpu 64'
	option eqdisc_opts 'nat dual-srchost mpu 64'
	option enabled '1'
	option download '184000'
	option upload '85000'

Hi! I have installed OpenWRT 19.07.4 for my WRT3200ACM from official site and now I'm looking to have luci-theme-atmaterial but I can't find the IPK for Luci, I have Luci git-20.272.48698-9883bb3-1

Is there a wey to install the ipk?


Forget it, and sorry for my ignorance, I'm new to this OpenWRT world! found it here and installed with no issues

1 Like

Guys, only 85 people signed the petition in nineteen days. During this time, this most popular thread dedicated to WRTXX00, probably, was visited by more than one hundred owners of these devices. Why are we so passive, everything suits us!?
Let's be active!

With your permission can I post it to the DD-WRT Forum?

1 Like

@Oli has already posted a petition on dd-wrt


I am simply trying to restrict one device on my network from accessing the internet. I have done this many times before, but it doesn't seem to be working this time and I think it is best if I get another set of eyes.

The destination address field does not have 'any' as an option like it used to. I am wondering if this is the problem, and if so, what is the numeric equivalent.

Changing the source zone to the lan subnet of the device has zero effect. Tcpdump is showing activity, no matter what I do. but source zone should be LAN.


Hi nitroshift,

Thanks for getting back to me. Using lan has no effect. I used, and it did not work.
I created a guest wifi network for these smartplugs(currently testing the firewall rules on one) that is not bridged to lan, and used every single network I have as the source zone, including the guest network (APGuest). The device has a static ip address assigned on my lan, so I can rule out the address changing.

I also tried creating a rule for incoming traffic(2nd rule). Here is what the firewall config currently reads:

config rule
        option name 'smartplug'
        list proto 'all'
        list src_ip ''
        option dest 'wan'
        list dest_ip ''
        option target 'REJECT'
        option src 'APGuest'

config rule
        option name 'smartplug2'
        list proto 'all'
        option src 'wan'
        list src_ip ''
        list dest_ip ''
        option target 'REJECT'
        option dest 'APGuest'

Here is a tcpdump of the smartplug, continuing to defy me:

root@router:~# tcpdump -i wlan1-2 host
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on wlan1-2, link-type EN10MB (Ethernet), capture size 262144 bytes
09:09:19.884939 IP ec2-3-230-193-66.compute-1.amazonaws.com.443 > Smart-Plug.lan.50659: Flags [P.], seq 1753640462:1753640691, ack 20110, win 263, length 229
09:09:19.893538 IP Smart-Plug.lan.50659 > ec2-3-230-193-66.compute-1.amazonaws.com.443: Flags [P.], seq 1:86, ack 229, win 11833, length 85
09:09:19.967732 IP ec2-3-230-193-66.compute-1.amazonaws.com.443 > Smart-Plug.lan.50659: Flags [.], ack 86, win 263, length 0
09:09:19.972696 IP Smart-Plug.lan.50659 > ec2-3-230-193-66.compute-1.amazonaws.com.443: Flags [P.], seq 86:1003, ack 229, win 11833, length 917
09:09:19.997041 IP ec2-3-230-193-66.compute-1.amazonaws.com.443 > Smart-Plug.lan.50659: Flags [.], ack 1003, win 270, length 0
09:09:20.366432 IP ec2-3-230-193-66.compute-1.amazonaws.com.443 > Smart-Plug.lan.50659: Flags [P.], seq 229:522, ack 1003, win 270, length 293
09:09:20.385752 IP Smart-Plug.lan.50659 > ec2-3-230-193-66.compute-1.amazonaws.com.443: Flags [P.], seq 1003:1088, ack 522, win 11687, length 85

Is set as the static IP address for the device named smartplug? (Check under the Network > DHCO and DNS > Static Leases tab.) If not try adding that to the list and restarting the router.

Yes I assigned this device a static ip address previously. I had to reboot the router last night for an unrelated reason, and it worked blocking the device initially. I then disabled the rules, and re-enabled them, and the firewall rules were no longer working. It must be a bug of some kind.

Edit: Manually restarting the firewall service ('service firewall restart') is what gets things working again after enabling or disabling the firewall rules.

Thanks all.

1 Like

Lot of nice mvebu fixes going in lately (since the last davidc502 build I've had incredible success with over the last few months). Can't help but think if there is ever an official OpenWrt 20.x release it'll be a big upgrade.

For example, I'm wondering if this commit is why some people had wifi issues and others didn't:


Restarting the firewall daemon will do that for you... :wink:

i've just looked at the openwrt bug tracker, and it seems the dsa issues for mvebu have been removed, and most others have been designated as low or very low priority. does this mean the openwrt developers have essentially deprioritizedd this line, or are things actually working?
i have not had a stable lan/wifi configuration since dsa was moved into development snapshots for this series (wrt1900, wrt3200).
the superwrt builds incorporate a lot of packages on the new dsa snapshot builds, and would be great - but the dsa issues above persist for me.

thankfully, david's last build, and 19.07.4 still work.
i'm trying to get a handle on where openwrt devlopment for this line of routers has moved.

1 Like

Don't overestimate priority levels in flyspray, no one classifies bugs that way. DSA for netifd is staging, but pending merging to master, afaik initial DSA support is also being tested and just waiting for the former.

1 Like