Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Quick question by noob. How much space is left free in WRT1900ACS (shelby) after flashing latest (r13342)?

Many Thanks

Please no stupid remarks, won't get you anywhere in this forum. Good luck with finding your answers.


it is stated

1 Like

Nice. Coming back to the original question: Why no new updates anymore since 2 months? Is the DSA stuff broken since 2 months or what.

You will have ~ 7MB available in /.

1 Like

@RuralRoots - This is an unrelated issue.
@mfka8 - The problem is that DSA uses a different configuration concept which is incompatible to the one used so far. Newer builds using older configuration will have non-functioning ethernet and thus appear to be soft-bricked in some cases.

Verily, it is. It was meant to be flippant as in ‘you can’t build from the snapshot when they aren’t building atm’ when he clearly hadn’t looked in to the direction he had been given re. (DSA).

Shoulda just said:


Luci > 
System > 
Scheduled Tasks > 
[paste]30 3 * * * sleep 90 && touch /etc/banner && reboot[end-paste]
Save >

Problem solved.

My apologies.

Ah. Good to know that I do not need to wipe the router but use the .bin –file. Thank you.

1 Like

I have a WRT1900ACS and I'm running the davidc502 build from May. I notice my LG phone cannot hold a connection within the first 20 feet of the router. Everywhere else it seems to work fine. I'm using only the 2.4ghz. 5ghz is disabled. Has anyone else noticed a similar phenomenon that if they are very close to the router then equipment may not work? What could be the reasons for that?

Nope never had that issue with any wifi device including my iPhone. 50ish-day uptime on the kernel 5.4.42 build for me. I only use 5GHz now though and disabled 2.4GHz.

1 Like

config interface 'lan'
option ifname 'lan1 lan2 lan3 lan4'

It took me a while to find the missing secret sauce for the wrt1200ac:

option type 'bridge'

Hopefully this saves somebody else some time....

Check the phone and wireless settings - i have LG, works well even if charging 1.5m from router, both 2.4 and 5.

1 Like

Hey everyone - I've just updated to the most recent build after running a super stable build for over a year and a half. Lots of configuration changes, which were a pain to fix. Aside from the broken UPNP, my WiFi performance (over 5GHZ) is terrible. Check out the iperf3 output below from a my Macbook a few feet away from the router:

[  5] local port 63187 connected to port 22233
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  5.17 MBytes  43.3 Mbits/sec
[  5]   1.00-2.00   sec  9.44 MBytes  79.2 Mbits/sec
[  5]   2.00-3.00   sec  22.0 MBytes   184 Mbits/sec
[  5]   3.00-4.00   sec  12.6 MBytes   105 Mbits/sec
[  5]   4.00-5.01   sec  5.51 MBytes  46.1 Mbits/sec
[  5]   5.01-6.01   sec  2.43 MBytes  20.4 Mbits/sec
[  5]   6.01-7.00   sec   522 KBytes  4.30 Mbits/sec
[  5]   7.00-8.00   sec  1.93 MBytes  16.2 Mbits/sec
[  5]   8.00-9.00   sec  8.90 MBytes  74.7 Mbits/sec
[  5]   9.00-10.00  sec  7.35 MBytes  61.6 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec  75.8 MBytes  63.6 Mbits/sec                  sender
[  5]   0.00-10.07  sec  75.6 MBytes  63.0 Mbits/sec                  receiver

Any idea what could be going wrong here?

EDIT 1: So this was due to messed up wireless settings. I think it's better now.

There also seems to be some kind of a regression with recent Samba4 package included in latest firmware... My TM backups are taking forever. Over Ethernet, 48GB yesterday took 8 hours. :frowning:

Might have to roll back if I can't figure out what's wrong.

Don't think there is a regression in Samba4, I get nearly 100MB/s read-write on the latest build kernel 5.4.42, and have a 50-day up time too. No real issues for me at all.

Thanks. Do you mind sharing your smb.conf?

I don't have any special config, all I did was enable it in LuCI. My drive is even NTFS which is known to be slow, but just mounted it: "ntfs-3g /dev/sda1 /mnt/usb-ntfs -o rw,big_writes" which is recommended on the OpenWrt docs.

@phinn Are you using a build of david or your own one?

Ok so use case is completely different - I am talking about TM backups. They worked fine for me previously on Samba 4.8, now they're too slow.