Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

I'm considering just reverting DSA and building as normal. Will see how things go.

2 Likes

Sounds good. The thing is that I don't even know if DSA offers any notable advantage over swconfig. All I know is that swconfig always worked fine with mvebu...

Hi @davidc502, do you have an ETA on this change? The latest builds from May still do not seem to have this. Thanks!

I don't have an ETA. If I get a chance to work with it this weekend I should know more.

3 Likes

Awesome, thanks much and appreciate all your work on these builds!

You're probably aware but there has been a dev discussion on DSA for the past year over on this thread too:

Figured it out :beer: :smiley:

  • add interface 'vpn0' in /etc/config/network
  • config zone 'vpn' and forwarding rule 'vpn forwarding lan out' in /etc/config/firewall
  • Reboot - all good.

No leaks, dnscrypt-proxy and Adblock working through the tunnel.

@davidc502 This latest build has been very much to my liking. It’s been incredibly stable for me. Nice work! and Thanks.

2 Likes

I asked in the dnscrypt-proxy github about this and they told me "this is normal" of change of the "GO runtime" used in dnscrypt-proxy:

I cant imagine this is proper or "good" behavior. When will the kernel clear the memory again, isnt that really bad when maybe /tmp runs full? So theoretically if I fill up /tmp the memory should be take away again from the dnscrypt-proxy process? When will this happen, just when I get close to the 499MB?

Over the years this kind of stuff happens all the time. What I mean is there is a process, in a snapshot, that leaks memory, but the next snapshot things are fine. My suggestion would be to manage the problem until the next update and see if the problem still exists. Chances are the problem will magically go away over time.

I can only speak for an older build (12394) and dnscrypt-proxy2 version 2.0.39-1 but in my case I don't encounter these memory problems. Even after +3 weeks of Uptime there no problems or signs of increased memory usage with dnscrypt-proxy2. Maybe it's just a combination of the latest Snapshot and version 2.0.42-1 of dnscrypt-proxy2. Or maybe the latest release (2.0.44) will fix this problem...

This morning I had some time and decided to start fooling around with the DSA changes dealing with the switch.
I compiled a new image and just flashed witch soft bricked due to the DSA change. I have wifi on the mobo of my machine so I just got into the router with wifi, and edited the network config.

these are the two main areas where I made the changes from eth0 to wan and lan1, lan2, lan3, lan4

config interface 'lan'
	option type 'bridge'
	option igmp_snooping '1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option delegate '0'
	option _orig_ifname 'br-lan wlan0 wlan0-1 wlan1'
	option _orig_bridge 'true'
	option ipaddr 'X.X.X.X'
	option ifname 'lan1 lan2 lan3 lan4'

config interface 'wan'
	option ifname 'wan'
	option _orig_ifname 'wan'
	option _orig_bridge 'false'
	option proto 'dhcp'
	option peerdns '0'
	option dns '127.0.0.1#5300'
	option ipv6 '0'

However after a reboot I found nothing worked until I made lan1-lan4 a member of 'LAN'

So I have a feeling things are screwed up because I don't remember eth1-eth4 being a part of 'lan' before. I was thinking it was br-lan, but I don't see that as an option.

Also, I found that eth0 is still an interface when I run the command 'ifconfig', so eth0 is still referenced somewhere. when I search for eth0 as text in files on the router, it is referenced in a ton of spots -- sigh. I've cleaned some of it up, but it still isn't completely clean.

Looks like eth0 is still being referenced in /etc/

root@dc502wrt:~# grep -rnw '/etc/' -e 'eth0'
/etc/board.d/02_network:28:		ucidef_set_interfaces_lan_wan "eth0 eth1" "eth2"
/etc/board.d/02_network:31:		ucidef_set_interface_lan "eth0 eth1 eth2 eth3"
/etc/board.d/02_network:34:		# eth0 is standalone ethernet
/etc/board.d/02_network:37:		ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 lan5 lan6" "eth0 eth2"
/etc/board.d/02_network:40:		# eth0 is standalone ethernet
/etc/board.d/02_network:43:		ucidef_set_interfaces_lan_wan "eth1" "eth0 eth2"
/etc/board.d/02_network:46:		ucidef_set_interface_lan "eth0"
/etc/board.d/99-default_network:12:ucidef_set_interface_lan 'eth0'
/etc/dnscrypt-proxy2/blacklist.txt:30:eth0.me
1 Like

Is there no way to get swconfig back with kernel 5.4.x?

One could probably revert the commit. I haven't looked at that yet.

@davidc502
Actually that looks completely fine? Expect for the wireless interface maybe..

The eth0 references in the 02_network script are also fine.
Some devices still use ethX scheme.

Seeing eth0 in ifconfig is normal. eth0 is the DSA master port (cpu port)....

https://www.kernel.org/doc/Documentation/networking/dsa/dsa.txt

thanks for looking @shm0

I was looking in /etc/config and found snmp, and one other package config which I forget right now, that needed to be tuned. So, I decided to expand out to /etc/ and found those.

1 Like

Need help please im getting error in IFB with the latest build on wrt32x...

Tue Jun 30 04:37:40 2020 daemon.info modprobe: Usage: modprobe [-q] [-v] filename modprobe -a [-q] [-v] filename [filename...]

I tried fresh install and reloading the firmware but still get the same error...

Question about IGMP snooping and WIFI flooding?

So, I have a WRT32X (Venom) with the latest build and it mostly working great, but I recently bought a multicast HDMI encoder (and a decoder) which work pretty well but I only want the encoders multi-cast data to go over the LAN / Ethernet and not over wifi. I have enable igmp_snooping on my bridge interface:

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.31.1'
	option igmp_snooping '1'

But I can still listen in on the multi-cast on my laptop over wifi eg. I can using VLC to watch the video via udp://239.255.42.42:5004

So it appears that the igmp_snooping feature is not working?? Is there something else I need to configure? The system details are as follows:

Hostname	ROUTER
Model	Linksys WRT32X
Architecture	ARMv7 Processor rev 1 (v7l)
Firmware Version	OpenWrt SNAPSHOT r13342-e35e40ad82 / LuCI Master git-20.144.63033-62ed4e6
Kernel Version	5.4.42

Basically I don't want to flood my wifi with these packets but given I can watch the multi-cast video on my laptop I imagine it not filtering out these packages on the bridge.

Hi,

im setting up my WRT3200ACM as a repeater, although i added a "master" to have a different SSID since my phone doesnt make the difference which BSSID is connected to, result is i have a slow connection.

I followed multiple tutorial about this, it's working great with LAN connection but impossible to have the other SSID (openWRT) running, highlighted on the screenshot below.
I set up the master to Lan while the client is wwan

thanky ou for helping

it is running; it wont have a signal strength unless something is connected to it.
If it doesnt work try deleting both then doing a scan and join as a client then add the ap again.
Also you need relayd to get an ip from the main router