Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Yes, i do. It's add a couple of free space, but some orphans are still present.
The same packages set only have about 25M footprint at 4.x (i can check exactly).
I see Samba is quite fat now (about 15Mb instead of 7), but can't find other lost space yet.

I'll investigate further, and let you know if i find the reason of this.

Edit:

 OpenWrt SNAPSHOT, r12833-02640f0147
 -----------------------------------------------------
root@ttrollstation:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                20.0M     20.0M         0 100% /rom
tmpfs                   249.5M      2.6M    246.9M   1% /tmp
/dev/ubi0_1              41.2M      5.3M     33.8M  14% /overlay
overlayfs:/overlay       41.2M      5.3M     33.8M  14% /
ubi1:syscfg              70.2M    396.0K     66.2M   1% /tmp/syscfg
tmpfs                   512.0K         0    512.0K   0% /dev

I mention /overlay in 5.x have another full copy of /rom, it explains 20M. 10M is still unexplained.

I set it for US now and let it to auto and tried originally DE before.

thnx

David,

I have observed this on LAN port cable cat 5e… Not sure about radio as this is just for silly things on mobile…

M.

Any best practice on how to migrate swconfig/switch settings to DSA?

I have bricket my WRT1200 several times now by keeping the config and updating. Unbricked now and reverted to an older release I am interested to know how to get the switch/ vlans setup on DSA now :slight_smile:

Any hints are highly appreciated.
Thank you

Read back in this thread a day or more for a number of methods people have utilised, or the search function seems to be functional as well.

First go to interfaces -->lan-->Physical Settings, uncheck lan1.


Then create the new wan or lan using lan1

You can try to adopt your config /etc/config/network:

...
config interface 'lan'
option type 'bridge'
option ifname 'lan2 lan3 lan4'
...
config interface 'wan'
option ifname 'wan'
option type 'bridge'
option proto 'dhcp'
...

config interface 'anyname'
option type 'bridge'
option ifname 'lan1'

No further ethx (CPU) configuration needed, delete all switch configs in /etc/config/network and keep in mind "switch" will not appear under luci any longer.

Addl. you may have to switch on vlan filtering on start up (rc.local):
ip link set dev br-lan type bridge vlan_filtering 1
ip link set dev br-anyname type bridge vlan_filtering 1
ip link set dev br-wan type bridge vlan_filtering 1

Disclaimer:
I am not a guru and no garantee for a working environment :slight_smile:

Try setting

ip link set br-Media type bridge vlan_default_pvid 10
ip link set br-DMZ type bridge vlan_default_pvid 20

This should fix those to bridges by making sure both the bridge interface and any wireless ports are matching the lan1 tag, assuming you are on a version with commit dc4ffaa5ab68 ("generic: fix DSA VLAN filtering")

Not sure about the lan1.1 problem since 1 will be the default pvid. But maybe the problem is that it is the pvid for lan1? Try making it explicitly tagged

bridge vlan add vid 1 dev lan1

Or maybe it's necessary to sed some other vid as pvid on lan1 to make this work? You could try

bridge vlan add vid 42 dev lan1 pvid untagged

and then re-add a tagged vid 1 as above.

This may solve the issue depending... Just be aware that there are DFS channels, and if radar is detected the router will shut down wifi temporarily until another channel is found. During this process wifi may not come back up for several minutes.

The following is a wiki page of wifi channels including which ones are DFS.

Thanks @bmork, you made my day:

  • ip link set br-Media type bridge vlan_default_pvid 10
  • ip link set br-DMZ type bridge vlan_default_pvid 20

were the missing parts of the puzzle.... switch up and DSA running.

Nevertheless, "bridge vlan add vid 1 dev lan1" failed, since the port has simply been not available ("RTNETLINK answers: Not supported").

@all,
I am currently running r13520-dd2daf08 on my wrt3200acm and stability of wifi is still simply a catastrophy.

Does anyone know why it's so complicated to use Samba on OpenWrt? On my WRT32X thanks to @solidus1983 I was able read fast and reliable on my USB 3.0 drive (80-100MB/s), but it keeps saying 'write protected' on writes. With the stock firmware you click 1 button and everything works and on this there are 2 pages in "Network Shares" and "Mount Points" and I still cannot write to the drive. It won't even unmount with you click unmount, you gotta use SSH.

EDITS: the work-around for writing with some help from @solidus1983 and updating these docs https://openwrt.org/docs/guide-user/storage/writable_ntfs

[wrt32x]
path = /mnt/sda1
force user = root
force group = root
create mask = 0666
directory mask = 0777
read only = no
guest ok = yes
inherent owner = yes

And then remounting with ntfs-3g as follows:

    umount /mnt/sda1
    ntfs-3g /dev/sda1 /mnt/sda1 -rw

Unfortunately performance is slower, getting 35-45 MB/s. The stock Linksys firmware was writing at 70-80 MB/s which uses kernel 4.4.14 so not sure how this is slower. Going to try adding 'big_writes' and 'noatime' options as per the tuxera faq and see if it improves.

Pm me a screen shot of the samba GUI. Might be able to help.

Can you please PM me how to get on your build? Checked many days irc but didn't see your ID.

I was offline for a few days, back today.

nitroshift

Ok, i got the reason why overlay getting out of free space. Well... Years passed, some things never changes.

Being short, you should not update from 4.x to 5.x both keeping you config and even restore settings from backup.

The source of this not a difference in network config or so, but - again - it's a BAD idea to keep/store HARDWARE configuration files. This time it was /etc/config/ubootenv - it's different for 4.x and 5.x

So, i recommend make a backup before update, then NOT use restore function, but unpack it and copy files to router - except /etc/config/ubootenv and /etc/fw_env.config.

I'll post to Openwrt bug tracker about it.

3 Likes

I just installed 2020-05-24 on a WRT1900ACS. I think there should be a way to manage dnscrypt in LuCI if it is enabled by default or at least something in the release notes about how to disable it. How can I do that? The dnscrypt page says it's now part of the build so instructions are no longer needed, and I can't find anything about it in the FAQ. I also searched this thread but it's so big I only get results from 2018. I'm not sure I want some random provider (seems to be chosen based on latency) having all my DNS queries I'd rather just continue using my ISP.

Hi,

I have problems in running DHCPv6 server, but process odhcpd is running:

root@linksys0:~# cat /etc/services | grep dhcp
dhcpv6-client	546/tcp
dhcpv6-client	546/udp
dhcpv6-server	547/tcp
dhcpv6-server	547/udp
root@linksys0:~# netstat -an | grep 547
root@linksys0:~# 
root@linksys0:~# ps -ef | grep odhcp
root     19547     1  0 10:14 ?        00:00:00 /usr/sbin/odhcpd
root     23978 21576  0 11:39 pts/0    00:00:00 grep odhcp
root@linksys0:~# 

In /etc/config/dhcp config file I have (relevant parts):

...
config dhcp 'lan1'
	option interface 'lan1'
	option ignore '0'
	option start '100'
	option limit '254'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config dhcp 'wan6'
	option dhcpv6 'relay'
	option ra 'relay'
	option ndp 'relay'
	option master '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '7'
...

I am running the latest Davidc502 build:

root@linksys0:~# cat /etc/openwrt_release 
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='SNAPSHOT'
DISTRIB_REVISION='r13342-e35e40ad82'
DISTRIB_TARGET='mvebu/cortexa9'
DISTRIB_ARCH='arm_cortex-a9_vfpv3-d16'
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r13342-e35e40ad82'
DISTRIB_TAINTS='busybox'
root@linksys0:~# 

Do you have some similar experiences, or maybe I am missing something in the configuration?
Best regards

  1. Possible bug on Status > Overview page. Total memory is showing 50% available and Used memory is showing 94% used. Shouldn't these two be reversed, how can I be using more than my total avail?

  2. Looks like Advanced Reboot was never fixed on WRT32X, it still says unknown for the Linksys firmware, not on you, but just noticed.

  3. Finally, anyone know if I can just delete WAN6 under Network > Interfaces to get rid of ipv6?

Thanks again for your builds, on the latest with kernel 5.4.42, it's running amazing. Maxing out my 200Mbit cable with A+ bufferbloat & quality ratings using SQM, software offloading enabled, USB 3.0 Network Share running awesome, Adblock works perfect minus youtube ofc, 5Ghz wifi is stable and fast, everything is in a good place right now.

2 Likes

Mine says 78/28 available/used so yeah it's not exact.

Unfortunately it's not that easy to get rid of IPv6. I would be interested in doing this as well, but so far everything I've tried has failed to completely get rid of it.

Network > Interfaces > LAN > DHCP > IPv6 > Disable everything
Network > Interfaces > LAN > Advanced > Uncheck 'Use IPv6-management'
Network > Interfaces > WAN > Advanced > Uncheck 'Use IPv6-management'
Network > Interfaces > WAN6 > Delete

I set all the 'disable_ipv6' settings that I could find using sysctl -a | grep disable_ipv6 (will differ depending on router)

cat << 'EOF' >> /etc/sysctl.conf
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.bond0.disable_ipv6 = 1
net.ipv6.conf.br-lan.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.eth0.disable_ipv6 = 1
net.ipv6.conf.eth0/1.disable_ipv6 = 1
net.ipv6.conf.eth1.disable_ipv6 = 1
net.ipv6.conf.eth1/2.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.sit0.disable_ipv6 = 1
net.ipv6.conf.teql0.disable_ipv6 = 1
net.ipv6.conf.wlan0.disable_ipv6 = 1
net.ipv6.conf.wlan1.disable_ipv6 = 1
EOF
cat /etc/sysctl.conf

I rebooted and monitored the IPv6 packets being sent by the router on boot and there's still multicast listener and router solicitation. Also I noticed a few settings don't remain IPv6 disabled.

# sysctl -a 2>/dev/null | grep disable_ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.bond0.disable_ipv6 = 1
net.ipv6.conf.br-lan.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.eth0.disable_ipv6 = 0
net.ipv6.conf.eth0/1.disable_ipv6 = 1
net.ipv6.conf.eth1.disable_ipv6 = 0
net.ipv6.conf.eth1/2.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 0
net.ipv6.conf.sit0.disable_ipv6 = 1
net.ipv6.conf.teql0.disable_ipv6 = 1
net.ipv6.conf.wlan0.disable_ipv6 = 1
net.ipv6.conf.wlan1.disable_ipv6 = 1
1 Like

@phinn & @newshoes

Completely getting rid of IPv6 cand be achieved at build level only.

nitroshift

1 Like