Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

I just updated to snapshot r13059-9fac9168c6 (posted April 25) and I'm getting a ton of the following messages in the logs:

Sun May 3 15:03:47 2020 daemon.err avahi-daemon[3686]: avahi_normalize_name() failed.
Sun May 3 15:03:47 2020 daemon.err avahi-daemon[3686]: avahi_key_new() failed.

I stopped the avahi daemon and the messages went away (obviously) but any idea what would cause this? I was running r11962 previously and had none of the errors.

Do I need avahi-daemon for my airplay / airprint to work properly? I have multiple access points (all OpenWrt) and multiple network switches in my environment.

Hi Ras,

You can do this using VPN-Policy based routing. It should be as simple as entering the device IP in the GUI and selecting the relevant VPN interface.

I have two tunnels running myself. You shouldn't need to create a separate Vlan for your PS4.

1 Like

Thanks for the reply David!

But I think I didnt asked properly, I mean, how can I download sfq,pie,codel queues from your build to use them in other clean openwrt? or what package did you used to implement them in sqm? When I Install SQM in clean Openwrt build I just get fq_codel and cake.

Thanks in advance!

Onfortunately, 5G is quite unstable with a short reach on the latest build. Used to work perfectly fine in the previous build.... It's a WRT3200acm running openVPN and VPNbypass.

radio0: ?Mbit/s and -101dBm is probably the reason.

Just installed latest sysupgrade for the WRT1200 but now I cant install any of my custom packages anymore, it says "incompatible with the architectures configured". What did you change? the architecture obviously didnt change, it was arm_cortex-a9_vfpv3 before.

root@wrtarm:/tmp# opkg install netstat-nat_1.4.10-1_arm_cortex-a9_vfpv3.ipk
Unknown package 'netstat-nat'.
Collected errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for netstat-nat found, but incompatible with the architectures configured
  • opkg_install_cmd: Cannot install package netstat-nat.

It seems you've switched to " arm_cortex-a9_vfpv3-d16" ... why? This is really bad news, and no word of this major change on your site. My custom packages are now broken, and I cant get a new compile anymore for this architecture so easily...

Do they just renamed it to arm_cortex-a9_vfpv3-d16? Is there still a arm_cortex-a9_vfpv3? Love when a change for no reason breaks EVERYTHING.

Opkg update failed on snapshot (arm_cortex-a9_vfpv3-d16) "The only actual change is that with -d16 the compiled code has been restricted to use less CPU registers (due to the smallest CPU in the series, Armada 370), so users with the more powerful CPUs should be just fine with those -d16 packages."

Lowest CPU we have with our WRT is the 385, so this change makes no sense for our models.

Does this make even any sense for us? Cant you compile with old arm_cortex-a9_vfpv3 or did they remove it?

It worked before, but is now broken with this or one of the last upgrades. Please compile netstat-nat and polipo into your package portfolio, I need them.

Also the Adblock package seems to be change/broken. What was changed there? Did you change it from the old ablock to a new one? The Luci adblock is broken now, and nothing works with this adblock. No adblock file anymore under /tmp.

Tue May 5 00:59:55 2020 user.err adblock-4.0.4[5959]: unrecoverable adblock config error, please re-install the package via opkg with the '--force-reinstall --force-maintainer' options

See thread and FS#2997

1 Like

So whats the status on this. Will david revert/change back to arm_cortex-a9_vfpv3 instead of arm_cortex-a9_vfpv3-d16? Or did the stubborn OpenWRT devs remove arm_cortex-a9_vfpv3? Awesome change as usual, totally like I know the OpenWRT devs.

I kinda fixed Adblock I think, had to reinstall it, the dev of the addon totally changed everything how it worked in the past...... This is also totally a stupid change, the default config also doesnt work at all it seems. It puts a option confdir '/tmp/dnsmasq.d' into /etc/dhcp but doesnt remove the old option serversfile '/tmp/adb_list.overall'. I am also nur sure if the file under /tmp/dnsmasq.d is even loaded by dnsmasq.

Thanks mate, maybe I'll try again and if it doesn't work I'll post in the policy thread.
Currently I'm able to use vpnbypass but only able to use 1tun. How did you assign which tun goes to which .ovpn? When I use policy, I have the option for wan/wan6/VPN only I don't see the 2nd tun. So I doubt I'm seeing it up correctly.


In my setup, I have two interfaces called ovpnc0 and ovpnc1 with devif also set the same.

It's not recommended to use tun0 etc cos they are not reliably assigned within openwrt.

In the .ovpn set Dev ovpnc0 and ovpnc1 respectively. Then start both interfaces.

You also need to add both interfaces in the VPN policy based routing config.

There is also some firewall configuration, but at the moment I am not at my router and writing this from the top of my head.

1 Like

Gremlin, you're awesome. I will give it a try later today. Thanks so much! If you get a chance please share your firewall settings if possible with the GUI as I have no hope with SSH.

Thanks in advance

It's possible to add/change architecture.
First, you need to add it into opkg,conf, read it here.
Second, MAYBE you need another ld-file link into /lib, or even link it to another libc.so - try it.

I even make BOTH soft-fp and hard-fp support working tougether for one of my projects (OpenWRT have HardFP, but some legacy libs only support SoftFP).

Your more than welcome, here is the firewall zone that covers my VPN interfaces. I forgot that I renamed them but should work the same regardless.

In the VPN Policy based routing instructions it does imply that you should have a separate zone for each VPN interface but I have had this setup like this for a while now with no issues.


1 Like

Is there a place where I can download previous firmware releases?


Bottom of the home page


Forgot the top part!

1 Like

I have been visiting this page for a few years now. How did I not notice this link? :rofl:

Thank you

New update for Marvell router wrt1900acs v2 !
Firmware version:
Release date: May 1, 2020

  • Added support for the Marvell A385 Rev. B0 chip
  • General bug fixes

I'm with a WRT3200ACM, and the 04/26 build makes the wifi unusable: some phantom thing clogs up the traffic. If I connect to the router through it's LAN ports the speedtest is fine. I removed all wifi clients (quite a few). Everything was off and the wifi showed 60-100 Mbit traffic (Graphs -> Wireless -> ...). Does anyone experience the same? The router's CPU utilization didn't go over 3-5% though. I cannot understand this. I'll try to revert back to the earlier firmware.

1 Like

Do you have a link?

Being a little more specific: by 04/26 build I meant r13059. Now I reverted back to r12833, and the wifi speed is usable, but something is not quite right: it's still heavily bogged down. I stopped now smbd (this is a pure wifi router, no shares) and also ddns (also don't use it). I also discovered that adblock was errorring, and I force reinstalled it, that wiped the config file and now it's OK. Now a little more detail about this "bog down situation".

  1. If I hook straight to a LAN port of the router the Ookla speedtest shows 110Mbps, which is actually little more than the 100Mbps my plan supposed to provide. Last night with r13059 the speedtest through wifi was only 2-5 Mbps, which means basically unusable. Now with r12833 it's up to 50 Mbps, but then where does the extra 50-60 Mbps go?
  2. Well, I'll show real-time graph and statistics graphs of wlan0 and wlan1. These graphs show constant ~25Mbps traffic. Not consistent completely between the aggregated statistics graphs vs the real-time graphs, but they show massive (25 Mbps constant traffic is I'd call massive, especially when I don't have any device which would account for that). The CPU utilization is not high, the system load is low, and although you can see some spikes but those are me mucking around.
  3. I know what you think: why don't we actually peek into that traffic and see what is that? I couldn't resist to do that. tcpdump -i wlan0 -l -U -s0 -n -q -c 500 or tcpdump -i wlan1 -l -U -s0 -n -q -c 500 should have filled the dump file in a blink of an eye if there's 25Mbps traffic. However, the dump lasted several seconds, and it showed completely boring stuff, nothing what I expected that 1.5K packets hauled around. So I'm absolutely dumbfounded. WTF is going on?

Real-time graphs:

Statistic graphs: