Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Same as @davidc502 , I checked mine as well and it was a dead-end.

I've tried fully resetting firmware to default and nothing is working. I know enough to get by but not enough to figure this thing out....

Support for kernel 5.4 is in the works so we'll see further improvements, including mvneta and DSA.

1 Like

I did some offloading testing on Shelby v2 and results are quite positive. While dl 5GB iso image on full speed of my connection (200 Mb/s) processor usage is significantly lower with offloading on.

Processor usage:

Connection speed:

Although yesterday with offloading on, I saw some odd short spikes in usage and at the same time my connection speed was dropping to 0. I cannot reproduce it now and I can't rule out that my ISP had temp issues and queued packets were chocking processor then. I'll be observing system and processor loads for next few days and report back if I can reproduce any unusual symptoms.

Since last build..transmission stopped working. No changes on my configuration files.
It starts..but, then, stops after few seconds.

Tue Mar 3 11:46:04 2020 user.notice transmission: Starting with 255464000 virt mem
Tue Mar 3 11:46:29 2020 daemon.info procd: Instance transmission::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

Hi @davidc502, quick request (and request for comments from other thread dwellers):

I get frustrated at the lack of command history between logins with busybox on openwrt. Would you consider changing the compile flags for busybox as per this post to retain command history for your builds?


Samba 4.12 is also out today and has a interesting new VFS module, that might help on heavy threaded workloads. Should not matter for bulk transfers from what i understand.

'io_uring' vfs module

The module makes use of the new io_uring infrastructure
(intruduced in Linux 5.1), see https://lwn.net/Articles/776703/

Currently this implements SMB_VFS_{PREAD,PWRITE,FSYNC}_SEND/RECV
and avoids the overhead of the userspace threadpool in the default
vfs backend. See also vfs_io_uring(8).

So keep this new module io_uring in mind if i update to 4.12 and we have kernel 5.1 support.


Did anyone noticed some negative effects when using software flow offloading in combination with SQM?

I have kept SQM activated after update and additionally enabled offloading on my WRT1900ACS.

At least not seen anything breaking so far.

But also cannot really prove that SQM is still working as before. I'm mainly using it to throttle down my guest Wifi but didn't have many "leeching guests" since the update ...

1 Like

Using offloading and SQM cake without any issues. Still getting A+ grades across the board with it on and B's with SQM off.


My WRT32X with the stock Linksys firmware (which hasn't been updated in 2 years thanks to that garbage company) maxed out my 200Mbit cable modem at full A+ ratings for bufferbloat, etc. on www.dslreports.com/speedtest. I can confirm that with these newer OpenWrt builds enabling SQM and using software offloading finally gets similar A+ results most of the time.

Samba is also working well, using my external 3TB 5400rpm USB 3.0 drive I get in the 85 MB/s range. I reset settings not sure what was happening when I spoke on it being slow before. Transfers are so fast and Kodi works perfectly on my Shield TV for example.

RE: using SQM with flowoffload

Are you saying that there is a mvebu 5.4 WIP out there in the wilds that can be grabbed? If so, can you link the git.

WIP. Patches were sent to devs, pending checks.

1 Like

Then why does my CPU usage go down with software offload when SQM is enabled? Is it disabling SQM behind the scenes?

Are you using QoS with the stock firmware? Otherwise it sounds like that your cable modem is doing some sort of QoS/Prioritization or your ISP behind the scenes...

I'm going to give SQM+Software Flow Offloading a try and I'll report if I encounter any issues. SQM is kinda CPU intensive so it would be quite nice to save a little bit CPU usage while SQM is active. ~15% does sound pretty good imho!

Absolutely no issue. Will be more than happy to make this change :).



It's not my cable modem, I use a pretty common SB6183. For years I used an R7000 router and it never got over B+ bufferbloat with the same modem and same internet. I got the WRT32X (off Amazon renewed for $100) 1-2 years ago and it's been A+ Bufferbloat and Quality ratings with the Linksys OEM firmware. Their firmware hasn't been updated in 2 years but it's still decent and based off of OpenWrt anyway. Now also getting more than my rated ISP speed and A+ on OpenWrt with SQM and software offloading enabled. Can't speak to what is happening behind the scenes other than that. A+/A+ should be expected these days though with these routers.

Just updated to davidc502 from 19.07.1 on wrt32x runs flawless.. as a AP wifi is working well with offloading + sqm thnks for all your hard work. 19.07.1 is not that far back One thing I did like is all of your basic pkgs are right out of the box . I went to facory. then I restored a backup of 19.07.1 work like a charm.

1 Like

Just noticed yesterday that my VOIP handset was no longer registering with Sipgate. It's a Siemens N510 Pro and was showing "registration failed" in the web UI for the basestation. This behaviour has only manifested since recently updating my WRT32X to build r12235. Previously i had been on r10307 since June last year, so a big jump, I know...

I did a little tcpdump'ing (VOIP telephony is my day job, lucky me!) and saw REGISTER requests going out but nothing coming back in. Previously I had no port forwards for this device configured and everything worked fine. I set up SIP and RTP port forwards to my basestation as per the Sipgate FAQs and everything is working fine again now.

So, no help required or problem, just posting this in case anyone else runs into a similar issue as something has obviously changed.

EDIT Spoiler: it was Software Flow Offloading. I've now disabled it and the VOIP service is registering without and SIP port forwards.

1 Like