Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

are these PR's place in /package/kernel/mwlwifi/patches/ folder or a direct patch run?

Only asking as i am just changing my scripting for copying patches about.

For PR2756 you can just grab and apply as a patch via patch or git apply. One way to try the proposed PR381, after applying the PR2756 patch, replace the contents of the 001-Fix-compile-with-mac80211-backports-5_3+.patch with the patch from PR381; i.e. you still need the change to the Makefile.

So I need both patches and I just simply patch run it for both. Thanks good timing!

Not really, You do not need both. Just using PR2756 will get the job done, and is the way I am currently running.

PR381 is maybe where it will end up, assuming kaloz pushes the PR upstream. More manual, there is also a comment in PR381 (with patch) which gives another method; you will have to add the actual patch from the PR of course.

right might be doing this wrong here so i used wget to download both patches directly in the root of my openwrt git folder (v19.07) and it failed to patch when i ran patch -p 1 -i <filename.patch> as for the 0001- 001-Fix-compile-with-mac80211-backports-5_3+.patch i don't have that file in /package/kernel/mwlwifi/patches/ folder, just done a fresh clone on git.

edit: sorry for being slow on this.

ha, should not have taken out the master only comment from my last post. I assume this works, but as stated there, I don't build that. On stable I would be inclined to just doing a link.

I am compiling v19.07 snapshot from scratch hence why i was asking. I take its only for master right now ?

Also i a using neon-vfvp3 too during compile.

@cdg I've had success getting IoT devices to connect using this solution: https://github.com/kaloz/mwlwifi/issues/278#issuecomment-502663238. You can set up 2 SSIDs on the same radio, with one of the SSIDs having WMM disabled - I have "SSID" and "SSID-IoT" both on Radio1 (phy#1). It has been working great so far.

The author of that solution has since come out with a new method, where you can use phy#2 for IoT and have phy#0 operating at 160MHz: https://github.com/kaloz/mwlwifi/issues/280#issuecomment-580008509. This would definitely be worth checking out, but I haven't tested it yet.

3 Likes

phy 2 isnt stable on the wrt32x
It will randomly die and webgui shows device not active

This is an interesting work-around for IoT support, the concern I had was the mwlwifi developer said not to disable WMM although not sure his reasoning (performance drop on 802.11ac? not sure). Performance aside, it's definitely a work-around. Hopefully it still works using the new WRT3200ACM / WRT32X firmware.

It would be nice if Linksys updated their WRT32X OEM firmware too so I could test it, this useless company only updated the WRT3200ACM.

By the way, Linksys released the GPL source code to their new WRT3200ACM update 1.0.8.198828 that contains the new wifi firmware there is so much talk about:

https://www.linksys.com/us/support-article?articleNum=114663

I'm no expert, so not sure if it could help OpenWrt development, but it's the first time they posted new source code in over 2 years.

It never contains anything useful, as the driver is still closed source.

So it looks like flow offload is built into the latest builds of OpenWrt but I don't see the options in David's builds. Is there a reason for this? My ISP just upped my speed to gigabit and my 1900ACv2 is having a hard time keeping up. When I run a speedtest I'm hitting around 700 peak and in htop I can see both CPU at 100%.

Hoping flow offload might be able to help with that.

Is there any way to add the required packages if we aren't going to see them in the core builds? I'm ok to add them on my own for testing (if needed).

Thanks again for a great firmware!

Yes, the flow offloading option is selected and is built in. From what I understand the 32x/3200acm, and maybe the 1900acs are capable of near gigabit speeds. However, I'm not sure that the V2 is even with flow offloading.
As for options, I haven't looked at this in a long time, but don't recall that there is any except to turn it on/off in the configuration prior to being built. If you find any other information I'll be happy to follow up to verify it is indeed turned on.

Looking at the following article

noresolv=1
localuse=1
list server....

These parameters are not present in /etc/config/dhcp in DavidC's build. Wondering if this intentional or not.

When went through the same article and configured dnsmasq - everything is working fine like ISP's DNS servers are not used but dnssec resolver test is failing.
http://dnssec.vs.uni-due.de/

Any one has any suggestions for the above(missing parameters & dnssec resolver test).

Thanks

The resolver check works for me on the newest build wrt32x. Have you tried doing a completely fresh install? That fixed quite a few issues I had.

The default build - dnsleak test is failing (resolving to ISPs DNS servers). To fix this followed the above link - which fixed dnsleak test but resulted in dnssec resolver test failure.

in summary - wanted to fix the dns leak issue as well as pass dnssec resolver test issue and wondering if any one has suggestions how to go about this.

edit - Was making a silly mistake of using a different config file for dnscrypt rather than using the default one(/etc/dnscrypt-proxy2/dnscrypt-proxy.toml).

However at present - dnsleaktest is showing it's using the ISPs DNS servers. Trying to figure out how to mask them.

dnsleaktest issue is fixed by adding these lines to dnsmasq section in dhcp file (from the note) - but this brought back dnssec resolver test. Can this dnssec resolver test be ignored?

    ...
    # Ignore ISP's DNS:
    option noresolv '1'
    # Change /etc/resolv.conf to direct local router processes to use local dnsmasq:
    option localuse '1'
    # Don't forward RFC 1918 private addresses and RFC 6761 top level domains
    option boguspriv '1'
    # Also don't forward these local zones to the upstream resolver:
    # The local domain (e.g. /lan/) is already automatically added
    list server '/internal/'
    list server '/intranet/'
    list server '/private/'
    list server '/workgroup/'
    list server '/10.in-addr.arpa/'
    list server '/16.172.in-addr.arpa/'
    list server '/168.192.in-addr.arpa/'
    list server '/254.169.in-addr.arpa/'
    list server '/d.f.ip6.arpa/'
    # Upstream dnscrypt-proxy resolver to use for queries:
    list server '127.0.0.53'

Thanks

this not works for me (wrt32x). When i set the other ssid on radio 1 (phy#1) both ssid stop working

About offloading,

Well, on your builds "cat /proc/net/nf_conntrack | grep OFFLOAD" is not showing anything, but it does work in 19.07.1. Also if enabled there should be a firewall forward rule with the name "Traffic offloading"

Best Regards,

Are you saying that grepping OFFLOAD for that path is there for 19.07.1?