Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Just find this error in log: Please enable the extra option 'adb_report' to use the adblock reporting feature
Will investigate tomorrow.


Lede SNAPSHOT r9133-e906a75e67 / LuCI Master (git-19.025.11637-a0a78ba)

no visible cake, only Fq_codel

You can add the daily snapshot repository to LuCi and get the package you want that way. However, be sure to do it soon before the daily snapshots change with a kernel bump.

can you go in detail on how i do this?

Yes, i use it, works ok. The only issue i have is forced to re-create database (but maybe it's just my issue).

Hi guys, I'm fairly new to openwrt. I've had some wifi issues with my linksys 1900acs, I've made a thread Linksys wrt1900acs - wifi not associated but not much feedback there.
It's been running smoothly for 1 day and 22 hours, but before that my radio0 and radio1 lost association or something. A reboot of the router fixed it.
Since I don't like lose ends and not knowing why it fails and if it will fail again I ask you guys :slight_smile:
I'm running this firmware version: Lede SNAPSHOT r8810-09004e6e13 / LuCI Master (git-18.350.50885-91a73be)

If anyone has a problem with IOT products (smart plugs, smart lights, smart something...) like any ESP8266 device tuya,meross etc... just follow this steps

1)disable WMM on wifi 2.4ghz settings
2)connect and set static ip to the device
3)enable WMM again

@davidc502 could you also test it? I have a wrt3200acs don't know if it's working for wrt1900acs
if it's working, could you please add it to the FAQ? It will be really helpful for others.


Manual installation of tcpdump-mini and enabling DNS Query Report in Extra Options of Adblock did it. Strange that it was working by default in the previous build 9028 and whitout tcpdump-mini.

Please let me know on the next build or the one you go to next. If it still doesn't work without tcpdump-mini then that means something likely changed. I might need to add it to the build which would fix the issue. However, I don't know if the two (tcpdump and mini) play well together on the same build.

Since you've installed mini is it working okay with the regular tcpdump?

David - Just keep doing what you are doing. Most of us here are very thankful for that! Your builds work best on our WRT series devices and that's how most of us like it. Those that wish for a minimal build should download and install the "trunk" package which you can find from: https://openwrt.org/. For those new to this and who have taken the plunge and installed David's snapshot builds, time to learn how to dig-in. It's a lot easier that it looks. Trust me...

For those with requests to remove packages, this can be done from Systems > Software and then click the Remove button for the software package(s) you no longer want. *** Make sure you did your research, know what you are doing, and exactly what you are removing - you may render your router inoperable by removing the wrong package. ***

As for those with requests to add packages, you need to do this fairly soon after a fresh snapshot release so the build kernel is in synch with the package kernels, (otherwise you need to download the packages directly from the corresponding release directory). This can be done from Systems > Software, then click Update lists... (NOTE: if using Rosy as your interface, it needs to be the latest build or make sure you have already done an "opkg update" after logging in via SSH in the terminal/CLI, because the Rosy GUI to update package lists works after an initial update from the CLI). Then click the Available tab, search for your package of choice, and click the Install button. My recommendation to new folks is to do your research before installing anything so you are sure it is what you need and you know how to configure it properly. This is where forums like this and the OpenWRT wiki site are your friends...

To add packages directly from a terminal using SSH:

  • Logon using SSH (EG: ssh root@ or whatever your router IP address is)
  • Run opkg update once on the command line. This pulls a fresh list of available packages from the OpenWrt online software repositories.
  • Run opkg list to display a list of available packages (The list also has a very short comment on each package).
  • Run opkg list | grep 'searchterm' to filter the list, only showing packages that contain the word 'searchterm' in either the package name or comment.
  • Run opkg install packagename to install any package from that list.
  • Run opkg remove packagename to uninstall an installed package.

Lastly, have fun with it all.


For SQM users, we have to wait for the next build, since /usr/sbin/tc doesn't run without this patch. :cry:

Hey David, hope all is well. Just a side note, yes, tcpdump-mini is required now for the newer adblock, in order to use logging. I have seen it also in my last few builds. A message pops up in the log saying you need it for advanced logging. But what I also found is that just trying to pull any logs (to be able to add to white/black list) needs this. The logging tab seems to be useless without, even if you hit the refresh button.

Great information! Thanks for taking the time to share.

Actually, this has been fixed on the latest build :slight_smile:

I just took a moment to check, and the 2 do not play together as I suspected. Will uninstall tcpdump and install tcpdump-mini and take a look at the package.

root@lede:~# opkg install tcpdump-mini
Installing tcpdump-mini (4.9.2-1) to root...
Downloading https://davidc502sis.dynamic-dns.net/snapshots/r9133/packages/arm_cortex-a9_vfpv3/base/tcpdump-mini_4.9.2-1_arm_cortex-a9_vfpv3.ipk
Collected errors:
 * check_data_file_clashes: Package tcpdump-mini wants to install file /usr/sbin/tcpdump
	But that file is already provided by package  * tcpdump
 * opkg_install_cmd: Cannot install package tcpdump-mini.

I see no reason why the 2 can't be switched in the build. Next build will have tcpdump-mini.

I use tcpdump quite a bit at work, and just playing around with it, mini seems to do the same job, so I don't see a reason why it can't be what is included in the build.



Actually, I acknowledged that here: (NOTE: if using Rosy as your interface, it needs to be the latest build or...

Thanks for all you do brother. :wink:

1 Like

A little offtopic, but important to mention - if you host any domain name zone using WRT DNS server - check you Bind/Unbound version!
Others - check firewall settings (default is ok, but if you play with DNS filtering before - better disable it now). DNSCrypt users - keep calm and watch the show ^_^.

Details is here - https://dnsflagday.net/

I have sometimes DNS resolv issues on my clients, and I never figured out, why or whats causing it. Shouldnt this actually never happen, because dnsmasq should cache IPs once resolved? Is there a config I have to set, to enable this or to increase to time it wont retry resolving it?

I have set a bit more not default configuration, where all traffic is going through a OpenVPN connection, also the DNS traffic of the router:

iptables -w -A OUTPUT -t mangle -p tcp --dport 53 -j MARK --set-mark 2
iptables -w -A OUTPUT -t mangle -p udp --dport 53 -j MARK --set-mark 2

And I also use a ipset resolver to route specific traffic, for example twitch, not over the VPN:

list server '/twitch.tv/'
list server '/secure.twitch.tv/'
list server '/justin.tv/'
list server '/hls.ttvnw.net/'

The problem actually happens for example on a client when watching twitch.tv via VLC, and then randomly, the video closes. Looking into the VLC log, it says couldnt resolve host, which it does every 10 seconds or so over and over again because of the m3u8 file. When this happens, I found out, I have maybe a time out for DNS resolv of about 1-2 seconds globally on the laptop, and Chrome shows for example "waiting for cache".

I have tried +, which should give a backup if one doenst work or the other, but this doesnt help anything actually. Isnt dnsmasq smart enough to handle this? If one answeres in maybe 100ms try the other, if it doesnt answer, use cache?

Anything else I could try? Maybe go away from dnsmasq? What is the current bleeding edge solution for DNS on this ROM? dnscrypt-proxy2 isnt implemented by default so far, right? I actually had lots of problems in the past with dnscrypt-proxy because then randomly the dnsprocy server had timeouts, even with using 3 backup services running, it never worked properly.

I actually think for the VLC twitch dns issue, it sometimes happen like every 10 minutes or so. Found a comment about that dnsmasq uses a default value of --min-cache-ttl=600. Could this be related?

Hey Guys -

I use a David502c image (kernel 4.14.91) on my Linksys1900ACS and have a quick question, please...

I'm trying to install a package which after extraction requires moving a few of the files into specific paths. The only thing is, I don't have enough free space to do so despite having plenty of free space in /tmp. Is it possible to (easily) reallocate some of the free space between partitions or is there an alternate way to accomplish what I'm trying to do? Full details below...

The package I'm trying to install is the ARM version of Telegraf using the steps at this post. The 1900ACS has plenty of storage - it's the allocation of partitions that seems to be the issue.

When trying to simply download the file in my home path, I get a message that I'm out of free space. I checked the mount points and see the "overlayfs:/overlay" mounted to "/" has "10.99 MB / 12.21 MB" free. It seems all my free space resides in "tmpfs" mounted to "/tmp" with "180.29 MB / 249.47 MB" free. I was able to download and extract the file into "/tmp", but obviously can't move the files to the paths specified in the post.

If you have suggestions if possible to reallocate - or - know another package which can send the same info to InfluxDB, it would be a huge help. So far, it seems the only way to reallocate between partitions is to completely rebuild the image - which I'm hesitant to do as I've never done so before.


I apologize, I don't have a lot of time, so I'll answer quick to one point before I go, and it is about /tmp. You will noticed whatever you put into /tmp doesn't survive a reboot, and that is because /tmp is volatile. Meaning, whatever you put into tmpfs, goes directly into RAM. So, just a heads up there, and I'm guessing that might just answer your question about not having "enough free space despite having plenty in /tmp".

What is the size of the package? I'm thinking you should have 38MB free in / unless there are other packages installed besides what is on the base build.