Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1371

Now I'm confused. I didn't mention fast_path (it's in the thread name though), just the flow_offloading parameter in /etc/config/firewall. Is there a naming issue here?

I am on 4.14 with latest davidc502 release, but I'm getting the error about the xt_FLOWOFFLOAD module not being there?


#1373

I did not go to the thread to read, I just assumed a thread with that title was about ...

As to the actual point of your post (and my response), a quick perusal of the manifest for an image provided by this community release would indicate that flowoffload has been removed.


#1374

Hi i'm using r8810 for the last 24 hours.
maybe im repeating things people already reported so sorry if this the case .
i'm using wrt1200ac , i experienced the below :

1] not able to change wifi password
errors i see in logs (not related to above):

2]

Sat Jan 12 09:34:14 2019 kern.debug kernel: [  353.067014] ieee80211 phy1: change: 0x40
Sat Jan 12 09:34:15 2019 kern.debug kernel: [  353.237169] ieee80211 phy1: change: 0x40
Sat Jan 12 09:34:15 2019 kern.debug kernel: [  353.417338] ieee80211 phy1: change: 0x40
Sat Jan 12 09:34:15 2019 kern.debug kernel: [  353.597496] ieee80211 phy1: change: 0x40
3]Sat Jan 12 09:34:14 2019 daemon.notice hostapd: handle_probe_req: send failed
Sat Jan 12 09:34:14 2019 daemon.notice hostapd: handle_probe_req: send failed
Sat Jan 12 09:34:14 2019 daemon.notice hostapd: handle_probe_req: send failed
Sat Jan 12 09:34:14 2019 daemon.notice hostapd: handle_probe_req: send failed
Sat Jan 12 09:34:14 2019 daemon.notice hostapd: handle_probe_req: send failed

i'm reverting to the older build for now cause i really need to change wifi pass.


#1375

Actually in the earlier build i cant also change wifi password , changes does not persist and applied... someone has any clue ?


#1376

i changed it eventually in /etc/config/wireless ... through the UI it does not persists the changes.... also in the latest build...


#1377

Added issue for Update Lists in LuCi -


#1378

New builds have been uploaded to the site and are ready for download.

Kernel version = 4.14.91
WiFi driver = 10.3.8.0-20181210
Build = r9028

Please note the LuCi issue listed above. The work around is to run the 'opkg update' command from command line.


Which OpenWrt Package Feed to Use?
#1379

I was starting to be afraid something happened to you. Glad you came back with a release.

Sorry if i bother but there are any major difference, known problems compared to r8873?

PS: IOT smart plugs, light etc still has problems with WMM Mode enabled, i would recommend to add something like this to the FAQ:
"If you have a problem with smart plugs, light etc just make another 2.4ghz interface and disable WMM on that."

I will install right away the new build and report for any bug i'll found. Thanks for your work.


#1380

It's amusing, I too was a little concerned something happened to David. I'm running r9028 now on my WRT1900ACS. Thanks for the new build. I'm happy to use the updated adblock which now can provided statistics.


#1381

Thanks -- It was time for a vacation :wink:


#1382

#1383

I have been unable to complete an upgrade the past month or so, Upon flashing, the window just hangs and then goes back to the main screen without upgrading or rebooting. Any idea what's going on? Tried multiple downloads to ensure it wasn't a bad file. I read back a few pages and tried searching for similar problems but perhaps I am blind if there was a simple solution :D.

Thanks in advance.


#1384

As always, thanks for your great work and contribution.

I upgraded to r9028 from the command line from r8614. Upgrade went fine. However, when I try to run 'opkg update' I get errors such as:

* opkg_download: Failed to download https://davidc502sis.dynamic-dns.net/snapshots/r9028/targets/mvebu/cortexa9/packages/Packages.gz, wget returned 5.

If I check in Chrome, your LetsEncrypt certificate is valid.

Thanks for any insight.


#1385

I just had the same thing happen. The 2019-01-13 image SHA-128 was correct when verified via a utility. The image SHA-128 for the same file was NOT correct during the upgrade of the router. I advanced rebooted to my router the the alternate partition. This time the SHA-128 was correct when reported during the update and the upgrade to the 2019-01-13 image was a success.


#1386

Possibly related to all of this download failed / checksum failed madness, there's been several times where I've tried to download something with wget on the command line over HTTPS and have it bomb out (it was an IPK I was trying to grab). Ended up just SCPing the file over from my PC directly to OpenWrt and then install and sure enough, worked great.

I also had all of the pre-reqs installed for HTTPS such as the ca-certificates and ca-bundles at the time.. and it let me download it, but the size of the file did not entirely line up with the file I copied over locally with SCP and by association the checksum was also wrong (file was corrupted).

I don't think this is a problem with your build in particular, but something with OpenWrt and HTTPS is my theory. Thought I'd throw my $0.02 in here with my experiences so far, and best of luck nailing this annoying bug down.


#1387

5 is a SSL error. Make sure you have the SSL libraries needed for the connection. The build will have these by default. Were they removed?


#1388

I didn't intentionally remove any packages :slight_smile: I did run the dnsproxy2 script. For wget, it looks like all dependencies are installed:

root@Wrt3200acm:~# opkg list wget
wget - 1.20.1-1

root@Wrt3200acm:~# opkg list-installed |grep libopenssl
libopenssl - 1.0.2p-1

Same is true for other packages:
wget depends on:
libc
libpcre
zlib
libopenssl
librt

Thanks for any further insight.


#1389

HELP! I'm running r8873 on a WRT1900AC. I've been running David builds for roughly 1.5 years. Suddenly today I'm unable to to upgrade to the newest release as I am out of space on the router. I have no idea how that happened, or how to fix. Any suggestions? I run ZERO additional packages.. Just a straight David install..

//Brew

Mount%20Points%20-%20LuCI


#1390

Good news is you're not out of space. /rom always shows 100%

root@lede:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                15.0M     15.0M         0 100% /rom
tmpfs                   249.5M      5.1M    244.4M   2% /tmp
/dev/ubi0_1              45.8M      4.6M     38.9M  10% /overlay
overlayfs:/overlay       45.8M      4.6M     38.9M  10% /
ubi1:syscfg              70.2M    472.0K     66.1M   1% /tmp/syscfg
tmpfs                   512.0K         0    512.0K   0% /dev

What is the error message when trying to sysupgrade?


#1391

Well, that was strange...

/dev/ubi0_1 and overlayfs/overlay were both at 100%... I rebooted and they went to 30% (when I took the screen shot)... I got the BIN file copied and did the sysupgrade... It SEEMS ok for now!?