Daemon.notice netifd: radio1 (2219): WARNING: Variable 'data' does not exist or is not an array/object

Hi,

I can see an netifd error in my log but do not know which parameter is causing it. Does somebody know how to find out what is causing this instead of "try and error"?

Device Wax206

Cheers,
Nils

Sun Nov 19 12:19:54 2023 daemon.notice netifd: radio0 (2218): WARNING: Variable 'data' does not exist or is not an array/object
Sun Nov 19 12:19:54 2023 daemon.notice netifd: radio1 (2219): WARNING: Variable 'data' does not exist or is not an array/object

config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/18000000.wmac'
option cell_density '0'
option hwmode '11g'
option htmode 'HT40'
option channel 'auto'
option country 'DE'
option log_level '2'
option noscan '1'

config wifi-iface 'default_radio0'
option device 'radio1'
option network 'lan'
option mode 'ap'
option key '---'
option mobility_domain '0812'
option ft_psk_generate_local '1'
option ieee80211r '1'
option encryption 'psk2+ccmp'
option ssid 'I-Gate'
option ieee80211k '1'
option wnm_sleep_mode '1'
option bss_transition '1'
option time_advertisement '2'
option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
option pmk_r1_push '1'
option ft_over_ds '0'
option dtim_period '6'
option wpa_group_rekey '3600'
option max_inactivity '1200'
option disassoc_low_ack '0'
option proxy_arp '1'

config wifi-device 'radio1'
option type 'mac80211'
option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option band '5g'
option cell_density '0'
option country 'DE'
option log_level '2'
option htmode 'HE160'
option channel '100'
option disabled '0'
option he_su_beamformee '1'
option he_bss_color '8'

config wifi-iface 'default_radio1'
option device 'radio0'
option network 'lan'
option mode 'ap'
option key '---'
option ssid 'I-Gate'
option ieee80211k '1'
option wnm_sleep_mode '1'
option bss_transition '1'
option time_advertisement '2'
option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
option encryption 'psk2+ccmp'
option ft_psk_generate_local '1'
option mobility_domain '0812'
option ieee80211r '1'
option dtim_period '3'
option ft_over_ds '0'
option wpa_group_rekey '3600'
option max_inactivity '1200'
option disassoc_low_ack '0'
option proxy_arp '1'

config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option ssid 'I-Gate Gastzugang'
option encryption 'psk2'
option key '---!'
option network 'guest'
option wnm_sleep_mode '1'
option bss_transition '1'
option ieee80211k '1'
option dtim_period '6'
option wpa_group_rekey '3600'
option max_inactivity '1200'
option disassoc_low_ack '0'
option ieee80211r '1'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option proxy_arp '1'

config wifi-iface 'wifinet3'
option device 'radio0'
option mode 'ap'
option ssid 'I-Gate Gastzugang'
option encryption 'psk2+ccmp'
option key '---!'
option network 'guest'
option wnm_sleep_mode '1'
option bss_transition '1'
option ieee80211k '1'
option dtim_period '3'
option wpa_group_rekey '3600'
option max_inactivity '1200'
option ieee80211r '1'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option disassoc_low_ack '0'
option proxy_arp '1'

config wifi-iface 'wifinet4'
option device 'radio0'
option mode 'ap'
option ssid 'I-Gate IoT'
option encryption 'psk2'
option key '---'
option network 'iot'
option wps_pushbutton '1'
option time_advertisement '2'
option wnm_sleep_mode '1'
option bss_transition '1'
option ieee80211k '1'
option dtim_period '3'
option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
option proxy_arp '1'

config wifi-iface 'wifinet5'
option device 'radio1'
option mode 'ap'
option ssid 'I-Gate IoT'
option encryption 'psk2+ccmp'
option key '---'
option network 'iot'
option time_advertisement '2'
option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
option wnm_sleep_mode '1'
option bss_transition '1'
option ieee80211k '1'
option dtim_period '6'
option wps_pushbutton '1'
option proxy_arp '1'

Setup a complete new Wax206 and can see that it happens also for R7800 and NBG6817.

So created an issue: https://github.com/openwrt/openwrt/issues/14010

If somebody knows how to debug it to support the investigation it would be nice.

I have the same happening on an Archer AX23v1 since building a new image last month. I'll be building a new one tomorrow, sysupgrade a device and see, whether it persists.

Revision from ubus call system board is r24164-67ce60c5f9, image was built on Thu Oct 19 22:36:32 2023.

This has not been happening with the image built before, sysupgrade was performed from the one below to the one above.

Revision from ubus call system board is r23566-37ff916af7 , image was built on Fri Jul 14 11:34:34 2023

Mon Nov 20 16:56:08 2023 daemon.notice wpa_supplicant[1282]: Set new config for phy phy0
Mon Nov 20 16:56:08 2023 daemon.notice wpa_supplicant[1282]: Set new config for phy phy1
Mon Nov 20 16:56:08 2023 daemon.notice netifd: Wireless device 'radio0' is now down
Mon Nov 20 16:56:08 2023 daemon.notice netifd: Wireless device 'radio1' is now down
Mon Nov 20 16:56:08 2023 daemon.notice netifd: radio0 (11104): WARNING: Variable 'data' does not exist or is not an array/object
Mon Nov 20 16:56:08 2023 daemon.notice netifd: radio1 (11110): WARNING: Variable 'data' does not exist or is not an array/object
Mon Nov 20 16:56:08 2023 daemon.notice hostapd: Set new config for phy phy0:
Mon Nov 20 16:56:08 2023 daemon.notice wpa_supplicant[1282]: Set new config for phy phy0
Mon Nov 20 16:56:08 2023 daemon.notice hostapd: Set new config for phy phy1:
Mon Nov 20 16:56:08 2023 daemon.notice wpa_supplicant[1282]: Set new config for phy phy1
Mon Nov 20 16:56:09 2023 daemon.notice wpa_supplicant[1282]: Set new config for phy phy0
Mon Nov 20 16:56:09 2023 daemon.notice wpa_supplicant[1282]: Set new config for phy phy1
Mon Nov 20 16:56:09 2023 daemon.notice hostapd: Set new config for phy phy0: /var/run/hostapd-phy0.conf
Mon Nov 20 16:56:09 2023 daemon.notice hostapd: Restart interface for phy phy0

This happened when the wifi name and password were changed and the wifi restarted subsequently, as well as before, when the network was restarted.