Daemon.err odhcpd: Failed to send to ff02::1% (Permission denied)

Hello,
I get this error messages in OpenWrt's system log:
Sat May 14 14:40:05 2022 daemon.err odhcpd[1558]: Failed to send to ff02::1%dmz@lan4 (Permission denied)

For the affected interface DMZ the following firewall rules are applied:

config zone                                                                     
        option name 'dmz'                                                       
        list network 'dmz'              
        option log '1'                                                          
        option log_limit '10/second'                                            
        option forward 'REJECT'                                                 
        option input 'REJECT'                                                   
        option output 'REJECT'                    

config rule
        option name 'DMZ: Allow DHCP to router'
        option proto 'udp'
        option src 'dmz'
        option dest_port '67'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'DMZ: Allow DHCP renew from router'
        option proto 'udp'
        option dest 'dmz'
        option dest_port '68'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'DMZ: Allow DHCPv6 to router'
        option proto 'udp'
        option src 'dmz'
        option dest_port '547'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'DMZ: Allow DHCPv6 from router'
        option proto 'udp'
        option dest 'dmz'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

What is causing this issue?
And how can I fix this?

How about allowing some icmp6 for router advertisements?

1 Like

Are you talking about a rule like this?

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'dmz'
        option proto 'icmp'

If yes, how is this related to process daemon.err odhcpd that I would identify as DHCP?