Daemon.err odhcp6c: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

Hello!
I am using LEDE 17.01.2 on several TP-LINK routers (1043ND, WDR4900, Archer C7), is working fine,
but i can not get out of this error message: daemon.err odhcp6c[XXXX]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied). Probably is something related to IPv6 multicast adress but i do not know what to do to get off...
This is fill up systems log (about every 2 minutes):
Mon Jun 26 07:52:39 2017 daemon.err odhcp6c[2086]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Mon Jun 26 07:54:39 2017 daemon.err odhcp6c[2086]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Mon Jun 26 07:56:39 2017 daemon.err odhcp6c[2086]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Mon Jun 26 07:58:36 2017 daemon.err odhcp6c[2086]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Mon Jun 26 08:00:32 2017 daemon.err odhcp6c[2086]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

Thanks in advance!

I have the same issue. If the wan interface not not a bridge, everthing works fine.

Some how, in my case, was related to ddns-scripts and ddns-scripts_no-ip_com
I remove those packages and now that error message go away...

ff02::1:2 is a message sent to all DHCP servers and relay agents on the local network segment (defined in RFC 3315)
Probably a router on the network is not able to respond properly. Changing this is the best solution. An other solution is below.

A solution to get rid of the message is to remove IPV6 from the wan.
This is done by editing the /etc/config/network file. I use nano to do this.

# nano /etc/config/network

Then remove or commend out the following 3 lines:

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'

Restart the network after the editing the file:

'# /etc/init.d/network restart'

Then the message is gone.

1 Like

Disconnect wan6

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'
option auto '0'