D7800 Wan problem

hi hi ,
just received my new Netgear D7800 (NETGEAR-Nighthawk-X4S-D7800-100PES (dsl) "to be exact")
installed , openwrt-18.06.4-ipq806x-netgear_d7800-squashfs-factory.img from the web & openwrt-18.06.4-ipq806x-netgear_d7800-squashfs-sysupgrade.bin from luci web interface

after spending hours and many setup and reset i need some help to solve this .


my setup is like so,
connected to connected to
dlink(router)> >>>>>>>>>>switch to my room >>>>>>>>>> D7800

the dlink is connect to the isp via dsl, i have a switch in my room thats connected to the router.
and the d7800 is connected to the switch on the WAN port.

note that the dlink have dhcp on, and the switch is unmanaged. clients connected to the switch receives dhcp ips from the router (dlink)

i want the netgear D7800 to act as a "client" / AP mode.
in short ,
1,the WAN port does not get any dhcp ip from the router
2,there is no connection betwen the router and the d7800 even if i setup the interface eth1,eth0,eth0.2 with a static ip (with same subnet and local ip that the dlink router gives)
cant ping from the d7800 to the router, and cant ping the d7800 from the router/clients in the network
from the picture above u can see that the D7800 try to send pack (TX) but cant receive any (RX)


router gives dhcp ips 10.0.0.1-254.

i tried to restart the main router - did not work
i tried to setup a local ip - did not work
i tried to connect it directly to the router with out the switch in the middle - did not work

help would be helpfull.
thanks !

update,
i even revert back to latest firmware to make sure the wan port working and it does :slight_smile:

anyone ?

back to my problem, i went back from official firmware to openwrt firmware,updated the firmware from tftp.
and the wan port this dont work.
there is not packagets that goes through .

still need help with that.

I see the WAN is only linked at 100baseT. If the equipment on the other end is GbE compatible, that would indicate a cabling problem. Generally a 1000-1000 link may show some activity with the green lights but will not pass data at all if the cable is bad or does not have all 4 pairs connected.

When connecting to another router that serves DHCP in a range other than 192.168.1.0/24, it should Just Work to plug in with a default configuration. (That may not be the case connecting Ethernet to a router with built in DSL modem though).

Going back to stock firmware is a good way to rule out a hardware problem. If some port or feature that should work with stock firmware does not, it is not going to work with OpenWrt either.

i did rule out with stock firmware to check if something was not wrong with the hardware and it seems that their is no problem with that.
however fun fact (or idk how to configure the router properly)
on the stock firmware i tried to get internet from wan, which it work but it disable the wifi option when the WAN option is on , totaly brain fucked.

anyhow, so u telling me that if i plug the WAN port to a gigabit switch/port on the other end that will work right ?

btw the dhcp range of the main router is different from the netgear D7800 one. that wouldnt be a problem actualy.
but even tho, even if i changed the dhcp address so they match, it wont work.
notice that i change the WAN ip port to a static one. it yet received any data.