D7800 Jumbo Frames supported?

Hi there,

does anybody know if jumbo frames (i only need mini jumbo frames) are supported on the Netgear D7800?
Everything i tried to achive MTU 1508 for WAN doesn't work.


I think this might be related to a known stnmac driver bug which I understand is fixed in kernel 4.19+ (so should work with recent snapshot, but not 19.07.x or earlier) - see this thread for discussion. That thread mentions a possible workaround of forcing a large MTU (and how to implement it) which might help you if this is your problem.

Thanks for your link. I already tried it. I am on latest snapshot.
If i try to manually
ifconfig eth1 down; ifconfig eth1 mtu 4088; ifconfig eth1 up
or any other mtu, i get following error:
ifconfig: SIOCSIFMTU: Invalid argument

Hmm.. I don't think that thread is related at all now. I know that thread used ifconfig but the more modern command would be:
ip link set eth1 mtu 1508

I don't have my D7800 usable at the moment but I just tried this on an IPQ40xx device (GL-B1300, like R7800 & D7800 also has 2 CPU ports to switch so WAN is eth1) - with no interface down/up - and no errors were reported. The changed MTU was then reported when looking at the interface (ip address show) and I was then able to change it back without issue.

What else have you got tied to the WAN interface? (e.g. VLANs?). Also, do you actually have a live ethernet connection to the WAN (i.e. cable plugged into another network device such as a cable modem etc)?

yeah ifconfig or ip doesn‘t matter. the error is still the same.
Maybe you could try it on your d7800 sometimes.
There is a known issue, that the wan port on eth0 doesn‘t receive traffic if directly connected to a 100mbit modem.
So i am using vlans on eth1 to get a functional lan and wan.
Maybe this mtu problem is also related to the 100mbit problem.

As the d7800 is the my gateway router i only have limited time to experiment on this, so i tried the forum if someone can confirm that mtu 1508 on D7800 is working or not. Or maybe i have a configuration problem or maybe the vlans are not okey ... whatever :smiley:

On a freshly flashed D7800 where eth0 is wan :-

root@OpenWrt:~# ifconfig eth0 mtu 1508
ifconfig: SIOCSIFMTU: Resource busy
root@OpenWrt:~# ifconfig eth0 down
**root@OpenWrt:~# ifconfig eth0 mtu 1508**
**ifconfig: SIOCSIFMTU: Invalid argument**

But on eth1 :-

root@OpenWrt:~# ifconfig eth1 mtu 1508
ifconfig: SIOCSIFMTU: Resource busy
root@OpenWrt:~# ifconfig eth1.1 mtu 1508
ifconfig: SIOCSIFMTU: Result not representable
1 Like