D-Link router won't obtain IP

Hello guys..first forgive me if this is the wrong category but I'm really coming to my wit's end here..and no one at my ISP's call centers could help me because they know nothing about the complexity of Linux..I own a VDSL2 D-link 2877al router... recently that router won't obtain IP no matter what which causes the internet led light to remain red..I checked the logs and I noticed that error "unrecognized option nas8_2" which causes the whole PPPoe handshake process to exit and fail..I tried creating that interface manually via ssh using the 2684ctl command but that didn't work and I ended with another error ..maybe I'm doing it wrong? Any help would appreciated thanks in advance

Is this device running OpenWrt? If so, what version?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

What firmware version is the Dlink modem router running?

I didn't think there was any OpenWrt support for this device.

Go to for help?

Sadly no..it doesn't support openwrt..and I tried calling d-link support but they weren't so helpful either and they blamed it on my ISP..and my ISP blamed my router.. basically I'm a tennis ball between them each side blames the other one ..all I need to do is create a PTM interface manually so the DSL connection can communicate over it..for some reason the router won't do this process automatically instead keeps spamming this "unrecognized option nas8_2" message..also if u guys could suggest any openwrt capable VDSL2 router that'd be appreciated

Sorry, we can't help you with this either (unless there happens to be someone who is familiar with that exact device and error situation). This is the OpenWrt forums, so we don't have specialized knowledge about dlink's firmware and DSL configuration parameters.

Hopefully someone can recommend a good DSL modem with OpenWrt support (I only have experience with cable ISPs).

The "generic" advice I can give you, however, is to reset the router to the default config. The manualy should state how to do that.

I know this is openwrt forums and I know this might not be the right place but all I need to do is create a PTM interface utilizing the 2684ctl command..I hate Linux and I hate each time I have to deal with it's complexities that's why I need ur help guys.. basically all existing routers use Linux in their firmware so I thought u could help me creating a PTM interface manually via ssh

It is not that we are unwilling to help... we (well, I'll speak for myself -- I) just don't have the knowledge about that particular equipment and firmware and configuration.

I like to make the analogy -- you wouldn't expect a dermatologist to diagnose and create a neurology issue, would you? Yes, they're both medical doctors, but very different expertise and training.

Your OP indicates that it previously worked and if so it suggests a hardware problem. Do you have an older VSDL modem to try? Most router modem combo's can disable the modem so you can still use the D-Link as a just a router Also try changing out the RJ-11 cord. My old Cisco 678 had a loose solder connection at the RJ-11 jack.
My ADSL2 router has a Web configuration interface where I can change/interrogate the connection.
I think the ISP also should give you the connection provisions.

Other sources include ISP specific forums and D-Link forums.

Only certain 'old' Lantiq based xrx200 modem routers support DSL in OpenWrt.
And even fewer in above list support VDSL, and may have issues, such as wifi functionality not working in OpenWrt.

fwiw, you may want to consider buying a VDSL2 bridge modem (eg. old Netgear DM200 or TPlink TD-W9970 offer 'bridge' mode function) which is compatible with your ISP, and use any router with ethernet WAN port of your choice wired to the bridge modem.

1 Like

Why are you using shell commands instead of the web interface for the router.

Because the web interface doesn't let you create a network interface manually..the router should create an interface automatically when u input your ISP's username and password..but for some reason it don't...instead it tries to communicate over a non existent interface "nas8_2" ..I tried to create an interface manually using the br2684ctl command but I couldn't..that's why I created this topic but no one is willing to help despite seeing many topics about br2684ctl and ATM interfaces here in this forum