D-Link DSL-2730u Compiling for WiFi?

I run OpenWrt generic images on a couple of old DSL-2730u's I use as wired routers, the pictures in the wiki are mine:

https://openwrt.org/toh/d-link/dsl-2730u

But the WiFi (BCM4313) never worked. I had mentioned that in the wiki, but someone (user 'dejavu51') recently edited my statement to claim that wifi will work:

if you build kmod-brcmsmac driver from openwrt source with “Use firmware extracted from broadcom proprietary driver” disabled.

I tried following the instruction and building from source with said setting unchecked, but the driver refuses to work. If it can be made to work perhaps it can be added as an official build (sans DSL of course). I will be extremely happy to test any images or build any configs. Or any suggestions whatsoever.

The kernel says this with the claimed working driver:

[ 15.535055] brcmsmac bcma0:1: mfg 4bf core 812 rev 24 class 0 irq 31
[ 15.542493] ieee80211 phy0: wl0: brcms_b_attach: Unsupported Broadcom board type (0x4313) or revision level (0x0)
[ 15.553083] ieee80211 phy0: wl0: brcms_b_attach: failed with err 15
[ 15.559524] ieee80211 phy0: wl0: brcms_c_attach: failed with err 15
[ 15.565987] ieee80211 phy0: brcmsmac: attach() failed with code 15
[ 15.572329] brcmsmac: brcms_bcma_probe: brcms_attach failed!