D-Link DIR-882 installation problem

Entering recovery mode and installing factory.bin went without issue following the D-Link recovery gui method here https://openwrt.org/docs/guide-user/installation/installation_methods/d-link_recovery_gui.

But then on the wiki it says "The device will reboot automatically after the flashing process finishes" but for me it just keeps blinking yellow forever, it doesn't reboot. And if I manually restart it, it seems to reset to stock (web interface). I have tried ssh:ing into it while it is in that blinking state in order to install sysupgrade.bin but no luck accessing it.

Any pointers? Thanks!

do check the model it's important all DIR-882 are not the same so A1 or R1
and make sure you are using the correct one
if you have the A1 you can try this file in the normal web interface & sysupgrade to current version after
http://luckys.onmypc.net/openwrt/DIR-882/openwrt-21.02.2-ramips-mt7621-dlink_dir-882-a1-squashfs-factory-enc.bin

It is A1

What is that file?

as stated a file built to upload via the normal web interface
it has the dlink encryption added
the pull request has still waiting to added to openwrt it's only been 2 years give it time :slight_smile:

2 Likes

Thanks, that installation method worked!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.