D-link DIR-882 and VLAN speed only 100Mbps

I am having two routers (D-link DIR-882 and D-link DIR-878), both the same version of OpenWrt. DIR-882 is a master, DIR-878 is a slave dumb AP. I have 2 VLANs configured on a master (home VLAN 100 and IOT VLAN 25) mapped also to two wifi networks. Both routers are gigabit and are connected with cat5e ethernet cable.

Master
Model: D-link DIR-882 A1
Openwrt: 22.03.2 r19803-9a599fee93

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd54:3376:3a8e::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'br-lan.100'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option hostname '*'
	option peerdns '0'
	list dns '1.1.1.1'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config interface 'IOTnetwork'
	option proto 'static'
	option ipaddr '172.16.1.1'
	option netmask '255.255.255.0'
	option device 'br-lan.25'

config bridge-vlan
	option device 'br-lan'
	option vlan '25'
	list ports 'lan2:t'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '100'
	list ports 'lan1:u*'
	list ports 'lan2:t'
	list ports 'lan3:u*'

Mater router br-lan setting:

  • port 1 = home VLAN 100 ethernet
  • port 2 = tagged VLAN 25/100 connection to slave dumb AP
  • port 3 = home VLAN 100 ethernet
  • port 4 = untagged VLAN 25 ethernet

And the problem is - as you can see: ports 2 and 4 are only 100Mbps. I checked those cables very precisely and they are definitely ok (I know, the cable is always the problem, but looks here is not). When I change e.g. cables from port 1 to port 2, speed is the same (port 1 = 1Gbps, port 2 = 100Mbps) When I set port 4 to VLAN 100, the port is suddenly gigabit as e.g. port 1 (with the same cable). So ports in the router are also ok.

It looks that I have something wrong with my VLANs configuration, which is capping the speed to 100Mbps. This is annoying, because the dumb AP has only 100Mbps connection and wifi is then also limited to this speed.

Any idea what I am doing wrong?

When you did this, did you swap the equipment at the other end of the cable, too, or did you keep everything the same physically just simply changing the vlan?

What is the device that is connected to port 4 (brand, model)?

Same HW config, only changed VLAN. On port 4 is old notebook used as web server visible to internet - therefore it is in my IOT VLAN 25. Except tagged port 2 I have tested all ports and cables also on my notebook (ethtool).

I don’t see any reason why the vlan would affect the speed. Do you experience the same thing on port 2?

And have you verified that the other side of the link is actually dropping down to 100M? (Just to rule out the possibility this is really just a UI glitch or something)

Master router, changed port 4 to VLAN 100

Slave router, tagged connection is 100Mbps

I will try some more play with port 2 also.

What is the router (ap) connected to port 2 (brand and model)?

D-link DIR-878 with the same version of OpenWrt as master, configured as slave dumb AP.

Master router after changing port 1 with port 2 (to tagged connection to slave AP on port 1)

That helped. A lot. For me it is a magic. VLANs are now on 1Gbps. Same cables, same routers.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.