D-Link Dir-842 - can’t access firmware upload form

Due to frequent WLAN dropouts I want to flash a Dir-842 C2 to OpenWRT. Keeping the reset button pressed while powering it on results in the power LED blinking about once per second. I'm connected to the router in LAN 1 with my laptop but I cannot ping 192.168.0.1 nor access a webpage on that address. If I disconnect power and boot the router without pressing the reset button, the power LED stays on and I can access the regular start page of the router.

My firmware version now is 3.07TM but I just don't get the basic firmware upload form. How can I flash the router to OpenWRT?

is your PC network card configured with a static IP e.g. 192.168.0.2 ?

Yes. I have tried using Firefox and IE11 also same cant access firmware upload form.

try 192.168.0.10. see here

Tried but not working

make sure the subnet mask is set to 255.255.255.0

Yes. subnet mask is set to 255.255.255.0

Meanwhile, we did some further investigation on this, and it turns out the TM version of the firmware uses different encryption keys than the international ones used in https://github.com/openwrt/openwrt/pull/3109.

For the TM devices, it should be added:

  IMAGE/factory-TM.bin := $$(IMAGE/default) | pad-rootfs -x 64 | \
	seama | seama-seal $$(SEAMA_SIGNATURE)TM | check-size | \
	alpha_encimg $$(SEAMA_SIGNATURE)TM \
	resvq+8+7/gxmTjaYkZe0DGfprQCBkZl PrKJz6rdgAis1wZS

Thanks a lot to @faiz981219 for providing a firmware dump from a TM router! :slightly_smiling_face:

For those who want to flash their device from TM to OpenWrt v23.03.5, you can use this image with the OEM Web updater:
http://sebastianschaper.net/openwrt/openwrt-22.03.5-ath79-generic-dlink_dir-842-c2-squashfs-factory-TM_signed.bin

The unpacked TM firmware is here:
http://sebastianschaper.net/openwrt/DIR842TMC2_FW306TMb01_decrypted.bin

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.