D-Link Dir-615 rev D4 - Device name on main router

Evening all,

I'm expecting a D-Link Dir-615 from a friend which I am going to flash openwrt for him.
He was asking if its possible to rename the 615 as KidsRoom so that it shows up as that name in the main router. He'll be using the 615 as a Access Point/wireless Repeater.
Currently I have one 615 which shows as unknown on my main router when used as AP.

Is there anything I can modify so it shows the name KidsRoom?

Cheers

is it statically or dynamically assigned ip?

when you say "shows up" what are you referring to?

2 Likes

The hostname can be changed from here http://192.168.1.1/cgi-bin/luci/admin/system/system (presuming that 192.168.1.1. is the router's IP).

That's the hostname the device advertises, as far as OpenWrt on that device is concerned.

Whether the other device will use that hostname or not, that's a different story.

3 Likes

Thanks for the replies guys, I'll check it out tomorrow and then let you know how I get on.

In previous versions, the DHCP client would not inherit the device's global hostname. It was necessary to specify option hostname in the network configuration (The GUI has a box to do this). That of course lets you use a different name, or intentionally not send one.

@mk24
where exactly do you mean as I can't seem to find it ?

@mhegab I have tried your suggestion by but it not dispalying the name on my main router.

@wulfy23 The main router is seeing my Dlink as a wireless .adapter I think and when I say "shows up" I mean its displaying the name on the main router as "UNKNOWN".

What happens if you ping the hostname from any PC?

How do I do that ?

From a computer connected to the D-Link (and then you can also try the same from a computer connected to the main router) you pen a Command Line or a Terminal and type:

ping thehostnameyouhave

Its pinging to the hostname with 0 packets lost

I am using firmware if that makes any difference.

Blockquote LEDE Reboot 17.01.5 r3919-38e704be71 / LuCI lede-17.01 branch (git-18.180.55366-b78664c)

I'm assuming this is a routed client with a WiFi connection from the wan network to the main router. Some instructions have you create a new network "wwan" or similar but that isn't necessary, you can use the default wan just change it from wired to wireless.

Go to network-interfaces-(your WAN network), right below where DHCP Client is set there is a box to enter a hostname. This hostname should register in the main router when the wan gets its IP address.

Restart the network or just reboot to make sure that a new DHCP has been done, then from a machine on the main router's network, try to ping this hostname (pinging the router's own hostname from the LAN side is trivial, you've already done that). The main router may require a domain such as .lan or .local.

Once that works you can open firewall ports on your routed client to allow administration from the main network. Those would be port 80 (TCP) for http and port 22 (TCP) for SSH. By default OpenWrt blocks everything incoming to wan except pings.

This can mean various things... but for the sake of simplicity i'll assume you mean that in the main routers web interface under "clients" or similar.

If you had access to the main router /etc/hosts file or similar configuration setting, i'd recommend adding it there and making sure it's up is statically set. Alternatively see the dhcp hostname option mentioned above.

1 Like

When I goto network-interfaces I am getting this , I am unable to find the DHCP Client.


Click the edit button for WWAN.

If WWAN is set up as static IP you need to change it to DHCP Client for this to work. The main router won't ask for the client's hostname if it static IP.

2 Likes

@mk24 ; Your suggestion seems to have worked.

Thanks for that

@mk24

When I try to revert back to the "normal " setting of static address I can't seem to connect to the internet. (I don't know if its me but I feel using the DHCP Client is making the internet flow from this router slow.)
I have pressed switch protocol and then pressed save followed by save and apply, after setting to static ip but that gives me no Internet.

Please advise .

DHCP is only involved in the initial setup of the connection it won't reduce the speed.

After you click "really change" then you need to set up the static parameters, then save and apply that. Of course the settings you make have to match what the network requires.

1 Like

ok I'll leave it as it is then.Thanks for the help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.