D-link dir-615 c1 with luci-app-sqm

Hi everyone,
I have an old D-Link DIR-615-C1 that I have DD-WRT on and I would like to try and build LEDE with SQM for it. I have previously experimented with OpenWRT and did succeed in building an image with SQM that functioned but was not too stable. I would like to do a better job with LEDE project.

My question is on what packages to remove and add. For adding would it be enough to have +luci and +luci-app-sqm? For subtracting package management could be dropped -opkg and my ISP does not offer IPV6 so is there a catch all IPV6 meta name to subtract.

I know it's an old and under-powered router but maybe just maybe it will be transformed into Super Router!

Thanks in advance,


Flash with a stable release first in which one you will base your build (I do not recommend to play with trunk builds)...

do a opkg list-installed and save that list for yourself and investigate the dependencies (usually are very easy to see, (you need to create a list of not-needed packages as you described...

example on ChaosCalmer opkg list-installed:

base-files busybox dnsmasq dropbear firewall fstools hostapd-common ip6tables iptables iw jshn jsonfilter kernel kmod-ath kmod-ath9k kmod-ath9k-common kmod-cfg80211 kmod-crypto-aes kmod-crypto-arc4 kmod-crypto-core kmod-gpio-button-hotplug kmod-ip6tables kmod-ipt-conntrack kmod-ipt-core kmod-ipt-nat kmod-ipv6 kmod-ledtrig-usbdev kmod-lib-crc-ccitt kmod-mac80211 kmod-nf-conntrack kmod-nf-conntrack6 kmod-nf-ipt kmod-nf-ipt6 kmod-nf-nat kmod-nf-nathelper kmod-nls-base kmod-ppp kmod-pppoe kmod-pppox kmod-slhc kmod-usb-core kmod-usb2 libblobmsg-json libc libgcc libip4tc libip6tc libiwinfo libiwinfo-lua libjson-c libjson-script liblua libnl-tiny libubox libubus libubus-lua libuci libuci-lua libxtables lua luci luci-app-firewall luci-base luci-lib-ip luci-lib-nixio luci-mod-admin-full luci-proto-ipv6 luci-proto-ppp luci-theme-bootstrap mtd netifd odhcp6c odhcpd opkg ppp ppp-mod-pppoe procd rpcd swconfig uboot-envtools ubox ubus ubusd uci uhttpd uhttpd-mod-ubus usign wpad-mini

to add sqm you just build with "sqm-scripts" or if you want to have sqm config on luci, use "luci-app-sqm" (automagically will add the "sqm-scripts" dependency as stated on opkg info luci-app-sqm | grep Depends

example to remove IPv6 support and add SQM support you could build using:

make image PROFILE=XXXXXXXX PACKAGES="luci-app-sqm -ip6tables -kmod-ip6tables -kmod-ipv6 -kmod-nf-conntrack6 -kmod-nf-ipt6 -libip6tc -luci-proto-ipv6 -odhcp6c -odhcpd"

I've not tested it but I did the same once with ChaosCalmer and worked just fine.

Thanks very much for the replies and info - this will certainly help steer me in the right direction. I'm still on the DD-WRT firmware and will work now on setting up the image build software on my system - running openSUSE leap. Thanks again and I will report back.


All right, I used the Image builder with the following line of code:

~$ make image PROFILE=DIR615C1 PACKAGES="luci-app-sqm -opkg -ip6tables -kmod-ip6tables -kmod-ipv6 -kmod-nf-conntrack6 -kmod-nf-ipt6 -libip6tc -luci-proto-ipv6 -odhcp6c -odhcpd"

and I think it will work but I'm stuck at flashing the image on to the router. It's running DD-WRT right now and if I upload through the web interface it says upgrade successful and reboots to DD-wrt again - must trigger some backup failsafe. The other method is to trigger the failsafe firmware upgrade mode on the router by powering up the router while holding in the reset button - after around 15 seconds - the power light will flash amber on and off. Then with the network IPv4 address pointed to, subnet mask, DNS of and browser address of will take you to the upload screen. Upload firmware and I get message of "incorrect hardware ID image". I have tried using Firefox, Edge and Chrome. I have tried LEDE factory and sys upgrade, original D-Link firmware - all returns "incorrect hardware ID image".

If anyone has any suggestions on how to move forward?

If the firmware recovery page states wrong version, make sure you actually have the c1 model. D-link firmware should load. Then with the correct make/model, the factory .bin for your router from the Lede download page. After that you can use your own "cooked" sysupgrade versions.

On ddwrt forum they state that the HTTP stack in the c1 is misbehaving. They say that Firefox should work, were other browsers seem to fail. You could try with Firefox.


Thanks for the reply - Double checked, H/W version is C1 and original firmware was 3.11 N/A. I've tried Chrome, Firefox, IE11 and Edge - all return "incorrect hardware ID image" - maybe I'll try to get D-Link version 3.11 and see how that goes. I'm thinking, maybe this thing is quasi borked.

No luck with D-Link firmware 3.11NA. I'll try playing around using a hex editor.

SUCCESS! :grinning: Finally got 17.01.1 LEDE default for D-Link DIR-615C1 installed!

Found a website: https://wayneoutthere.com/flash-openwrt-dir-615-d-link-router/ that used curl to load the firmware.

Here are the steps I took:

  1. From my openSUSE drive, I set the network to static ip netmask Single cable from computer to one of the LAN ports on router.

  2. Put router into recovery mode. unplugged power to router. Press and hold reset while plugging back in power plug. After around 15sec, power light on router will flash amber.

  3. Open a terminal in the location where the LEDE firmware file that you want to upload.
    curl -0vF files=@lede-17.01.1-ar71xx-generic-dir-615-c1-squashfs-factory.bin
    (you can have this ready before hand) and press enter.

  4. Wait for and watch the router reboot.

  5. Reset the network back to DHCP.

  6. Browser to and LEDE initial setup.

So far everything works. All the LED's light properly. I tried right away to do a firmware sysupgrade with the custom image I generated but that was not successful so I had to redo everything over. I'm happy, for now, to get LEDE on the old DIR-615 running a 4.4 kernel just like my openSUSE Leap 42.2 :smiley: and work next on getting SQM properly built-in.

1 Like

OK, managed to update with sysupgrade.bin image with SQM that worked.

make image PROFILE=DIR615C1 PACKAGES="luci luci-app-sqm -opkg -ip6tables -kmod-ip6tables -kmod-ipv6 -kmod-nf-conntrack6 -kmod-nf-ipt6 -libip6tc -luci-proto-ipv6 -odhcp6c"

I added the luci and removed -odhcpd, maybe just having luci-app-sqm doesn't pull in all the required dependencies.

Now to play with SQM :grin:

What was the size of your image with these build parameters? My image size barely changes even when removing a lot of packages.

Sorry not using that router any more. DIR-615 is too small for LEDE - not stable at all.

Yea its not the best, got mine up and running though.

Steps works perfect in D-Link DIR-615C2, thanks