D-Link DIR-2660 rev A1 Not Working After Successful Upgrade

try the snapshot there is a change in the header it should work
if not
http://luckys.onmypc.net/openwrt/DIR-2660/DIR2660A1_FW104B03.bin

Thanks for your reply.
I have tried snapshot and also I Tried today after seeing one of your older post.
I’m not sure the exact file name.
After flashing I got other led on, but Further login page is not coming up on 192.168.1.1
Tried to ssh not working too.
I will give a try again the one you shared.
What could be the issue that further login page not coming up.

with snapshots luci isn't installed so no web page
you do that via ssh
but if you didn't get ssh well don't know
the one I shared is the OEM firmware decrypted just to get you back to stock
it should then update to the latest etc

I tried snapshot from repository that doesn’t work at all.
Only working firmware is from your old post, that doesn’t show any login page.
How can I go back to Dlink firmware again.
Anyway I will try all again and update here.
Thanks for your response.

here is a 21.02.1 with a modifier header
i have not tested it but if got the checksum wrong it won't upload
http://luckys.onmypc.net/Openwrt/DIR-2660/openwrt-21.02.1-ramips-mt7621-dlink_dir-2660-a1-squashfs-factory.bin
and again the dlink unencrypted firmware
http://luckys.onmypc.net/Openwrt/DIR-2660/DIR2660A1_FW104B03.bin

please note dlink's ip is 192.168.0.1 openwrt's is 192.168.1.1

Thanks for your response and community contribution.
I will try again and share the results.
I’m surprised why the supported version in download repository .bin files are not working.
There are no much forum posts on DIR-2660 openwrt installation attempts or have reported any issue.

The 2660 is still rather new from OpenWRT perspective.

So far three 2660 subvariants have popped up.
dir-2660 a2 (emergency recovery function requiring certain header bytes in flash factory file)
dir-2660 a1 (emergency recovery function ignoring header)
dir-2660 a1 variant 2 (a1 HW revision with emergency recovery code from a2)
Meaning: the vendor own recovery function which is squeezed in the boot partition of all 3 variants is not the same, the newer ones requiring certain headers bytes to be customized, while the oldest variant simply ignores those header bytes.
Since this recovery function in the device boot partition is the matter of choice to initially get OpenWRT onto the device, this is relevant for OpenWRT factory file creation.

D-Link has further added confusion, by assigning the same sales label to both variants of a1. Maybe variant 2 can be identified from the serial number, but so far no one has tried to pin down the sequence number as of when variant 2 rollout had started.

When this was found out, 21.02 was already in preparation, the relevant OpenWRT patch for the custom header bytes did not make it. So the 21.02.(0/1) release factory file for dir-2660 does not have the custom header bytes for the newer variants. The required patch although is contained in the snapshot for future release, e.g. 22.xx?

It's already in OpenWRT with this commit: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=2c9a07ed28e87bbe2d221d48aaa19b04672646a5

Have the 21.02.1 firmware up and running here. Works like a charm!

Could you please share the working one.
Or is it you are referring to current checked in into repository, if yes than I tried it doesn’t work.
If different from repository then pls share, I will give a try.
Thanks for your comments

The snapshot builds should work:

https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=ramips%2Fmt7621&id=dlink_dir-2660-a1

They have the headers set correctly:

Thanks for all, snapshot has worked.
The only trouble I see now is using USB 2.0 and USB 3.0
Tried installing packages relevant to network share and mounting point, got kernel incompatible. If USB 2 connected it shows present, but under mount it does not detect.
Right now I can’t use network share.
Any solution to this problem.

upgrade to new shapshot
the support file for snapshot images don't stay around long
so get the new one & try again

Thanks for your post,
Are you referring to DIR 2660 to upgrade, then please post the link for latest snapshot.
Currently DIR 2660 is on OpenWrt SNAPSHOT r18442-02de391b08 / LuCI firewall4 branch git-21.357.58153-63d9bcb
For DRA 1360 its on D-Link firmware, i'm afraid openwrt is not supported.

the snapshot imgaes are compled on a loop
I don't know how often maybe each day
but if you wait to long between getting the snapshot & trying to install it's packages
you will get "kernel incompatible" error cos they don't match anymore

so you get if from the same place as you did last time

I tried from this link
OpenWrt Firmware Selector

Should i download snapshot or sysupgrade.
Will snapshot overwrite all settings and configurations.
May be i need to backup or just install straight away.

https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/
I would sys upgrade

Thanks Lucky1,
I could connect DRA 1360 to DIR 2660.
But i'm facing new issue, wireless connected clients are getting very low internet speed.
With 1Gbs line, clients over wireless with speedtest shows only 20Mbs
After Snapshot upgrade i cannot access Luci web console nor i can update the packages

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

root@OpenWrt:~# ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
ping: sendto: Network unreachable

But wirelessly connected hosts are having internet access.

I would expect as a snapshot you would have to reinstall Luci
but that should work if the device has internet
my only guess is your setting may be stopping it somehow
so I would reset it try with default settings
but as snapshots are snapshots they don't always work as expected

the 2660 will never be able to saturate 1Gbs, the Mediatek hw is simply not that powerful. From a WiFi client over your 1360 repeater via MPS to the 2660 (probably in another room far away from the repeater) and from there on to the internet modem, probably with untuned WiFi paramters it will be even a lot less throughput.

I do not know, what your reference speed expectation is that you use for comparison to the 20Mbs, probably D-Link stock firmware.

If you happen to have tested WiFi n on OpenWRT on 2.4 Ghz on a crowded 20mhz channel of many neighbour WiFis, comparing it to stock D-Link mesh, 20Mbs throughput might be a reasonable outcome. Unlike the D-Link stock firmware, you will need to set WiFi parameters yourself and you will not get things like band steering or D-Link-like out of the box mesh autotuning functionality in OpenWRT.

Of course the snapshot image (which is a daily release beta firmware) may always contain unexpected bugs that could cause lower throughput, but so far the OpenWRT MT76xx drivers are quite stable and longterm proven.

Thanks Pico,
Probably I have to tune WiFi hard way to get reasonably good internet speed for clients at least not lagging for the speed I’m paying.
If I connect laptop to LAN port of main isp router , speed test shows between 800-900 Mbps.
I couldn’t get even half of the wired speed for WLAN clients.
What are more powerful HW available, so that upgrade could be considered.
You know these days work and schooling is behind these home routers. It looks like router is clogging.