D-link DIR-2660, OpenWrt 21.02.0-rc4, Guest wifi no internet connection

I have my dlink, working as an AP, connected to my pfSense and have it working fine, as per my post:
D-link DIR-2660 A1 no Switch/VLAN config page? - Installing and Using OpenWrt / Network and Wireless Configuration - OpenWrt Forum

What I want to try is to add a virtual Guest wifi using dhcp on the AP itself (instead of adding another vlan and have my pfSense serves dhcp, etc as I did with my other virtual ssids). I have followed the great instruction here

After following the setup, my phone can connect to the guest, get an IP; can't access internet.
I also try fixing the IP on my phone with manual dns 8.8.8.8, still no go. Need help...thanks.
image



image

image
image


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'xxxx:xxxx:dc9f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u'
	list ports 'lan3:u'
	list ports 'lan4:u'

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.8.254'
	option defaultroute '0'
	list dns '8.8.8.8'
	option gateway '192.168.8.1'

config bridge-vlan
	option device 'br-lan'
	option vlan '11'
	list ports 'lan1:t'

config interface 'bbc'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option device 'br-lan.11'
	option ipaddr '192.168.11.254'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '82'
	list ports 'lan1:t'

config interface 'iot'
	option proto 'static'
	option device 'br-lan.82'
	option ipaddr '192.168.82.254'
	option netmask '255.255.255.0'
	option gateway '192.168.82.1'

config interface 'bbc_wg'
	option proto 'wireguard'
	option private_key 'EOD6Dvt....Ch90Q='
	option listen_port '51820'
	list addresses '10.100.1.97/32'
	option auto '0'

config wireguard_bbc_wg
	option description 'bbc vpnunlimited'
	option public_key 'oJsl11....wS/bTgs='
	option preshared_key 'yylomM..B79hy4='
	list allowed_ips '0.0.0.0/0'
	option route_allowed_ips '1'
	option endpoint_host 'xx.150.xx.82'
	option endpoint_port '51820'
	option persistent_keepalive '25'

config interface 'guest'
	option proto 'static'
	option device 'wlan0-3'
	option ipaddr '192.168.99.254'
	option netmask '255.255.255.0'