D-Link DIR-2660 A1 Not uploading OpenWrt Build

I bought a D-link dir2660 recently and installed Openwrt on it with NO issues.
I have bought another D-Link DIR2660 and tried to install Openwrt with no success, each time it fails to upload the file after selection.
After further checking the 1st working Openwrt DIR2660 is HW Ver A2 and the one that keeps failing is HW Ver A1. Yet the Openwrt file below works fine on the A2

Model:D-Link DIR-2660 A1
Platform: ramips/mt7621
Version: 21.02.2 (r16495-bf0c965af0)

Also tried

No luck on both

Resolved by following the instructions from https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=b5dd746cbb1aaf91f4b68e9f3eda97413550d904 below


  • D-Link Recovery GUI: power down the router, press and hold the reset
    button, then re-plug it. Keep the reset button pressed until the power
    LED starts flashing orange, manually assign a static IP address under
    the 192.168.0.xxx subnet (e.g. and go to

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.